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1 Introduction 

Gsharp3 is an application for data presentation, which allows the users to design graphs interactively and display their 
data in 2D and 3D graphs. Gsharp is a modular application with powerful interactive graphing and easy layout. 

• This cookbook aims to explain to the users how Gsharp works and how the presentations through this application, 
are structured.  

• There are examples of how a graph is drawn in Chapter 2. The examples used will show the user how to produce a 
data presentation with Gsharp.  

• Chapters 3, 4, 5, and 6 contain four example datasets; and describe step-by-step how to visualize them respectively. 

This cookbook is written for users:  

• Who are new to using Gsharp. 
• Who want to visualize data using Gsharp. 

It is not intended to be a tutorial on Gsharp. 

1.1 Conventions Used 

• Underlined text denotes the title of a dialogue window. 
• Italic text is used to signify the name of a file or a command or a button, which can be selected. 
• The figures in Chapter 2 are preceded by the Roman numerals II, figures in Chapter 3 are preceded by III and so 

on. 
• All files used or created are stored in the current working directory. 

                                                           
3  http://www.avs.com/ 
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2 Drawing a Graph 

2.1 Creating a 2D Graph 

2.1.1 Specifying a Viewport 

• Select Viewport… from the Create drop-down menu (Figure II.1). 

 

Figure II-1: Creating a Viewport for 2D Graphs 
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• Use the left mouse button to draw a rectangle on the Canvas4 area (Figure II-2). 

 

Figure II-2: Defining a Viewport for 2D Graphs 

                                                           
4  Refer to Appendix A, Figure A-1, for descriptions of what the canvas is. 
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2.1.2  Selecting a Graph Type 

• Select Graph… from the Create drop-down menu (Figure II-3). 

 

Figure II-3: Selecting Graph Type 
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• The Graph Editor appears (Figure II-4). 

 

Figure II-4: Graph Editor 
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• Under Main of the Graph Editor, select Line from the Graph Type drop-down menu (Figure II-5). 

 

Figure II-5: Selecting Graph Type for 2D Graphs 
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2.1.3 Setting the Data Values 

• Select Data to set a value for Y Data. The 5 in the example is next to the Y so a value is to be set. (Figure II-6). 

 

Figure II-6: Graph Editor for 2D Graphs 

                                                           

5 The  next to some data resources signifies that a value is to be set. 
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• Next to the  in the box, there is the word “Unset” (Figure II-6). In the example, the value6 log(-10:10) is entered. 
The X values are set automatically7 (Figure II-7). 

 

Figure II-7: Setting a Y Value for 2D Graphs 

• Select OK and a line is drawn according to the entered values (Figure II-8). 

                                                           
6 (-10:10) is shorthand for –10, -9, -8, …, 10 
7 In the example, X takes a value when Y values are true. Since log(-10) to log(0) are undefined, no values are set for X. So for log(1), X will take 

the value of 12 because the previous values are undefined. 
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Figure II-8: An Example of a 2D Line Graph 
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2.1.4 Labelling the Axes 

• Double click with the left mouse button on the x-axis (Figure II-9) so that Axis Editor appears (Figure II-10). 

 

Figure II-9: X-Axis 
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Figure II-10: Axis Editor 
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• Select Text and enter in the box next to Text, X-AXIS, and set the Height to 5 (Figure II-11). 

 

Figure II-11: Writing Text for an X-Axis 

• Select OK and the result will be (Figure II-12). 
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Figure II-12: An Example of Labelling an X-Axis 
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• Double click with the left mouse button on the y-axis (Figure II-13) so that the Axis Editor appears (Figure II-14). 

 

Figure II-13: Y-Axis 
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Figure II-14: Axis Editor 
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• Select Text and next to the box of Text enter Y-AXIS. Also set Height to 5 (Figure II-15). 

 

Figure II-15: Setting Text for Y-Axis 

• Select OK and the result will be (Figure II-16). 
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Figure II-16: An Example of Labelling a Y-Axis 

Demetriou Alexandros Page 17 of 165 22 October 2002 
Manchester Visualization Centre 



Visualization Cookbook Using Gsharp 

2.1.5 Writing a Title 

• Select the viewport by clicking with the left mouse button in the graph (Figure II-17, Section 2.1.1). 

 

Figure II-17: Selecting Viewport to Write a Title for 2D Graphs 
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• Select Title… from the Create drop-down menu (Figure II-18). 

 

Figure II-18: Creating a Title for 2D Graphs 
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• The Title Editor appears and next to Text a name is written for the title. For this example log(-10:10) is written. 
Next set Height to 10 (Figure II-19). 

 

Figure II-19: Writing a Title for 2D Graphs 

• Select OK and the title is written above the graph8 (Figure II-20) 

                                                           
8 If necessary, drag the title with the left mouse button to position it. 
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Figure II-20: An Example of a Title for 2D Graphs 
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2.2 Creating a 3D Graph 

2.2.1  Specifying a Viewport 

• Select Viewport… from the Create drop-down menu (Figure II-21). 

 

Figure II-21: Creating a Viewport for 3D Graphs 
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• Use the left mouse button to draw a rectangle on the Canvas9 area (Figure II-22). 

 

Figure II-22: Defining a Viewport for 3D Graphs 

                                                           
9 Refer to Appendix A, Figure A-1, for descriptions of what the canvas is. 
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2.2.2 Selecting a Graph Type 

• Select Graph… from the Create drop-down menu (Figure II-23) so that the Graph Editor appears (Figure II-24). 

 

Figure II-23: Selecting Graph Type 
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Figure II-24: Graph Editor 
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• Under Main of the Graph Editor, select 3D Line from the Graph Type drop-down menu. (Figure II-25). 

 

Figure II-25: Selecting 3D Line Graph 
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2.2.3 Setting Data Values 

• Select Data to set a value for X, Y and Z values. The 10 in the example is next to the X, Y and Z values so values 
are to be entered (Figure II-26). 

 

Figure II-26: Graph Editor for 3D Graphs 

• Next to the  in the boxes, there is the word “Unset” (Figure II-26). Here a value is entered for the 3D line graph. 
In this example the values11 (1:10) for X, 1/(1:10) for Y, and (-10:10) for Z are entered (Figure II-27). 

                                                           

10 The  next to some data resources signifies that a value is to be set for those resources. 
11 (1:10) is shorthand for 1,2,3, …,10; 1/(1:10) is shorthand to 1/1,1/2,1/3, …,1/10; and (-10,10) is shorthand to –10,-9,-8, …,10. 
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Figure II-27: Setting Values for 3D Graphs 

• Select OK and a 3D line graph is drawn according to the entered values (Figure II-28). 
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Figure II-28: An Example of a 3D Line Graph 
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3 Displaying Temperature Inside a Room 

This chapter describes how the temperature flows inside a room. 

The values given are x, y, z and t from a data file called block.dat12. t is the value for the temperature at locations given 
by coordinates x, y and z. The task is to visualize the distribution of temperature in the room. For example, if in the 
centre of the room the colour of the temperature is blue then this part of the room is cold. The data is irregular (the 
location of each point is given explicitly) and the coordinates are located on a regular grid (the points are arranged in 
planes perpendicular to the coordinate axes). 

3.1 Choosing the Best Graph 

Notice that there is no functionality within GSharp menus/data manager to automatically create a 3D block or a variable 
such as unique x. This means there is no tag or a button that sets automatically variables or creating a 3D block. 

                                                           
12  Courtesy of John Stringer, AVS UK. Refer to Appendix B, Figures B-1 and B-2 for descriptions of the file. 
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• Select Open… from the File drop-down menu. Import block.dat file into Gsharp (Figure III-1). 

 

Figure III-1: Opening a File 

• The result will be (Figure III-2). 
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Figure III-2: Result of Opening block.dat 
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3.1.1 2D Contour for z=1 

The task is to visualize all values of Z (10 values) within the block.dat file. To do that a 3D block is to be created using 
2D contours of each slice (Z values) of the block. 

• Type BlockX = unique(x); in command line13 (Figure III-3)14. 

 

Figure III-3: Writing Commands in Command Line 

• Press enter so that the command is processed. 

                                                           
13  Refer to Appendix A, Figure A-1, for descriptions of what the command line is. 
14  This command is entered in order to get the unique values (not the repeated) of x. 
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• Type BlockY=unique(y); in command line (Figure III-3) and press enter15. 
• Type BlockZ=unique(z); in command line (Figure III-3) and press enter16. 
• Type Block=reshape(t,size(BlockX),size(BlockY),size(BlockZ)); in command line (Figure III-3) and press enter17. 
• Type Classes=range(t, 10) and press enter (Figure III-3)18. 
• Select Viewport… from the Create drop-down menu (Section 2.1.1). 
• Select Graph… from the Create drop-down menu (Section 2.1.2). 
• Select 2D Contour for Graph Type (Section 2.1.2)19. 

                                                           
15  This command is entered in order to get the unique values (not the repeated) of y. 
16  This command is entered in order to get the unique values (not the repeated) of z. 
17  This command is entered in order to get a new block of 10 (BlockX) by 10 (BlockY) by 10 (BlockZ) with range t. 
18  This command is entered in order to get 10 different classes of colour for the t value. 
19  Refer to Appendix B, Figure B-3 to see how the dataset is managed and if the dataset is set correctly in the Data Editor. 
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• In Data, set X to be BlockX, Y to be BlockY and Color Grid to be Block[,,1] (Figure III-4)20. 

 

Figure III-4: Setting Values for 2D Contour 

• Select OK and the result will be (Figure III-5). 

                                                           
20  That means the plane is set to z=1. 
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Figure III-5: Result of 2D Contour for z=1 
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• Select Domain… from the Edit drop-down menu (Figure III-6). 

 

Figure III-6: Editing the Domain 
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• In the Domain Editor select Classes and set Num Values to 10 (Figure III-7)21. 

 

Figure III-7: Changing the Classes Value 

• Select ClassEditor…, (Figure III-7) and the Class Editor appears (Figure III-8). 

                                                           
21  This gives 10 different colours to the graph. 
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• Set Mode to Min/Max22, the Type to Limits23, Minimum to 324 and Maximum to 11.125 (Figure III-8). 

 

Figure III-8: Class Editor 

• Select OK and return to Domain Editor (Figure III-9). 

                                                           
22  To set minimum and maximum values to the colours. 
23  There are two options here, percentiles and limits. Limits are to be set because the temperature is between 3 and 11.1 values. Other values are not 

needed. 
24  3 is the minimum value of t in the file. 
25  11.1 is the maximum value of t in the file. 
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• In the Domain Editor set Classes Dataset to Classes (Figure III-9). 

 

Figure III-9: Changing Classes Dataset 

• Select OK and the result will be (Figure III-10). 
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Figure III-10: Result After Changing Colour Classes 
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• Select Legend… from the Edit drop-down menu (Figure III-11). 

 

Figure III-11: Editing the Legend 
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• In the Legend Editor select Text and set Entry Height to be 7 (Figure III-12)26. 

 

Figure III-12: Editing Entry Height 

• Select Controls (Figure III-13). 

                                                           
26  The legend is more readable when setting Entry Height to 7 than other values. 
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• Set Enabled to On (Figure III-13). 

 

Figure III-13: Enable the Legend 

• Select OK and the result will be (Figure III-14). 
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Figure III-14: Result With a Legend 

This result (Figure III-14) is the plane of z=1. The Legend27 shows the value of the corresponding colour in the graph in 
each x, y dimension. 

                                                           
27 The Legend will require positioning to provide a result similar to Figure III-14. 
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3.1.2 2D Contour for z=2 

• Select Graph… from the Edit drop-down menu (Figure III-15). 

 

Figure III-15: Editing Graph 

• In Data of Graph Editor set Color Grid to be Block[,,2] (Section 3.1.1, Figure III-4). 
• Select OK and the result will be (Figure III-16). 
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Figure III-16: Result of 2D Contour for z=2 

This result (Figure III-16) is the plane of z=2. 
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3.1.3 2D Contour for z=3 

• Select Graph… from the Edit drop-down menu (Section 3.1.2, Figure III-15). 
• In Data of Graph Editor set Color Grid to be Block[,,3] (Section 3.1.1, Figure III-4). 
• Select OK and the result will be (Figure III-17). 

 

Figure III-17: Result of 2D Contour for z=3 

This graph (Figure III-17) is the plane of z=3. 
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3.1.4 2D Contour for z=4 

• Select Graph… from the Edit drop-down menu (Section 3.1.2, Figure III-15). 
• In Data of Graph Editor set Color Grid to be Block[,,4] (Section 3.1.1, Figure III-4). 
• Select OK and the result will be (Figure III-18). 

 

Figure III-18: Result of 2D Contour for z=4 

This graph (Figure III-18) is the plane of z=4. 
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3.1.5 2D Contour for z=5 

• Select Graph… from the Edit drop-down menu (Section 3.1.2, Figure III-15). 
• In Data of Graph Editor set Color Grid to be Block[,,5] (Section 3.1.1, Figure III-4). 
• Select OK and the result will be (Figure III-19). 

 

Figure III-19: Result of 2D Contour for z=5 

This graph (Figure III-19) is the plane of z=5. 
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3.1.6 2D Contour for z=6 

• Select Graph… from the Edit drop-down menu (Section 3.1.2, Figure III-15). 
• In Data of Graph Editor set Color Grid to be Block[,,6] (Section 3.1.1, Figure III-4). 
• Select OK and the result will be (Figure III-20). 

 

Figure III-20: Result of 2D Contour for z=6 

This graph (Figure III-20) is the plane of z=6. 
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3.1.7 2D Contour for z=7 

• Select Graph… from the Edit drop-down menu (Section 3.1.2, Figure III-15). 
• In Data of Graph Editor set Color Grid to be Block[,,7] (Section 3.1.1, Figure III-4). 
• Select OK and the result will be (Figure III-21). 

 

Figure III-21: Result of 2D Contour for z=7 

This graph (Figure III-21) is the plane of z=7. 
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3.1.8 2D Contour for z=8 

• Select Graph… from the Edit drop-down menu (Section 3.1.2, Figure III-15). 
• In Data of Graph Editor set Color Grid to be Block[,,8] (Section 3.1.1, Figure III-4). 
• Select OK and the result will be (Figure III-22). 

 

Figure III-22: Result of 2D Contour for z=8 

This graph (Figure III-22) is the plane of z=8. 
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3.1.9 2D Contour for z=9 

• Select Graph… from the Edit drop-down menu (Section 3.1.2, Figure III-15). 
• In Data of Graph Editor set Color Grid to be Block[,,9] (Section 3.1.1, Figure III-4). 
• Select OK and the result will be (Figure III-23). 

 

Figure III-23: Result of 2D Contour for z=9 

This graph (Figure III-23) is the plane of z=9. 
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3.1.10 2D Contour for z=10 

• Select Graph… from the Edit drop-down menu Section (3.1.2, Figure III-15). 
• In Data of Graph Editor set Color Grid to be Block[,,10] (Section 3.1.1, Figure III-4). 
• Select OK and the result will be (Figure III-24). 

 

Figure III-24: Result of 2D Contour for z=10 

This graph (Figure III-24) is the plane of z=10. 
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The conclusion from those 10 graphs is that they give a very good visualization as each plane shows the different 
temperatures in the room. The blue colour represents the coldest temperature in the room and the yellow colour the 
hottest temperature in the room. 
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3.1.11 2D Contour in 3D Style 

A graph will be drawn to show the previous 2D graphs in a 3D style, i.e. the 10 planes combined into a 3D graph. 

1. Select Open… from the File drop-down menu. Import block.dat (Section 3.1, Figure III-1). 
2. Type BlockX=unique(x); in command line28 (Figure III-3)29 and press enter so that the command will be processed. 
3. Type BlockY=unique(y); in command line (Figure III-3)30 and press enter. 
4. Type BlockZ=unique(z); in command line (Figure III-3)31 and press enter. 
5. Type Block=reshape(t,size(BlockX),size(BlockY),size(BlockZ)); in command line (Figure III-3) and press enter32. 
6. Type Classes=range(t,10) and press enter (Figure III-3)33. 
7. Select Viewport… from the Create drop-down menu (Section 2.1.1). 

                                                           
28  Refer to Appendix A, Figure A-1, for descriptions of what the command line is. 
29  This command is entered in order to get the unique values (not the repeated) of x. 
30  This command is entered in order to get the unique values (not the repeated) of y. 
31  This command is entered in order to get the unique values (not the repeated) of z. 
32  The reshape command is entered in order to get a new block of 10 (BlockX) by 10 (BlockY) by 10 (BlockZ) with range t. 
33  The range command arranges the colours according to the t value. 
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8. Select Domain… from the Create drop-down menu (Figure III-25). 

 

Figure III-25: Creating Domain 

9. Select OK and the result will be (Figure III-26). 
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Figure III-26: Result of Creating Domain 

10. Select Domain… from the Edit drop-down menu (Section 3.1.1, Figure III-6). 
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11. In the Domain Editor select X Limits and set X Minimum to 1 and X Maximum to 10 (Figure III-27)34. 

 

Figure III-27: Editing X Limits 

12. Select Y Limits (Figure III-28). 

                                                           
34  To give the correct limits to the x-axis. 
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13. Set Y Minimum to 1 and Y Maximum to 10 (Figure III-28). 

 

Figure III-28: Editing Y Limits 

14. Select Projections (Figure III-29). 
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15. Set 3D Plane to On35, Location to Inside and Level to 0 (Figure III-29)36. 

 

Figure III-29: Editing Projections 

16. Select Style (Figure III-30). 

                                                           
35  This will draw the domain in a 3D way. 
36  This will set the location of the domain inside the viewport. 
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17. Set X Data Type to Continuous37 (Figure III-30). 

 

Figure III-30: Editing Style 

18. Select Classes and set Num Values to 10 (Section 3.1.1, Figure III-7). 
19. Select ClassEditor… and the Class Editor appear. Here set Mode to Min/Max,38 the Type to Limits,39 Minimum to 3 

and Maximum to 11.1 (Section 3.1.1, Figure III-8). 
20. Select OK and then set Classes Dataset to Classes (Section 3.1.1, Figure III-9). 

                                                           
37  This will make sure that the values will be correctly set to the axis. 
38  To set minimum and maximum values to the colours. 
39  There are two options here, percentiles and limits. Limits are to be set because the temperature is between 3 and 11.1 values. Other values are not 

needed. 

Demetriou Alexandros Page 63 of 165 22 October 2002 
Manchester Visualization Centre 



Visualization Cookbook Using Gsharp 

21. Select OK and the result will be (Figure III-31). 

 

Figure III-31: Result of 1st Domain 
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22. Select Viewport… from the Edit drop-down menu (Figure III-32). 

 

Figure III-32: Editing Viewport 
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23. In Viewport Editor select 3D Workbox. Set Angle in XY Plane to 245, Elevation Plane to 10.292 and Distance 
Factor to 10 (Figure III-33)40. 

 

Figure III-33: Editing Values in 3D Workbox 

24. Select OK. 

                                                           
40  All these values are selected to give a better view to the graph. 
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25. Select Graph… from the Create drop-down menu (Section 2.1.2). 
26. Select 2D Contour for Graph Type (Section 2.1.2). 
27. In Data set BlockX for X, BlockY for Y and Block[,,1] for Color Grid (Section 3.1.1, Figure III-4). 
28. Select OK and the result will be (Figure III-34). 

 

Figure III-34: Result of 1st Block 
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• To produce the remaining graphs in a 3D style, repeat steps 841 – 21 followed by steps 25 - 28 for each graph, i.e. 
the second graph for the 2nd Block, the third graph for the 3rd Block, …, the tenth graph for the 10th Block. Use the 
following settings while creating those graphs: 

o In Projections of Domain Editor, set Level for the 2nd Block to 0.1111111, for the 3rd Block to 0.2222222, for 
the 4th Block to 0.3333333 and so on. 

o In Data of Graph Editor, set Color Grid for the 2nd Block to Block[,,2], for the 3rd Block to Block[,,3], for the 
4th Block to Block[,,4] and so on. 

• The final result will be Figure III-35. 

 

Figure III-35: Result When Visualizing the Dataset in 3D way 

                                                           
41  The viewport must be selected before repeating step 8. 
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• Select Legend… from the Edit drop-down menu (Figure III-11). 
• In the Legend Editor select Text and set Entry Height to be 7 (Figure III-12). 
• Select Controls and set Enabled to On (Figure III-13). 
• Select OK and the result will be (Figure III-36). 

 

Figure III-36: Result of 3D Block With Legend 
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Figure III-36 shows the temperature of the room. Each plane represents the room height (z). The Figure illustrates a 
method for visualizing 2D graphs in a 3D style. The Legend shows the temperature for each graph, where the blue 
colour represents the coldest temperature and the light yellow the hottest temperature. 
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4 Visualizing Behaviour of a Superconductor 

This chapter describes the visualization of the behaviour of a superconductor. The visualization shows the critical 
current, the angle and the temperature. 

The task is to visualize the behaviour of the superconductor in each point of critical current (Jc), against each angle (phi, 
theta). 

The values given are T(Kelvin), B(Tesla), Theta, Phi, Jc(A/m2), dv/di criterion, Smoothed Jc, Actual Theta and actual 
phi (the values needed for the task are Theta, Phi, and Jc(A/m2)) from 10 files42 which are: 

• 02-07-33,Sep-07.txt contains the following variables: 

1. T1 represents T(Kelvin) that is the temperature values. 
2. T2 represents B(Tesla) that is magnetic field values. 
3. Theta that is angle values. 
4. phi that is angle values. 
5. T3 represents Jc(A/m2) that is the maximum current values. 
6. T4 represents dv/di criterion. 
7. T5 represents Smoothed Jc. 
8. T6 represents Actual Theta. 
9. T7 represents actual phi. 

• 01-23-29,Sep-07.txt 

02-07-33,Sep-07.txt is imported first. The variables, in the files that follow, will not have the same name of the file in 
Gsharp. The same will happen with the names of this file against the next file and so on. 

1. T8 represents T(Kelvin). 
2. T9 represents B(Tesla) that is magnetic field values. 
3. T10 represents Theta that is angle values. 
4. T11 represents phi that is angle values 
5. T12 represents Jc(A/m2) that is the maximum current values. 
6. T13 represents dv/di criterion. 
7. T14 represents Smoothed Jc. 
8. T15 represents Actual Theta. 
9. T16 represents actual phi. 

                                                           
42  Courtesy of John Durrell, University of Cambridge. Refer to Appendix C, Figures C-1 and C-2 for description of the file. 
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• 00-39-33,Sep-07.txt 
• 20-00-22,Sep-06.txt 
• 20-45-45,Sep-06.txt 
• 21-33-38,Sep-06.txt 
• 22-19-18,Sep-06.txt 
• 23-06-59,Sep-06.txt 
• 23-54-13,Sep-06.txt 
• phi-90.txt 
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4.1 Choosing the Best Graph 

The data will be visualized in 2D. A scatter graph will best show the pattern of the visualization. 

Each of the 10 data files will be imported individually. 

• Define a viewport (Section 2.1.1). 
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4.1.1 Scatter Graph for 02-07-33,Sep-07.txt 

• Select Open… from the File drop-down menu to import a file (Figure IV-1). 

 

Figure IV-1: Importing Files 

• Select Graph… from the Create drop-down menu (Section 2.1.2, Figure II-3). 

Demetriou Alexandros Page 74 of 165 22 October 2002 
Manchester Visualization Centre 



Visualization Cookbook Using Gsharp 

• In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure II-5). 
• In Data set X to be Theta, Y to be T3 (Figure IV-2). 

 

Figure IV-2: Setting Data Values for Scatter 
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• Select Markers and set Symbol to  and Color to Blue (Figure IV-3). 

 

Figure IV-3: Setting Markers 

• Select OK and the result will be (Figure IV-4). 
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Figure IV-4: Result of 02-07-33,Sep-07.txt File 
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• Double click with the left mouse button on the x-axis (Section 2.1.4, Figure II-9) so that Axis Editor appears 
(Section 2.14, Figure II-10). 

• Select Text and enter in the box next to Text, Theta, and set the Height to 5 (Section 2.1.4, Figure II-11). 
• Select OK and the result will be (Figure IV-5). 

 

Figure IV-5: Labelling the X-Axis 
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• Double click with the left mouse button on the y-axis (Section 2.1.4, Figure II-13) so that Axis Editor appears 
(Section 2.14, Figure II-14). 

• Select Text and enter in the box next to Text, Jc (A/m2), and set the Height to 5 (Section 2.1.4, Figure II-15). 
• Select OK and the result will be (Figure IV-6). 

 

Figure IV-6: Labelling the Y-Axis 
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4.1.2 Scatter Graph for 01-23-29,Sep-07.txt 

• Select Open… from the File drop-down menu to import the 01-23-29,Sep-07.txt file (Section 4.1.1, Figure IV-1). 
• Select the previous graph43. 
• In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure II-5). 
• In Data set X to be T10, Y to be T12 (Section 4.1.1, Figure IV-2). 
• Select Markers and set Symbol to  and Color to Green (Section 4.1.1, Figure IV-3). 
• Select OK and the result will be (Figure IV-7). 

 

Figure IV-7: Result of 01-23-29,Sep-07.txt File 

                                                           
43  This graph is must be selected in order to visualize the next graph. This must be done for all of the graphs. 
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4.1.3 Scatter Graph for 00-39-33,Sep-07.txt 

• Select Open… from the File drop-down menu to import the 00-39-33,Sep-07.txt file (Section 4.1.1, Figure IV-1). 
• Select the previous graph 
• In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure II-5). 
• In Data set X to be T19, Y to be T21 (Section 4.1.1, Figure IV-2). 
• Select Markers and set Symbol to  and Color to Red (Section 4.1.1, Figure IV-3). 
• Select OK and the result will be (Figure IV-8). 

 

Figure IV-8: Result of 00-39-33,Sep-07.txt File 
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4.1.4 Scatter Graph for 20-00-22,Sep-06.txt 

• Select Open… from the File drop-down menu to import the 20-00-22,Sep-06.txt file (Section 4.1.1, Figure IV-1). 
• Select the previous graph 
• In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure II-5). 
• In Data set X to be T28, Y to be T30 (Section 4.1.1, Figure IV-2). 
• Select Markers and set Symbol to  and Color to Turquoise (Section 4.1.1, Figure IV-3). 
• Select OK and the result will be (Figure IV-9). 

 

Figure IV-9: Result of 20-00-22,Sep-06.txt File 
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4.1.5 Scatter Graph for 20-45-45,Sep-06.txt 

• Select Open… from the File drop-down menu to import the 20-45-45,Sep-06.txt file (Section 4.1.1, Figure IV-1). 
• Select the previous graph 
• In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure II-5). 
• In Data set X to be T37, Y to be T39 (Section 4.1.1, Figure IV-2). 

• Select Markers and set Symbol to  and Color to Orange (Section 4.1.1, Figure IV-3). 
• Select OK and the result will be (Figure IV-10). 

 

Figure IV-10: Result of 20-45-45,Sep-06.txt File 
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4.1.6 Scatter Graph for 21-33-38,Sep-06.txt 

• Select Open… from the File drop-down menu to import the 21-33-38,Sept-06.txt file (Section 4.1.1, Figure IV-1). 
• Select the previous graph 
• In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure II-5). 
• In Data set X to be T46, Y to be T48 (Section 4.1.1, Figure IV-2). 
• Select Markers and set Symbol to  and Color to Yellow (Section 4.1.1, Figure IV-3). 
• Select OK and the result will be (Figure IV-11). 

 

Figure IV-11: Result of 21-33-38,Sep-06.txt File 
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4.1.7 Scatter Graph for 22-19-18,Sep-06.txt 

• Select Open… from the File drop-down menu to import the 22-19-18,Sep-06.txt file (Section 4.1.1, Figure IV-1). 
• Select the previous graph 
• In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure II-5). 
• In Data set X to be T55, Y to be T57 (Section 4.1.1, Figure IV-2). 
• Select Markers and set Symbol to  and Color to Purple (Section 4.1.1, Figure IV-3). 
• Select OK and the result will be (Figure IV-12). 

 

Figure IV-12: Result of 22-19-18,Sep-06.txt File 
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4.1.8 Scatter Graph for 23-06-59,Sep-06.txt 

• Select Open… from the File drop-down menu to import the 23-06-59,Sep-06.txt file (Section 4.1.1, Figure IV-1). 
• Select the previous graph 
• In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure II-5). 
• In Data set X to be T64, Y to be T66 (Section 4.1.1, Figure IV-2). 

• Select Markers and set Symbol to  and Color to Brown (Section 4.1.1, Figure IV-3). 
• Select OK and the result will be (Figure IV-13). 

 

Figure IV-13: Result of 23-06-59,Sep-06.txt File 
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4.1.9 Scatter Graph for 23-54-13,Sep-06.txt 

• Select Open… from the File drop-down menu to import the 23-54-13,Sep-06.txt file (Section 4.1.1, Figure IV-1). 
• Select the previous graph 
• In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure II-5). 
• In Data set X to be T73, Y to be T75 (Section 4.1.1, Figure IV-2). 
• Select Markers and set Symbol to  and Color to Dark Green (Section 4.1.1, Figure IV-3). 
• Select OK and the result will be (Figure IV-14). 

 

Figure IV-14: Result of 23-54-13,Sep-06.txt File 
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4.1.10 Scatter Graph for phi-90.txt 

• Select Open… from the File drop-down menu to import the phi-90.txt file (Section 4.1.1, Figure IV-1). 
• Select the previous graph 
• In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure II-5). 
• In Data set X to be T82, Y to be T84 (Section 4.1.1, Figure IV-2). 
• Select Markers and set Symbol to  and Color to Dark Blue (Section 4.1.1, Figure IV-3). 
• Select OK and the result will be (Figure IV-15). 

 

Figure IV-15: Result of phi-90.txt File 
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• Select Legend… from the Edit drop-down menu (Figure IV-16). 

 

Figure IV-16: Editing a Legend 
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• In Legend Editor set Entry Height to be 6 (Figure IV-17). 

 

Figure IV-17: Setting Entry Height 
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• Select Controls and set Enabled to On (Figure IV-18). 

 

Figure IV-18: Enable the Legend 

• Select OK and the result will be (Figure IV-19). 
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Figure IV-19: Result of a Legend 
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4.1.11 3D Scatter Graph 

A 3D scatter graph will be drawn so that the previous 10 scatter graphs will be visualized in 3D style. 

1. Select Open… from the File drop-down menu to import the 02-07-33,Sep-07.txt (Section 4.1.1, Figure IV-1). 
2. In Graph Editor select 3D Scatter for Graph Type (Section 2.1.2, Figure II-5). 
3. Select Data and set X to be Theta, Y to be T3 and Z to be Phi (Section 2.2.3 Figure II-28). 
4. Select Markers, set Color to Blue (Section 4.1.1 Figure IV-3). 
5. Select OK and the result will be (Figure IV-20). 
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Figure IV-20: Result of 3D Scatter for 02-07-33,Sep-07.txt File 
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• Repeat steps 1-5 in Section 4.1.11 using the data files and colour settings listed in Sections 4.1.1 to 4.1.10 
inclusive. The values for X, Y and Z for each graph should correspond to the Theta, Jc(A/m2) and phi values in the 
data files44 (Section 4). The final result will be (Figure IV-21). 

 

Figure IV-21: Final Graph of 3D Scatter 

                                                           
44 For example in 01-23-29,Sep-07.txt file the values to be entered are T10 (Theta) for X, T12 (Jc(A/m2)) for Y, and T11 (phi) for Z. The colour of the 

graph will be green. 
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5 Showing Percentiles of a Value Over 10 Days 

In this chapter percentiles over a period of 10 days are visualized. The file percs.dat45 contains 10 values (p3, p5, p10, 
p25, p50, p75, p90, p95, p97, x). Each value of p contains percentile data for each day x (24 May 2002 to 02 June 
2002). 

The task is to visualize how the percentiles vary through the 10 days. 

5.1 Choosing the Best Graph 

First the data will be visualized in 2D. A scatter graph will best show the pattern of the visualization. 

                                                           
45  Courtesy of John Stringer, AVS UK. Refer to Appendix D, Figures D-1 and D-2, for descriptions of the file. 
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5.1.1 2D Scatter Graph 

1. Import percs.dat file by selecting Open… from the File drop-down menu (Figure V-1). 

 

Figure V-1: Importing File 

2. Define a viewport (Section 2.1.1). 
3. Select Graph… from the Create drop-down menu (Section 2.1.2, Figure II-3). 
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4. In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure II-5). 
5. Select Data and set X to x and Y to p3 (Figure V-2). 

 

Figure V-2: Setting Data Values 

6. Select OK and the result will be (Figure V-3)46. 

                                                           
46  To remove June, double click on the x-axis, the Axis Editor will appear. Select Labels, select Level 2 and the Level 2 Labels window will appear, 

set Enabled to Off. Select OK on the Level 2 Labels window and select OK on the Axis Editor. June will now be removed from the x-axis. To 
remove 2002 from the x-axis repeat the steps above but select Level 3 instead. 
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Figure V-3: Result for Variable p3 
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7. Repeat steps 3 to 647 but change Y48 to p5 for the second graph, Y to p10 for the third graph until Y to p97 for ninth 
graph. The result will be (Figure V-4). 

 

Figure V-4: Final Result of Scatter Graph 

                                                           
47  The previous graph must be selected before repeating steps 3-6. 
48  The value of Y is determined by the column headings in the percs.dat file. For example, the value of Y for the second graph corresponds to the 

value of the second column heading in the percs.dat file (Appendix D, Figures D-1 and D-2). 
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8. Select Legend… from the Edit drop-down menu (Figure V-5). 

 

Figure V-5: Editing Legend 
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9. In the Legend Editor select Text and set Entry Height to 6 (Figure V-6). 

 

Figure V-6: Setting Entry Height 
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10. Select Controls and set Enabled to On (Figure V-7). 

 

Figure V-7: Enable Legend 

11. Select OK and the result will be (Figure V-8). 
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Figure V-8: Graph With Legend 

12. Double click with the left mouse button on the y-axis (Section 2.1.4, Figure II-13) so that the Axis Editor appears 
(Section 2.1.4, Figure II-14). 

13. Select Text and next to the box of Text enter Percentiles. Also set Height to 5 (Section 2.1.4, Figure II-15). 
14. Select OK and the result will be (Figure V-9). 
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Figure V-9: Labelling the Y-Axis 

The graph above shows percentiles over a period of ten days. The symbols show the values of the percentiles (p3, p5, 
p10, p25, p50, p75, p90, p95, p97) on each day, from 24 May 2002 to 2 June 2002. 
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5.1.2 2D Bar Graph 

The dataset will be visualized using a bar graph so a clearer image of the percentiles over the time period can be 
obtained. 

1. Import percs.dat file by selecting Open… from the File drop-down menu (Figure V-1). 
2. Define a viewport (Section 2.1.1). 
3. In Graph Editor select Bar for Graph Type (Section 2.1.2, Figure II-5). 
4. Select Data and set X to x and Y to p97 (Section 5.1.1, Figure V-2). 
5. Select OK and the graph will be (Figure V-10). 
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Figure V-10: Result for Variable p97 
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6. Repeat steps 3 to 549 but change Y50 to p95 for the second graph, Y to p90 for the third graph until Y to p3 for ninth 
graph. The result will be (Figure V-11). 

 

Figure V-11: Final Result of Bar Graph 

                                                           
49  The previous graph must be selected before repeating steps 3-5. 
50  The value of Y is determined by the column headings in the percs.dat file (Appendix D, Figures D-1 and D-2). 
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7. Double click with the left mouse button on the y-axis (Section 2.1.4, Figure II-13) so that the Axis Editor appears 
(Section 2.1.4, Figure II-14). 

8. Select Text and next to the box of Text enter Percentiles. Also set Height to 5 (Section 2.1.4, Figure II-15). 
9. Select OK and the result will be (Figure V-12). 

 

Figure V-12: Labelling the Y-Axis 
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10. Double click with the left mouse button on the x-axis (Section 2.1.4, Figure II-13) so that the Axis Editor appears 
(Section 2.1.4, Figure II-14). 

11. Select Text and next to the box of Text enter Date. Also set Height to 5 (Section 2.1.4, Figure II-15). 
12. Select OK and the result will be (Figure V-13). 

 

Figure V-13: Labelling the X-Axis 

13. Select Legend… from the Edit drop-down menu (Section 5.1.1, Figure V-5). 
14. In the Legend Editor select Text and set Entry Height to 6 (Section 5.1.1, Figure V-6). 
15. Select Controls and set Enabled to On (Section 5.1.1, Figure V-7). 
16. Select OK and the graph will be (Figure V-14). 
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Figure V-14: Graph with Legend 

This graph shows the percentiles for each day in a bar chart. Each percentile is represented by a different colour so the 
percentile change can be compared between dates. 
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5.1.3 2D Area Graph 

The dataset will be visualized displaying the percentiles using a 2D Area graph. 

1. Import percs.dat file by selecting Open… from the File drop-down menu (Figure V-1). 
2. Define a viewport (Section 2.1.1). 
3. In Graph Editor select Area for Graph Type (Section 2.1.2, Figure II-5). 
4. Select Data and set X to x and Y to p97 (Section 5.1.1, Figure V-2). 
5. Select OK and the graph will be (Figure V-15). 

 

Figure V-15: Result for variable p97 
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6. Repeat steps 3 to 551 but change Y52 to p95 for the second graph, Y to p90 for the third graph until Y to p3 for ninth 
graph. The result will be (Figure V-16). 

 

Figure V-16: Result Area 

                                                           
51  The previous graph must be selected before repeating steps 3-5. 
52  The value of Y is determined by the column headings in the percs.dat file (Appendix D, Figures D-1 and D-2). 
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7. Double click with the left mouse button on the y-axis (Section 2.1.4, Figure II-13) so that the Axis Editor appears 
(Section 2.1.4, Figure II-14). 

8. Select Text and next to the box of Text enter Percentiles. Also set Height to 5 (Section 2.1.4, Figure II-15). 
9. Select OK and the result will be (Figure V-17). 

 

Figure V-17: Labelling the Y-Axis 
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10. Double click with the left mouse button on the x-axis (Section 2.1.4, Figure II-13) so that the Axis Editor appears 
(Section 2.1.4, Figure II-14). 

11. Select Text and next to the box of Text enter Date. Also set Height to 5 (Section 2.1.4, Figure II-15). 
12. Select OK and the result will be (Figure V-18). 

 

Figure V-18: Labelling the X-Axis 

13. Select Legend… from the Edit drop-down menu (Section 5.1.1, Figure V-5). 
14. In the Legend Editor select Text and set Entry Height to 6 (Section 5.1.1, Figure V-6). 
15. Select Controls and set Enabled to On (Section 5.1.1, Figure V-7). 
16. Select OK and the graph will be (Figure V-19). 
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Figure V-19: Graph with Legend 
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5.1.4 Box Plot 

The dataset will be visualized showing the percentiles as a box plot. 

1. Import percs.dat file by selecting Open… from the File drop-down menu (Figure V-1). 
2. Define a viewport (Section 2.1.1). 
3. In Graph Editor select Line Bar for Graph Type (Section 2.1.2, Figure II-5). 
4. Select Data and set X to x, Y to p97 and Y Base to p3 (Figure V-20). 

 

Figure V-20: Graph Editor 

5. Select Chart from the Graph Editor (Figure V-21). 
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Figure V-21: Chart 

6. Set Bar Ends to be 4 (Figure V-22). 
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Figure V-22: Bar Ends 

7. Select OK and the result will be (Figure V-23). 
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Figure V-23: Maximum and Minimum Values 

8. In Graph Editor select Bar for Graph Type (Section 2.1.2, Figure II-5). 
9. Select Data and set X to x, Y to p75 and Y Base to p25 (Figure V-20). 
10. Select Chart and set Color to White (Figure V-24). 
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Figure V-24: Color 

11. Select OK and the graph will be (Figure V-25). 
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Figure V-25: Lower and Upper Quartiles 

12. In Graph Editor select Line Bar for Graph Type (Section 2.1.2, Figure II-5). 
13. Select Data and set X to x, Y to p50 and Y Base to p50 (Figure V-20). 
14. Select Chart from the Graph Editor, set Bar Ends to be 4 (Figure V-21). 
15. Set Color to Black (Figure V-24). 
16. Select OK and the graph will be (Figure V-26). 
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Figure V-26: Mean Values 

17. Double click with the left mouse button on the y-axis (Section 2.1.4, Figure II-13) so that the Axis Editor appears 
(Section 2.1.4, Figure II-14). 

18. Select Text and next to the box of Text enter Percentiles. Also set Height to 5 (Section 2.1.4, Figure II-15). 
19. Select OK and the result will be (Figure V-27). 
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Figure V-27: Labelling the Y-Axis 

20. Double click with the left mouse button on the x-axis (Section 2.1.4, Figure II-13) so that the Axis Editor appears 
(Section 2.1.4, Figure II-14). 

21. Select Text and next to the box of Text enter Date. Also set Height to 5 (Section 2.1.4, Figure II-15). 
22. Select OK and the result will be (Figure V-28). 
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Figure V-28: Labelling the X-Axis 
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6 Viewing Percentage of Longitude and Latitude Points 

In this chapter the task is to visualize the various percentages in each point of longitude and latitude over the UK. 

The file scores.dat53 contains four variables, which are x, y, t1 and t2. x represents the latitude over UK, y represents the 
longitude over UK and t1, t2 are the percentage values for each point. 

                                                           
53  Courtesy of John Stringer, AVS UK. Refer to Appendix E, Figures E-1 and E-2, for descriptions of the file. 
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6.1 Choosing the Best Graph 

1. Select Open… from the File drop-down menu to import a file (Figure VI-1). 

 

Figure VI-1: Importing File 

2. Define a viewport (Section 2.1.1). 
3. Select Graph… from the Create drop-down menu (Section 2.1.2, Figure II-3). 
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6.1.1 2D Scatter Graph for t1 

In this section, 2 scatter graphs will be visualized - one for each percentage values (one graph for t1 and one for t2). 
This will show the pattern of the final graph. 

4. In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure II-5). 
5. Select Data and set X to x, Y to y and Color to t1 (Figure VI-2). 

 

Figure VI-2: Setting Data Values 

6. Select OK and the result will be (Figure VI-3). 
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Figure VI-3: Final Graph for Variable t1 
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7. Select Legend… from the Edit drop-down menu (Figure VI-4). 

 

Figure VI-4: Editing the Legend 

Demetriou Alexandros Page 130 of 165 22 October 2002 
Manchester Visualization Centre 



Visualization Cookbook Using Gsharp 

8. In the Legend Editor select Text and set Entry Height to 6 (Figure VI-5). 

 

Figure VI-5: Setting Entry Height 
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9. Select Controls and set Enabled to On (Figure VI-6). 

 

Figure VI-6: Enable the Legend 

10. Select OK and the result will be (Figure VI-7). 
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Figure VI-7: Result With Legend 

11. Double click on the y-axis and the Axis Editor will appear (Figure VI-8). 
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Figure VI-8: Axis Editor 

12. In the Axis Editor select Text and set Text to Latitude and Height to 5 (Figure VI-9). 
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Figure VI-9: Setting Text for the Y-Axis 

13. Select OK and the result will be (Figure VI-10). 
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Figure VI-10: Result of the Y-Axis 

14. Repeat steps 11-13 for the x-axis. The only thing to be changed is to set Text to Longitude. Select OK and the result 
will be (Figure VI-11). 
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Figure VI-11: Result of the X-Axis 
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6.1.2 2D Scatter Graph for t2 

This section contains the second 2D scatter graph which is going to show the visualization of the t2 percentage value. 

1. Change page by selecting this icon  in the icon toolbar54. 
2. Repeat steps 1-14 from Sections 6.1 and 6.1.1 but when setting data values set Colour to t2. The result will be 

(Figure VI-12). 

 

Figure VI-12: Result of Percentage Value t2 

                                                           
54  Refer to Appendix A, Figure A-1 for where the icon toolbar is and Figure A-2 for a description of the icon. 
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6.1.3 3D Scatter Graph for t1 and t2 

This section shows how to produce a 3D graph displaying both the t1 and t2 datasets. 

1. Select Open… from the File drop-down menu to import the scores.dat file (Section 6.1, Figure VI-1). 
2. Define a viewport (Section 2.1.1). 
3. Select Graph… from the Create drop-down menu (Section 2.1.2, Figure II-3). 
4. In Graph Editor select 3D Scatter for Graph Type (Section 2.1.2, Figure II-5). 
5. Select Data and set X to x, Y to y and Color to t1 (Section 6.1.1, Figure VI-2). 

6. Select Markers and set Symbol to  and Color to Red (Section 4.1.1, Figure IV-3). 
7. Select OK and the result will be (Figure VI-13). 

 

Figure VI-13: 3D Scatter Graph for t1 
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8. Repeat steps 3-755, but when setting data values set Colour to t2 and select Markers and set Color to Blue. The 
result will be (Figure VI-14). 

 

Figure VI-14: 3D Scatter Graph for t1 and t2 

                                                           
55  The previous graph must be selected before repeating steps 3-7. 
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6.1.4 3D Irregular Bar Graph for t1 and t2 

Continuing from Section 6.1.3, this section shows how to produce a 3D Irregular Bar graph displaying both the t1 and 
t2 datasets on the same set of axes as the 3D Scatter Graph. 

1. Select Graph…56 from the Create drop-down menu (Section 2.1.2, Figure II-3). 
2. In Graph Editor select 3D Irregular Bar for Graph Type (Section 2.1.2, Figure II-5). 
3. Select Data and set X to x, Y to y and Color to t1 (Section 6.1.1, Figure VI-2). 
4. Select Chart from the Graph Editor and set Bar Frame Color to Red (Figure VI-15). 

 

Figure VI-15: Bar Frame Color 

5. Select OK and the result will be (Figure VI-16). 

                                                           
56  The previous graph must be selected 
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Figure VI-16: 3D Irregular Bar for t1 

6. Repeat steps 1-557, but when setting data values set Colour to t2 and set Bar Frame Color to Blue. The result will 
be (Figure VI-17). 

                                                           
57  The previous graph must be selected before repeating steps 1-5. 
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Figure VI-17: 3D Irregular Bar for t1 and t2 
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6.1.5 3D Irregular Grid for t1 and t2 

This section shows how to produce a 3D Irregular Grid for both the t1 and t2 datasets. 

1. Select Open… from the File drop-down menu to import the scores.dat file (Section 6.1, Figure VI-1). 
2. Define a viewport (Section 2.1.1). 
3. Select Graph… from the Create drop-down menu (Section 2.1.2, Figure II-3). 
4. In Graph Editor select 3D Irregular Grid for Graph Type (Section 2.1.2, Figure II-5). 
5. Select Data and set X to x, Y to y and Z to t1 (Section 6.1.1, Figure VI-2). 
6. Select OK and the result will be (Figure VI-18). 

 

Figure VI-18: 3D Irregular Grid for t1 
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7. Repeat steps 1-6, but when setting data values set Y to t2. The result will be (Figure VI-19). 

 

Figure VI-19: 3D Irregular Grid for t2 
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6.1.6 Visualizing scores.dat on the same axes as uk.dat 

This section shows how to visualize scores.dat using 3D Irregular Grid to show the percentage of longitude and latitude 
points with an Area graph of the UK on the same axes. 

1. Select Open… from the File drop-down menu to import the uk.dat file (Section 6.1, Figure VI-1). 
2. Define a viewport (Section 2.1.1). 
3. Select Graph… from the Create drop-down menu (Section 2.1.2, Figure II-3). 
4. In Graph Editor select Area for Graph Type (Section 2.1.2, Figure II-5). 
5. Select Data and set X to Long and Y to Lat (Section 6.1.1, Figure VI-2). 
6. Select OK and the result will be (Figure VI-20). 

 

Figure VI-20: UK Area Graph 
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7. Select Open… from the File drop-down menu to import the scores.dat file (Section 6.1, Figure VI-1). 
8. Select Graph…58 from the Create drop-down menu (Section 2.1.2, Figure II-3). 
9. In Graph Editor select 3D Irregular Grid for Graph Type (Section 2.1.2, Figure II-5). 
10. Select Data and set X to x, Y to y and Z to t1 (Section 6.1.1, Figure VI-2). 
11. Select Grid Cells from Graph Editor and set Num X Cells to 30, Num Y Cells to 30 and Width to 0 (Figure VI-21). 

 

Figure VI-21: Grid Cells 

12. Select OK and the result will be (Figure VI-22). 

                                                           
58  The viewport must be selected. 
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Figure VI-22: Area Graph for uk.dat and 3D Irregular Grid for scores.dat 

13. Select the Viewport (Figure VI-23). 
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Figure VI-23: Selecting Viewport 

14. Select the  button from the icon toolbar59 and use the left mouse button to drag the graph to produce a better 
view of the graph. The result will be (Figure VI-24). 

                                                           
59  Refer to Appendix A, Figure A-1, for where the icon toolbar is; and Figure A-2 for a description of the icon. 
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Figure VI-24: Result of Rotating the Graph 
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Appendix A: Gsharp Window 

Figure A-1 shows the Gsharp window. 
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Figure A-1: Gsharp Window 
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Figure A-2 shows the icons of Gsharp and description of each icon. 

Icon Description 

 
Open 

 
Save 

 
Print 

 
Data Manager 

 
Hierarchy Browser 

 
Script Builder 

 
Object Editor 

 
Shade Editor 

 
Line Editor 

 
Text Editor 

 
Rotate 

 
Copy Clipboard 

 
Repaint 

 
Stop 
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Icon Description 

 
Page 

 
Viewport 

 
Domain 

 
Graph 

 
Title 

 
Note 

 
Arrow 

 
Logo 

 
Select 

Figure A-2: Icons Descriptions 
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Appendix B: File Block.dat 

Figure B-1 shows the description of the first 41 lines of the block.dat file. The first line contains the title. 

x   y   z   t 
1   1   1   3 
2   1   1   3.5 
3   1   1   4.33333333333333 
4   1   1   5.25 
5   1   1   6.2 
6   1   1   7.16666666666667 
7   1   1   8.14285714285714 
8   1   1   9.125 
9   1   1   10.1111111111111 
10  1   1   11.1 
1   2   1   3.5 
2   2   1   3.5 
3   2   1   3.83333333333333 
4   2   1   4.25 
5   2   1   4.7 
6   2   1   5.16666666666667 
7   2   1   5.64285714285714 
8   2   1   6.125 
9   2   1   6.61111111111111 
10  2   1   7.1 
1   3   1   4.33333333333333 
2   3   1   4.16666666666667 
3   3   1   4.33333333333333 
4   3   1   4.58333333333333 
5   3   1   4.86666666666667 
6   3   1   5.16666666666667 
7   3   1   5.47619047619048 
8   3   1   5.79166666666667 
9   3   1   6.11111111111111 
10  3   1   6.43333333333333 
1   4   1   5.25 
2   4   1   5 
3   4   1   5.08333333333333 
4   4   1   5.25 
5   4   1   5.45 
6   4   1   5.66666666666667 
7   4   1   5.89285714285714 
8   4   1   6.125 
9   4   1   6.36111111111111 

... 

... 

Figure B-1: First 40 Lines of the File 
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Figure B-2 shows the description of the last lines of the block.dat file 

... 

... 
1   7   10  10.8428571428571 
2   7   10  5.98571428571429 
3   7   10  4.46190476190476 
4   7   10  3.77142857142857 
5   7   10  3.41428571428571 
6   7   10  3.22380952380952 
7   7   10  3.12857142857143 
8   7   10  3.09285714285714 
9   7   10  3.0968253968254 
10  7   10  3.12857142857143 
1   8   10  10.925 
2   8   10  6.05 
3   8   10  4.50833333333333 
4   8   10  3.8 
5   8   10  3.425 
6   8   10  3.21666666666667 
7   8   10  3.10357142857143 
8   8   10  3.05 
9   8   10  3.03611111111111 
10  8   10  3.05 
1   9   10  11.0111111111111 
2   9   10  6.12222222222222 
3   9   10  4.56666666666667 
4   9   10  3.84444444444444 
5   9   10  3.45555555555556 
6   9   10  3.23333333333333 
7   9   10  3.10634920634921 
8   9   10  3.03888888888889 
9   9   10  3.01111111111111 
10  9   10  3.01111111111111 
1   10  10  11.1 
2   10  10  6.2 
3   10  10  4.63333333333333 
4   10  10  3.9 
5   10  10  3.5 
6   10  10  3.26666666666667 
7   10  10  3.12857142857143 
8   10  10  3.05 
9   10  10  3.01111111111111 
10  10  10  3 

Figure B-2: Last 40 Lines of the File 
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Figure B-3 shows Data Editor 

 

Figure B-3: Data Editor Containing Values of Block.dat 

To see the dataset of other planes, for example plane z=2, click on the upper arrow (Figure B-3). The horizontal grey 
cells (1,2…10) are the y values and the vertical grey cells are the x values (1,2…10). 

To use the Data Editor follow steps 1 –3 overleaf. 
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1. Select Data Manager from the Tools drop-down menu (Figure B-4). 

 

Figure B-4: Selecting Data Manager 
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2. Select Block in the Data Manager by clicking once with the left mouse button on it (Figure B-5). 

 

Figure B-5: Selecting Block 
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3. Select Editor… from the Edit drop-down menu (Figure B-6). 

 

Figure B-6: Selecting Editor for Block 
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Appendix C: Superconductor Files 

These are the first 25 lines and 3rd, 4th and 5th column of 00-39-33,Sep-07.txt file. The first line contains header 
information. 

Theta       Phi             Jc (A/m2) 
1.10000000E+2 6.00000000E+1 3.22356347E+10 
1.07000000E+2 6.00000000E+1 2.72672295E+9 
1.04000000E+2 6.00000000E+1 3.99047557E+10 
1.01000000E+2 6.00000000E+1 4.49788889E+10 
1.00500000E+2 6.00000000E+1 5.47276568E+10 
1.00000000E+2 6.00000000E+1 5.40836973E+10 
9.95000000E+1 6.00000000E+1 5.89814061E+10 
9.90000000E+1 6.00000000E+1 6.01080968E+10 
9.85000000E+1 6.00000000E+1 6.00190000E+10 
9.80000000E+1 6.00000000E+1 6.13340059E+10 
9.75000000E+1 6.00000000E+1 6.14041306E+10 
9.70000000E+1 6.00000000E+1 5.84813843E+10 
9.65000000E+1 6.00000000E+1 5.60704645E+10 
9.60000000E+1 6.00000000E+1 5.76031000E+10 
9.55000000E+1 6.00000000E+1 5.77612824E+10 
9.50000000E+1 6.00000000E+1 5.55248723E+10 
9.45000000E+1 6.00000000E+1 5.59663788E+10 
9.40000000E+1 6.00000000E+1 5.52096211E+10 
9.35000000E+1 6.00000000E+1 5.28042857E+10 
9.30000000E+1 6.00000000E+1 5.30446316E+10 
9.25000000E+1 6.00000000E+1 5.13812061E+10 
9.20000000E+1 6.00000000E+1 5.05760806E+10 
9.15000000E+1 6.00000000E+1 4.96483687E+10 
9.10000000E+1 6.00000000E+1 4.92829048E+10 
9.05000000E+1 6.00000000E+1 4.45706370E+10 

... 

... 

Figure C-1: First 25 Lines and 3rd, 4th and 5th Column 
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These are the last 25 lines and 3rd, 4th and 5th column of 00-39-33,Sep-07.txt file. 

... 

... 
-8.65000000E+1 6.00000000E+1 4.95293759E+10 
-8.70000000E+1 6.00000000E+1 4.72481049E+10 
-8.75000000E+1 6.00000000E+1 4.70969448E+10 
-8.80000000E+1 6.00000000E+1 4.51317600E+10 
-8.85000000E+1 6.00000000E+1 4.43541698E+10 
-8.90000000E+1 6.00000000E+1 3.14603254E+10 
-8.95000000E+1 6.00000000E+1 4.25624647E+10 
-9.00000000E+1 6.00000000E+1 4.27740195E+10 
-9.05000000E+1 6.00000000E+1 4.20171477E+10 
-9.10000000E+1 6.00000000E+1 4.02391475E+10 
-9.15000000E+1 6.00000000E+1 4.00687173E+10 
-9.20000000E+1 6.00000000E+1 3.81946048E+10 
-9.25000000E+1 6.00000000E+1 3.66846151E+10 
-9.30000000E+1 6.00000000E+1 3.68072364E+10 
-9.35000000E+1 6.00000000E+1 3.53120000E+10 
-9.40000000E+1 6.00000000E+1 4.22324515E+9 
-9.45000000E+1 6.00000000E+1 3.59350042E+10 
-9.50000000E+1 6.00000000E+1 3.48161520E+10 
-9.55000000E+1 6.00000000E+1 3.43704468E+10 
-9.60000000E+1 6.00000000E+1 3.37127385E+10 
-9.65000000E+1 6.00000000E+1 3.36291080E+10 
-9.70000000E+1 6.00000000E+1 3.26614471E+10 
-9.75000000E+1 6.00000000E+1 2.81305867E+9 
-9.80000000E+1 6.00000000E+1 3.20563254E+10 
-9.85000000E+1 6.00000000E+1 3.10477712E+10 

Figure C-2: Last 25 Lines and 3rd, 4th and 5th Column 
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Appendix D: File percs.dat 

This figure shows the first four columns of the file perc.dat. 

p3                p5                p10               p25 
2.43675231933594  3.77732753753662  5.70948028564453  7.10166454315186 
1.84078788757324  3.50401306152344  4.90051651000977  6.66944313049316 
1.59338760375977  3.26341724395752  4.47679138183594  5.91360950469971 
2.01849555969238  3.69032096862793  5.4636344909668   7.16080856323242 
1.45458221435547  2.97425365447998  4.92519378662109  6.528639793396     ... 
2.1877498626709   4.14098739624023  5.86970901489258  7.02697563171387 
1.61725997924805  2.7100076675415   3.77587890625     4.81455326080322 
1.58316993713379  3.23186683654785  5.22469711303711  6.23193359375 
2.5045166015625   4.22495174407959  6.05863189697266  7.71629619598389 
1.57023429870605  3.10932159423828  4.17752456665039  6.12541389465332 
 

Figure D-1: First Four Columns of percs.dat File 
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This figure shows the last four columns of the file perc.dat. 

p90               p95               p97               x           
11.9674530029297  13.8349866867065  15.0559692382813  24-MAY-2002 
12.1997451782227  14.1032314300537  15.705602645874   25-MAY-2002 
10.2283935546875  12.1270723342896  13.1783790588379  26-MAY-2002 
12.7075729370117  14.6593627929688  15.6653079986572  27-MAY-2002 

...   11.7831573486328  13.3862447738647  14.7151870727539  28-MAY-2002 
11.5595169067383  13.3478031158447  15.0407543182373  29-MAY-2002 
9.43350219726563  10.7913370132446  12.0494499206543  30-MAY-2002 
10.7643661499023  12.1877174377441  13.9972248077393  31-MAY-2002 
12.2233734130859  14.0631742477417  15.2575836181641  01-JUN-2002 
10.5418472290039  11.9082317352295  13.1667995452881  02-JUN-2002 

 

Figure D-2: Last Four Columns of percs.dat File 
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Appendix E: File scores.dat 

This is the first 25 lines of scores.dat file. The first line contains the title. 

x                   y                 t1                t2                
-5.90733313200349   55.5266956331216  51.7027875726873  33.5983972549438 
-1.46225439109685   60.1075656571411  59.7741234519265  54.222677230835 
1.06086531013739    50.5573746640111  1.54237955266779  68.2734390894572 
-6.52290783287663   53.7736891078093  81.0779072154652  26.507391611735 
1.39636514483277    58.1416396545574  59.4995085976341  49.2445370356242 
-3.90857078830641   53.399280273421   37.1455126675693  70.76717821757 
-0.425759868677005  56.7069040250462  34.8837006308816  50.8982877731323 
0.612751125563591   59.0741435867967  71.115478515625   64.1433537801107 
-7.54941335136959   53.3659391575675  80.8876491893421  26.6496082941691 
-7.45483522166569   54.3848920580858  90.9967269897461  28.9188365936279 
1.76506208042906    58.0115493110898  38.6923290599476  72.2880900700887 
-6.29041610035802   58.1423005793913  81.1032229336825  32.5832506815592 
-4.09463699135927   54.0793719275425  40.0948371887207  51.3035198847453 
-5.89688668770987   52.8292986966335  69.7386328957298  64.4605299631755 
-0.501863008875034  56.6057926935282  73.2044154080478  61.3572340011597 
0.614618229101325   50.9885721937462  3.13098421963778  76.3990224202474 
-5.62816381104153   60.333998505248   79.3884731639515  12.7326389948527 
-7.8670169986558    59.6548016416709  93.7991423173384  0.0240942637125627 
-1.44299521810512   53.7911476914996  58.7413375160911  47.9315659205119 
1.30055472679396    54.7825247743313  29.7147424871271  53.0532341003418 
-4.60749299110398   51.3576631252399  70.4393667741255  73.2497911453247 
-5.01972144568254   56.2966120562123  66.9868490045721  22.1736570994059 
1.51318981318877    52.7016588590886  14.3460641340776  89.8317238489787 
-1.16398460094388   53.2083848452312  28.7966142134233  84.9824091593425 

... 

... 

Figure E-1: First 25 Lines of File scores.dat 
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These are the last 25 lines of the scores.dat file. 

... 

... 
0.785943649723777   54.543493682082   43.055605801669   65.9791768391927 
-5.53630231698503   50.6206404227305  70.9149901650169  40.7115360895793 
-1.44253777773838   54.9021623373483  56.403318231756   40.3092047373454 
1.77126086417434    57.1827292331836  32.9838079972701  42.9769099553426 
0.0881323735311526  58.2463403163274  70.6714130748402  38.0455792744954 
0.801879378418334   54.5162737469982  33.0352197126909  88.7063086827596 
1.07256271380129    54.5973234677876  32.6649773337624  51.9302031199137 
-4.27527925863501   52.7014961698987  60.776478507302   42.6509122848511 
-5.78678359208971   53.0409776688321  78.4202769886364  35.9273096720378 
-4.67377516669353   50.5214813614912  52.0707324634899  75.6735544204712 
-4.70108155593289   59.4874758098667  74.7530524513938  16.2260672251383 
-3.43235669548972   52.2048467454551  51.2239563681863  53.0950765609741 
0.148551844012218   53.7646598577703  21.6022685657848  74.6390164693197 
-5.54948406796143   59.5125401131845  86.3400653492321  35.0198488235474 
-5.21755973654081   56.6720173618887  65.169319152832   16.8963413238525 
-6.28241556169883   55.1617634440445  53.1987557844682  34.4737908045451 
-5.65108250696721   57.7622993041005  99.1254133744673  38.3359731038411 
-2.08335571844168   57.5520133580903  84.9288007562811  54.1882257461548 
-1.76741379330406   54.4077498892657  67.5235075517134  74.489528020223 
0.299833908157098   60.20826009761    66.5677091425115  47.8629013697306 
-6.50423679749929   58.2139651675388  83.0511460737748  24.0640780131022 
1.03086095628601    53.1882418899077  44.5077483437278  76.7415107091268 
1.75861123770619    52.7883823653756  19.7151204889471  73.486421585083 
-3.13933346627778   57.1508828242622  53.5556033741344  57.3330462773641 
-1.7895389702262    57.4623817825341  57.230674050071   60.5098546346029 

Figure E-2: Last 25 Lines of scores.dat File 
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