3 Parts

The Part is the fundamental visualization entity in EnSight. Virtually every
postprocessing task you perform will involve a Part, thusit is vital to understand
how Parts work.

A Part isacollection of nodes and elements that are grouped together and share
the same attributes. When you start EnSight, you either read directly or
interactively extract Parts from the data files. Parts which come from the original
dataset are referred to as model Parts. Other Parts created within EnSight, are
referred to as created (or dependent) Parts.

In this chapter you will learn how to create derived Parts and how to modify the
attributes of all Part types.

Section 3.1 is extremely important. It defines how Parts work together to form

other Parts and explains the dependencies which may exist between model Parts
and created Parts. Failure to understand the concept of Parts as explained in this
section will limit your ability to use EnSight. Please study this section carefully.

Clip Plane

Contours Elevated Surface

T

—— Profile

Vector Arrows 7 = Model Part

Particle Traces

Figure 3-1
Various EnSight Part Types
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3.1 Part Overview

Reassign Parent

3-2

In EnSight, a Part is simply acollection of hodes and elements which are grouped
together, will be manipulated together, and which share the same attributes. This
section defines Parts and how they arerelated. It gives you an overview of the Part
types and Part attributes that are available within EnSight.

Partsthat are defined or extracted from your dataset are referred to as model Parts.
Parts that are created within EnSight are referred to as created (or dependent)
Parts. The types of Partsthat you create depends on what features within EnSight
you choose to utilize. Any created Part is derived from Parts that already exist,
which iswhy the created Parts are sometimes called dependent Parts—they
depend on the Parts from which they were created. The Parts that are used to
create a dependent Part are referred to as parent Parts. Any time that a parent Part
changes, its dependent Parts must also change. A parent Part will change when
you change its attributes, or modify the current time in the case of transient data.

TheMain Parts List contains all Partsthat have been read in from your results data
or created within EnSight. Displayed are a Part ID Number, a Part symbol, a case
number, and a Part description. Table 3-1 lists all of the different types of Parts
and their associated symbols. The figure below of the Parts List shows a number
of different Part types.

Using Parts(s)
: Y
Parent Part - P —(M/l) Computational mesh
Indicator 2—(I/C1) Iso surface
3-(T/Cl) Particle trace part\
13- i ~ Part Description
Part ID ——— 4-(2/C1) Clip_plane p
Number 5-(V/Cl) Vector Arrow part
6-(C/CI) Contour part
/
] ” \\ |-
Part Symbol Case Number
Figure 3-2

Main Parts List

Notethat in the illustration above the | sosurface Part is selected and that thereisa
“P” in the left column next to the Computational mesh (model) Part. This
indicates that the Computational mesh Part is the parent Part of the isosurface
Part. All parent Parts of a created Part will be so noted if that individual created
Part is highlighted in the Main Parts List.

Parent Parts of any created Part can be changed by first selecting the created Part
in the Feature Detail Editor, then selecting a new parent Part in the Main Parts
List, and finally by clicking the Update Parent button in the Feature Detail Editor.
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3.1 Part Overview

Table 3—1 Part Types, Symbols, and Descriptions

Part Type Symbol  Description

Clip 2 A surface or lineresulting from aclip of other Parts using the line,
plane, or quadric tools

Contour (© Lines of constant value on 2D elements

Developed Surface (D) A planar surface derived by unrolling a surface of revolution (i.e.,
the unrolling of a cylinder clip Part produced by the cylinder

quadric tool)
Elevated Surface (B) Surface created by elevating elements by a variable
I sosurface ) Surface of constant value through 3D elements of other Parts
Model Part (M) A Part that originated from the dataset
Particle Trace (M Path of a massless Particle through a vector field
Profile (P) Plot of avariable along aline (Similar to a2D elevated surface)
Vector Arrow V) Arrows showing direction and magnitude of vector field
Subset S Valid node and/or element label range(s) from model Part(s)

Part Creation
Part creation occurs on either the server or the client. Since the datathat is
available on the client and server are different, it is useful to understand where
Parts are created and where the data structures are stored. By understanding this,
you will understand why some Parts can be created with certain parent Parts and
others cannot. This information can be gained by examining the following table.

Table 3-2 Part Creation and Data Location

Data on

Part Type Where Created Server Data on Client

Clip Server Yes Depending on Part attributes
Contour Client No Yes

Developed Surface Server Yes Depending on Part Attributes
Discrete Particle  Not Applicable Yes Depending on Part attributes
Elevated Surface  Server Yes Depending on Part attributes
Isosurface Server Yes Depending on Part attributes
Model Not Applicable Yes Depending on Part attributes
Particle Trace Server No Yes

Profile Client No Yes

Vector Arrow Client. Server if Maybe  Yes

necessary.
Subset Server Yes Depending on Part attributes

(see Introduction to Part Creation)
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Part Attributes

3-4

Each type of created Part has a unique set of attributes that are used to accomplish
its creation, the Creation Attributes. Model Parts (symbol: M) and discrete
Particle Parts (symbol: D) do not have creation attributes because they are not
created—they are read or extracted from the dataset.

All Parts have aset of Display Attributesthat are used in visualizing the Part in the
Graphics Window. These can be modified using the Feature Detail Editor or by
utilizing the Part Mode | cons (See Section 8.4). The Feature Detail Editor for each
Part type will show you attributes grouped together under turndown sections.
They deal with such things as color, line width, symmetry operations, etc. Display
attributes do not control how the Part is created, only how it appears or how it
behaves in the Graphics Window.

Table 3—3 Display Attribute Sections

Section: Includes controls for...
General Attributes Visibility in Graphics Window and
(see Section 3.3 Part Editing) individual Viewports

Symmetry options
Susceptibility to Auxiliary Clipping
Reference frame

Response to changes in time (frozen or
active)

Coloration (constant or by a palette
associated with a variable)

Hidden Surface and Hidden Line display
Surface shading (flat, Gouraud, smooth)
Opaqueness and Fill density
Lighting (diffuse, shininess, and
highlight intensity)

Node, Element, and LineAttributes  General Visibility: Node, Line, and

(see Section 3.3, Part Editing) Element

Label Visibility: Node and Element
Node Representation: Node type (dot,
cross, or sphere), Node Scale, Node

Detail (for spheres), and Node size
(constant or variable)

Line Representation: LineWidth and Line
style (solid, dotted, or dot-dash)

Element representation on client (full,
border, 3D border/2D full, feature angle,
or non visual), Element-size, Shrink-
Factor, and Element Angle

Displacement Attributes Displacement variable
(see Section 3.3, Part Editing) Displacement scaling factor
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3.2 Part Selection and Identification

Selecting Parts

Identifying Parts

EnSight 6.2 User Manual

In the process of creating a Part you will need to be able to select the parent
Part(s) from the Main Parts List. You will also find that it is possible to either read
or create so many Parts within EnSight that you become confused as to the
identity of each Part. This section describes Part selection and identification

Itemsin all Parts Lists are selected using standard Motif methods:
To: Do This: Details

Select an item Select (or Place the mouse pointer over the item
single-click)  and click theleft mouse button. Theitem
is highlighted to reflect the “ selected”

state.
Extend acontiguous  Select-drag  Place the mouse pointer over the first
selection item. Click and hold the left mouse

button as you drag over the remaining
itemsto be selected. Only contiguous
items may be selected in this fashion.

Extend a (possibly  Shift-click Select the first item. Place the mouse

long) contiguous pointer over thelast itemin thelist to be

selection selected. Pressthe shift key and click the
left mouse button. This action will
extend a selection to include all those
items sequentially listed between the
first selection and this one.

Extend anon- Control-click Place the mouse pointer over the item.

contiguous selection Press the control key and click the left
mouse button. This action will extend a
selection by adding the new item, but
not those in-between any previously
selected items.

De-select an item Control-click  Place the mouse pointer over the
selected item. Press the control key and
click the left mouse button. This action
will de-select the item.

Open the Quick Double-click Place the mouse pointer over the item
Interaction Areafor a and click the left mouse button twicein
Part rapid succession.

(see How To Select Parts)

There are two quick ways to identify one or more Parts that have been selected in
the Main Parts List. You can identify them in the Graphics Window by toggling
visibility on/off while in Part Mode or you can select View > Show Selected
Parts... from the Main Menu to show only the selected Part(s) in the pop-up
Selected Part(s) Window.
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3.3 Part Editing

In EnSight, new Parts can be created and edited in the Quick Interaction Area
Editor or in the Feature Detail Editor specific to each type of Part. This processis
described in Sections 7.2 to 7.9. For editing, the Quick Interaction Area provides
access to the most common attributes; the Feature Detail Editor allow
modification of all attributes.

Whereas each individual change made in the Quick interaction Area Editor is
applied to the Part immediately, the Feature Detail Editor allows you to make a
number of changes to various attributes and then apply them all at one time. This
is done by toggling off View > Immediate M odification in the Feature Detail
Editor. The default behavior isto immediately apply a change when you press
Return.

The Feature Detail Editor for Partsis opened from the Main Menu (or by double clicking
on aPart creation Icon in the Main GUI Feature Icon Bar).

Toolsr Prefe Care

Fie  Edit I Query View
Fart « Salected Fart Type
Fart Feanwe Detail Editors - Contours

Flipbook Animation Editor...  Cl#.
KeyTrawve Animation Editor,,, Developed Sarfacer_
Solwtion Tise Editor Elsvated Susfacss...

Trawslorsmations Editor I 4 I

Varables Editor... Modkel Fares..,

Particle Traces,.,

Profiles

Veeter Arreras

— Editor Title Bar
Editor Main Menu ————— | File  Edit View Help

G B I I Il || P e oon
24— -

2 - {ICT) o surface = )
e — Parts List (of chosen

Part Type)

Description of Selected Part — | D= | 1o purface

— Creation Attributes Turndown

m Creation Attributes

m General Attribates |

Display Attributes Turndowns |

ﬂ Desplacessent Attributes

(\oul (.hlh] Update P-nn!] Apph u'h.ur.l.c-]

Figure 3-3
Feature Detail Editor (Isosurfaces)
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Feature Detail Editor Main Menu

File

Edit

Select All

Copy

Delete

Immediate
Modification Toggle

View

Show Selected
Part(s) Toggle

Part Type Icon Bar
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Not applicable when Feature Detail Editor is used for Parts - only applicable for Variables.

Opens a pull down menu.

Edit
Select Al
Copy
Delete
Immediate Modifioation

Figure 3-4
Feature Detail Editor Edit pull-down menu

Selects all Partsin Feature Detail Editor Parts List. (see Section 3.4, Part Operations)

Makes a copy of all selected Parts. (see Section 3.4, Part Operations), also (see How To
Copy aPart)

Deletes selected Parts. (see Section 3.4, Part Operations), also (see How To Delete a Part)

Toggles on/off the immediate modification of Parts when individual changes are made to
Attributes within the Feature Detail Editor. Default is on. By toggling off, you can make
severa changes within the Feature Detail Editor and then apply them all at one time by
clicking the Apply Changes button.

Opens a pull-down menu.

View |

Show Selecind Pasvst |

Figure 3-5
Feature Detail Editor View pull-down menu

Opens the Selected Part(s) Window in which only Parts selected in the Feature Detail
Editor's Parts List are visible.
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Creation Attributes

Model Parts

The Feature Detail Editor isinitially opened from EnSight’'s Main Menu (or by double
clicking a Part creation icon in the Feature Icon Bar) and the Feature Detail Editor’s Parts
List contains all Parts of the type named in the Editor’'s Title Bar. The type of Partsin the
Feature Detail Editor’s Parts List may be changed by clicking on the appropriateicon in
the Feature Detail Editor’s Part Type Icon Bar. The figure below shows the choices
available.

n‘— Model Parts
-'— Contour Parts

1
-!— Isosurface Parts
i_ Particle Trace Parts

|— Clip Parts

|
|
L__J
|
-!— Vector Arrow Parts
‘“ |
|
-I— Elevated Surface Parts
“I— Profile Parts

]— Developed Surface Parts

m‘— Subset Parts

Figure 3-6

Feature Detail Editor Part Type Selection Icons

ThereisaColor Icon in the Feature Detail Editor’s Part Type Icon Bar which, if clicked
will open the Feature Detail Editor for Variables.

See Section 4.1 Variable Selection and Activation for further discussion.

Creation Attributes are “ specific” attributes used to create (or modify) model and created
Parts.

Creation Attributes for updating the I,J,K node range attributes of the selected block
structured Model Parts with proper updating of all dependent parts and variables. The
Creation Attributes areaisinactive for unstructured Model Parts.

Access: Main Menu > Edit > Part Feature Detail Editors > Model Parts

B Creation Attriutes

Using Node Ranges:
From Yo Step Min Max

' l l
| |

2
= | l

Figure 3-7
Feature Detail Editor (Model) Creation Attributes Area

Using Node Ranges

IJK From These fields specify the desired minimum interval value in the respective 1JK
component direction of the Model Part.
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Created Parts

General Attributes

Visible Toggle

Visible In Viewports
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IJK To These fields specify the desired maximum interval value in the respective 1JK
component direction of the Model Part.

IJK Step These fields specify the desired interval stride value in the respective 1K
component direction of the Model part.

IJK Min These fields verify the minimum interval limit in the respective 1JK component
direction of the Model part.

IJK Max These fields verify the maximum interval limit in the respective |JK component
direction of the Model part.

(see How To Create 1K Clips)

See the appropriate Section in Chapter 7 for a description of the Creation Attributes
section.

» (see Section 7.2, Contour Create/Update)

» (see Section 7.3, Isosurface Create/Update)

* (see Section 7.4, Particle Trace Create/Update)

* (see Section 7.5, Clip Create/Update)

* (see Section 7.6, Vector Arrow Create/Update)

» (see Section 7.7, Elevated Surface Create/Update)

» (see Section 7.8, Profile Create/Update)

» (see Section 7.9, Developed Surface Create/Update)
* (see Section 7.16, Subset Parts Create/Update)

General Attributes are “genera” in that: (a) all Parts have them, and (b) they can’t
be neatly categorized into any other attribute type. Like all Part attributes, they are
set individually for each Part.

Access: Main Menu > Edit > Part Feature Detail Editors > General Attributes

B General Attributes
Visibl Visdble In  Detail
it Viewport(x) Rep. Bex O

T Aux. Clp —

Par:';u l.

Active

Codor By None .
Blioe Ol Blrm M.

Surface
U Hidden Surface Shading Gouwrand
© Hidden Line
Opaueness [‘TPP":IN Pill0 =3
ezl 1oy U i
Dift 10 Shin | g w0 Hint [ ;00

Figure 3-8
Feature Detail Editor General Attributes Area

Toggles-on/off whether Part is visible on aglobal basis (in the Graphics Window or in all
viewports). (Performs the same function as the Visibility Toggle in the Parts Mode Icon
Bar). Default is ON.

This small window allows you to control the visibility of the selected Part(s) on a per
Viewport basis. Each visible viewport is shown. A green outline around a Viewport

3-9



3.3 Part Editing

indicates that the selected Part(s) will be visible in thisViewport, while ared outline
indicates that the selected Part(s) will not be visible. Change the visibility (red to green,
green to red) by selecting a viewport with the mouse.

Detail Rep. This button opens a pop-up menu button for the selection of the detail of representation in
which a part displays on the client. This attribute helps the display of complex data sets.
The part detail representation displays according to whether the view Detail Mode
(located in the View Menu or aView Mode icon) is off, dynamic, or static. For instance,
when the Detail Mode is Off (default) the part displays according to its specified Element
Representation. When dynamic, the parts are displayed by the detail representation only
while being transformed. Finally when static, the part is displayed all the time by the
detail representation. The part detail representations are:

Box abounding (Cartesian extent) box of all part elements (default).
Elements display according to specified Element Representation.
Points  point cloud representation of the part.

(see How To Set Global Viewing)

Symmetry This button opens a pull-down menu which allows you to toggle-on/off the display of a
mirror image of Parts (which are selected in the Feature Detail Editor’'s Parts List) in each
of the seven other quadrants of the Part’slocal frame. It performs the same function asthe
Symmetry Pulldown Icon in the Part Mode Icon Bar. You can mirror the Part to more than
one quadrant. If the Part occupies more than one quadrant, each portion of the Part mirrors
independently. Symmetry enables you to reduce the size of your analysis problem while
still visualizing the “whole thing.” Symmetry affects only the displayed image, not the
data, so you cannot query the image or use the image as a parent Part. However, you can
create the same effect by creating dependent Parts with the same symmetry attributes as
the parent Part. Symmetry works asif the local frame is Rectangular, evenif itis
cylindrical or spherical. The images are displayed with the same attributes as the Part. For
each toggle, the Part is displayed as follows. The default for all toggle buttonsis OFF.

1, 1,-1 face-sharing quadrant on other side of the X-Y plane.

1,-1, 1 face-sharing quadrant on other side of the X—Z plane

-1, 1, 1 face-sharing quadrant on other side of theY—Z plane.

1,-1, 1 diagonally opposite quadrant on same side of the X-Y plane.
1,-1,-1 diagonally opposite quadrant on same side of theY—Z plane.
1, 1,-1 diagonally opposite quadrant on same side of the X—Z plane.
1

-1
1
,-1,-1 quadrant diagonally opposite through origin.

(see How To Set Symmetry)

Aux Clip Toggle Toggles-on/off whether Part(s) selected in the Part List of the Feature Detail Editor will be
affected by the Auxiliary Clipping Plane feature, which enables you to make invisible
that portion of each Part on the negative side of the current position of the Plane
Tool. Performs the same function as the Part Mode: Auxiliary Clipping Toggle
Icon. A Part with its Aux Clip attribute toggled-off will not be cut away. Defaultis
ON. (seeAuxiliary Clipping in Section 6.4, View Menu Functions).

Active Toggle Toggles-on/off whether or not display of the Part automatically updates as the solution
time changes. When visualizing transient data, you may wish to “freeze” a Part in time
while other Parts continue to update. For example, you can create two identical vector-
arrow Parts, toggle-off Active for one of them, change the time step of the display, and see
how the vector arrows change from one time step to the other. Only the EnSight client Part
isfrozen, the EnSight server Part is kept current. Default is ON.
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Thisfield specifies which frame the Part is assigned to. Default is the frame of the Part’s
parent Part (Frame O for original model Parts). Enter a different frame number in the field
to change the assignment. Changing a Part’s frame causes the Part to be drawn in the new
coordinate frame. Once assigned to a different frame, the Part will transform with that
frame. The choice of frame does not affect variable values. The interpolated value of a
variable at point 0,0,0 in Frame 0 is the same as at point 0,0,0 in Frame 1, even though the
points may appear at different locations in the Main View Window.

(see Section 8.6, Frame Mode)

This button opens a pop-up menu for the selection of the variable color palette by which
you wish to color the selected Part(s). Coloring a Part with a palette does not normally
affect graphics performance while in line drawing mode, but Hidden Surface mode
performance can become considerably slower. If you do not color by apalette (Color By >
None), the Part will be displayed according to the color specified inthe R, G, B fields. If
you want to color Parts by palettes and want Hidden Surface mode, consider using the
Static Lighting option (see Static Lighting in Section 6.4, View Menu Functions).

These fields allow you to specify a solid color for the selected Part(s) (applicable only if
Color By isNone). Enter a numerical value from 0 to 1 for each component color (Red,
Green, and Blue).

Opens the Color Selector dialog for the selection of asolid color for the selected Part(s)
(applicable only if Color By is None). (see Section 7.1, Color)

Toggles on/off hidden surface shading for individual Parts. When global Hidden

Surface has been toggled on for the Graphics Window display (from Main Menu > View >
Hidden Surface or viathe Global Hidden Surface Toggle in the View Mode Icon Bar),
individual Parts can be forced to stay in line drawing mode using thistoggle. Default is
ON. (see Section 6.4, View Menu Functions)

Toggles on/off hidden line representation for individual Parts. When global

Hidden Line has been toggled on for the Graphics Window display (from Main Menu >
View > Hidden Line or viathe Global Hidden Line Toggle in the View Mode Icon
Bar), individual Parts can be forced not to appear as Hidden Line representation using this
toggle. (To have lines hidden behind surfaces, Parts must have surfaces, i.e. 2D elements)
Default is ON. (see Section 6.4, View Menu Functions)

Opens a pop-up menu for selection of appearance of Part surface when Hidden Surfaceis
on. Normally the mode is set to Gouraud, meaning that the color and shading will
interpolate across the polygon in alinear scheme. You can a so set the shading typeto Flat,
meaning that each polygon will get one color and shade, or Smooth which means that the
surface normals will be averaged to the neighboring elements producing a “ smooth”
surface appearance.Not valid for all Part types. Options are:

Flat Color and shading same for entire element

Gouraud Color and shading varies linearly across element

Smooth Normals averaged with neighboring elements to simulate smooth surfaces

This field specifies the opagueness of the selected Part(s). A value of 1.0 indicates that the
Part is fully opague, while avalue of 0.0 indicates that it is fully transparent. Setting this
attribute to a value other than 1.0 can seriously affect the graphics performance.

Opens a pop-up menu for selection of afill pattern which can provide pseudo-
trangparency for Hidden Surface shaded surfaces. Default is Fill 0 which uses no
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3-12

pattern (produces a solid surface), while Fill patterns 1 through 3 produce a EnSight
defined fill pattern.
Lighting

Diff Thisfield specifies diffusion (minimum brightness or amount of light that a Part reflects).
(Some applications refer to this as ambient light.) The Part will reflect no light if valueis
0.0. If valueis 1.0, no lighting effects will beimposed and the Part will reflect all light and
be shown at full color intensity at every point. To change, enter avaluefrom0to 1.

Shin Thisfield specifies shininess.You can think of the shininess factor in terms of how smooth

the surface is. The larger the shininess factor, the smoother the object. A value of 0

corresponds to a dull finish and a value of 100 corresponds to a highly shiny finish. To

change, enter avalue from 0 to 100.

H Int Thisfield specifies highlight intensity (the amount of white light contained in the color of

the Part which is reflected back to the observer). Highlighting gives the Part amore

realistic appearance and reveals the shine of the surface. To change, enter avalue from 0 to

1 with larger values representing more white light. Will have no effect if Shin parameter is

zero.

(see How To Set Attributes)

Troubleshooting Surface Attributes and Lighting

Problem

Probable Causes

Solutions

Part not in Hidden Surface mode

Part appears not to have any
lighting.

Global Toggle not on, or if on,
Hidden Surfaceis turned off for
the Part in the Feature Detail
Editor

Part contains only 1D elements
Diffuse light intensity too high

Turn on Hidden Surface toggle
from View menu of Main Menu
or turn and make sure Hidden
Surface is turned on for the Part
in the Feature Detail Editor.

No Solution
Lower the Diff value.
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Node, Element, and Line Attributes

General Visibility

Node Toggle

Line Toggle

Element Toggle

Label Visibility

Node Toggle

Element Toggle

Node Representation

Type
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Each Part’s Node, Element, and Line attributes control the representation of the

Part on the client, and how nodes, elements, and lines are displayed.
Access. Main Menu > Edit > Part Feature Detail Editors > Node, Element, and Line Attributes

“ Nole, Element, and Line Attriltes

General Visibility
l | Node 7 Line ” Element ‘

Label Visibility
| | Node Element ‘

Node Representation

Type Cress =i | 54l | o000es00
Detall o Size By Sealar -

Varmble temperature

Line Representation
Width | Style  Solid i |

Element Representation

Visual Rep. FPull -
Shrink Pactor | , o0 Angle | 109
Figure 3-9

Feature Detail Editor Node, Element, and Line Attributes Area

Toggles-on/off display of Part’s nodes whenever the Part is visible. Default is OFF.

Toggles-on/off display of line (1D) elementsin the client-representation whenever the Part
isvisible. Default is ON.

Toggles-on/off display of 2D elementsin the client-representation whenever the Part is
visible. Note that 3D elements are aways represented as 2D elements on the client.
Default is ON.

Toggles-on/off display of Part’s node labels (if they exist) whenever the Part is visible.
Only model Parts may have node labels. Default is OFF.

Toggles-on/off display of Part’'s element labels (if they exist) whenever the Part is

displayed in Full visual representation. Only model Parts may have element labels, and.
Default is OFF.

Opens a pop-up menu for the selection of symbol to use when displaying the Part’s nodes.
Default is Dot. Options are:

Dot to display nodes as one-pixel dots.
Cross to display nodes as three-dimensional crosses whose size you specify.
Fohere to display the nodes as spheres whose size and detail you specify.
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Scale Thisfield is used to specify scaling factor for size of node symbol. Values between 0 and 1
reduce the size, factors greater than one enlarge the size. Not applicable when node-
symbol TypeisDot. Default is 1.0.

Detail Thisfield is used to specify how round to draw the spheres when the node-symbol typeis
Sphere. Ranges from 2 to 10, with 10 being the most detailed (e.g., roundest spheres).
Higher values take longer to draw, slowing performance. Default is 2.

Size By Opens a pop-up menu for the selection of variable-type to use to size each node-symbol.
For options other than Constant, the node-symbol size will vary depending on the value of
the selected variabl e at the node. Not applicable when node-symbol TypeisDot. Default is
Constant. Options are:

Constant sizes node using the Scale factor value.

Scalar sizesnode using ascalar variable.

\ector Mag sizes hode using magnitude of avector variable.

\ector X-Comp sizes hode using magnitude of X-component of a vector variable.
Vector Y-Comp sizes node using magnitude of Y-component of avector variable.
\ector Z-Comp sizes node using magnitude of Z-component of a vector variable.

Variable Selection of variable to use to size the nodes. Activated variables of the appropriate Size
By type are listed. Not applicable when node-symbol Typeis Dot or Size By is Constant.

Line Representation

Width Specification of width (in pixels) of line elements and edges of 2D elements whenever
they arevisible. Rangeisfrom 1 to 20. Default is 1. Line widths other than 1 are not
available on all hardware. This performs the same function as the Part Line Width
Pulldown Icon in Part Mode.

Style Selection of style of linewhen lines are visible. Default is Solid. Options are:
Solid
Dotted
Dot-Dash
Element Representation
Visual Rep. Selection of representation of Part’s elements on the client. Saves memory and time to
download.

3D border, 2D full represents the Part’s 3D elements in Border representation, the
Part's 1 and 2D elementsin Full representation. The result is the outside
surfaces of the Part are displayed along with all bar elements.

Border represents the Part’s 3D elements with 2D elements corresponding to
unshared element faces, the Part’s 2D elements with 1D elements
corresponding to the unshared edges, and the Part’s 1D elements as 1D
elements. The result is the outside faces and edges of the Part’s elements.

Feature Angle first runs the 3D border, 2D full representation to get alist of 1 and
2D elements. The 1D elements and all non-shared 2D edges will be shown,
but only the shared edges above the Angle value will be shown. The result
consists of 1D elements visualizing the sharp edges of the Part.

Bounding Box represents all Part elements as a bounding box surrounding the Cartesian
extent of the elements of the Part.

Full represents all faces of the Part’s 3D elements, and all the 1 and 2D elements.

Non Visual means the Part exists on the server, but is not loaded on the client. Not
Loaded Parts may be used as parent Parts, but do not exist on the client.
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Shrink Factor Specification of scaling factor by which to shrink every element toward its centroid. Enter
the fraction to shrink by in range from 0 to 1. Default is 0.0 for no shrinkage.

Angle Specification of lower limit for not displaying shared edgesin Feature Angle
Representation. Valueisin degrees.

(see How To Set Attributes and How To Display Labels)

Troubleshooting Node, Element and Line Attributes

Problem Probable Causes Solutions

After changing to FeatureAngle  Anglevalueisto large Set Angle to smaller value.
representation, the Part is not

shown.
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Displacement Attributes
Displacement Attributes specify how to displace the Part nodes based on a vector
variable. Each node of the Part is displaced by a distance and direction
corresponding to the value of a vector variable at the node. The new coordinateis
equal to the old coordinate plus the vector times the specified Factor, or:

Cren = Corig + Factor * Vector,

where C,, is the new coordinate location, C,g is the coordinate location as

defined in the datafiles, Factor is a scale factor, and Vector is the displacement
vector.

You can greatly exaggerate the displacement vector by specifying alarge Factor
value. Though you can use any vector variable for displacements, it certainly
makes the most sense to use a variable calculated for this purpose. Note that the
variable value represents the displacement from the original location, not the
coordinates of the new location.

Access: Main Menu > Edit > Part Feature Detail Editors > Displacement Attributes

Displacement Attributes

Displace By velocity i E
Factor | 1 0000e+00

Figure 3-10
Feature Detall Editor Displacement Attributes Area

Displace by Opens apop-up menu for selection of vector variable to use for displacement (or None for
no displacement). Variable must be a vector and be activated.

Factor Thisfield is used to specify ascalefactor for the displacement vector. New coordinates are
caculated as: Cyqy, = Cyyig + Factor*Vector, where C,g, is the new coordinate location,
Corig Isthe original coordinate location as defined in the data file, Factor is a scale factor,

and Vector is the displacement vector. Note that a value of 1.0 will give you “true”
displacements.
(see How To Display Displacements)

Troubleshooting Displacement Attributes

Problem Probable Causes Solutions
Displacement not visible Displace By attribute set to None  Set the Displace By attribute
for Part that is not displacing.
Factor value too small. Specify alarger Factor.
Create Clicking this button creates a new Part using attributes currently selected/specified in the

Feature Detail Editor. This performs the same function as the Create button in the Quick
Interaction Area Editor for each type of created Part. Clicking Create updates the Graphics
Window and adds the new Part to the Main Parts List and to the Parts List in the Feature
Detail Editor for thistype of Part. Not applicable for model Parts or discrete Particles.

(see Introduction to Part Creation)
Update Parent Clicking this button assigns the Part which is currently selected in the Main Parts List as

the new parent Part of the created Part(s) which is(are) currently selected in the Feature
Detail Editor’'s PartsList.
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Apply Changes Clicking this button applies all changes that have been made within the Feature Detall
Editor al at once if Immediate M odification has been toggled off above in the Feature

Detail Editor’s Edit pull-down menu. If Creation attributes have been changed, the Part
will be regenerated.
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3.4 Part Operations

Select All

Select ...

Find What

Match Whole Word
Only Toggle

Match Case Toggle

This section will describe the Part operations accessible through “ Edit > Part” in
the Main Menu and “ Edit” in the Feature Detail Editor Menu. These include
Slect All, Sdlect, Delete, Copy, Cut, Extract, and Merge.

Edit

View
U" dhow Varable Select All
Part r
Select All I Copw
Fart Feature Detall Editors Select =
- - —_
Flighook Animation Editer... Delete_
Kayframe Anlmation Editor... N
7 Copy
Solution Time Editor... -
T Ynndornuﬁa Editor... e
Ungroup

ll-ln‘ \ ariables Editor.. A ——
Cut & Split
(.-0 & Remsove
Extract

Figure 3-11
Part Operation Selection Menus

Choosing this from the Main Menu > Edit >Part pull-down, selects al Partsin the Main
Parts List. Choosing this from the Edit pull-down in the Feature Detail Editor Menu
selects all Partsin the Feature Detail Editor Parts List.
Access: Main Menu > Edit > Part > Select All

Feature Detail Editor Menu > Edit > Select All

(see How to Select Parts)

Choosing this from the Main Menu > Edit >Part pull-down, opens the Select Part(s) By
Keyword dialog.

| Find What) [Rusa

 Mateh Whode Word Only . Addl To Oarvent Selection
I Mateh Case Select Next Mateh |
© Use Reguiar Exprossion  salect All Matchves |

1 =

.~ Match Any 1 Char -
J

Figure 3-12
Select Part(s) By Keyword dialog

Thisfield is used to specify the keyword or regular expression to compare (match) against
Part names.

When on, the entire Part name must match the keyword or regular expression.
When off, a Part name will be selected if only a substring of the Part name matches.

When on, the comparison is case sensitive. When off, case isignored.
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Use Regular
Expression Toggle

Special Character
Selection List

Add to Current
Selection Toggle

Select Next Match
Select All Matches

Delete...

Copy
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When on, special characters in the keyword will be used to define aregular expression.
When off, any special characters will be treated as aregular character during comparison.

Contains alist of specia characters available to create aregular expression. Selecting an

item from the list will insert the specia character into the “Find What” text field at the

cursor location.

* Match any number of charactersin the part name

. Match any one character in the part name

~ Match part names that do not match the specified search criteria.

| Separates multiple search keywords or regular expressions. (extra spaces are not
allowed around “[")

Examples: Find What: abc*xyz Match Whole Word Only: On
Select any Part who's hame starts with “ abc” and ends with “ xyz’

Find What:  tom|jerry Match Whole Word Only: OFF
Select all Part swho's names contain the string “ tom” and/or the
string “ jerry”

When on, any matching Part names will be added to the list of Part names currently
selected. When off, only the matching Part names will be selected.

Sel ects the next Part name which matches the keyword or regular expression.
Selects al Part names which match the keyword or regular expression.

If chosen from the Main Menu > Edit > Part pull-down, deletes all selected Partsin the
Main Parts List after you have confirmed in a pop-up dialog that you wish to do so. If
chosen from the Edit pull-down in the Feature Detail Editor Menu, deletes all selected
Parts in the Feature Detail Editor Parts List after you have confirmed in a pop-up dialog
that you wish to do so. If model Parts are deleted, they are no longer available for the
current session. Parts dependent upon selected Parts will also be deleted or modified
Access: Main Menu > Edit > Part > Delete...

Feature Detail Editor Menu > Edit > Delete...

(see How to Delete a Part)

If chosen from the Main Menu > Edit > Part pull-down, makes a copy of selected Part(s)
in the Main Parts List. If chosen from the Edit pull-down in the Feature Detail Editor
Menu, makes a copy of selected Part(s) in the Feature Detail Editor Parts List.

The Copy operation creates a dependent copy of another (original) Part. The Copy is
created on the Client and its existence is not known to the EnSight Server process. A Copy
shares geometric data and variable data with the original Part. (Thistype of Partis
sometimes called a“ shallow copy”.)
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relationships

attributes

description

copies of copies

frame assignment

usefulness

Original Clip Part - colored by temperature Copy of Clip Part, assigned to new Frame,
translated to right, and colored by velocity
at the same time step

Figure 3-13

Part Copy Example

The relationship between aModel Part and a Copy made from aModel Part will be one of
original and copy. That is, the Model Part will not be a Parent to the Copy asitistoa
Created Part such asaclip.

The relationship between a Created Part and a copy made from it will also be one of
original and copy since the Copy will initially regard as its Parent the same Part that the
original Created Part regards as its Parent. The Parent of individual Created Parts can of
course be reassigned (using the Update Parent button at the bottom of the Feature Detail
Editor) but the Parent of a Created Part Copy can Not be reassigned.

A copy can be used as a Parent Part for Parts created since the create operation will
operate on the original Part.

Theinitial attributes assigned to a Copy are the same as those of the original Part at the
time of copying. All attributes for the Copy except Element Representation (3D border, 2D
full, border, Feature Angle, etc.) can be changed. The Element Representation of a Copy
cannot be changed independently; a change in Element Representation of the original
changes the copy as well.

The description of the new Copy will be the same as the original Part with the suffix “-
COPY” added (of course, you can change this description in the Desc field in the Feature
Detail Editor).

You can make multiple copies from aModel or Created Part, but you can Not make copies
of copies.

A new frame is automatically created for each newly created Copy and the Copy is
assigned to the new frame so that it can easily be moved with alocal transformation. The
location of the original Part and the Copy will initially coincide aswell. Like all Parts,
Copies of Parts can be reassigned to different frames in the General Attributes Section of
the Feature Detail Editor (for that type of Part).

One of the most useful purposes for copies is a separation alowing for the side-by-side
display of different attributes (shown in Figure 3-11). Since all attributes except Element
Representation can be different, the original and the copy can be displaying different
variables, different displacements, etc.

(see How To Copy a Part)
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Cut & Split
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The group operation is used to collect any number of partsinto a set which can be
modified and utilized as one entity. The operation is non-destructive and reversible, and is
used solely as a convenience to the user in order to organize alarge number of parts.

Any attribute modification to a grouped part affects each of the partsin the group.
Similarly, if agrouped part is used as a parent part, each part in the group isused as a
parent in the creation process.

When group is selected, the dialog shown in the figure below will appear. A part name
must be input in order to compl ete the grouping operation.

fubd parts

Okay Cancel

Figure 3-14
Group Parts Dialog

Only parts of the same type and case can be grouped together. Further, groups can not
contain other part groups.

(see How To Group Parts)

Cuts selected Part(s) aong the surface of the plane or quadric tool. The original Part(s) are
preserved and two new Parts are created which still contain valid elements of the same
order asthosein the original Part (Cutting 3D elementsyields valid 3D elements, cutting
2D elementsyields valid 2D elements, etc.). Variable values at new nodes created on the
cutting plane are interpolated and stored as part of the information about the node (just
like aregular Part), thus the cut Parts are full-fledged Parts which exist on the server and
can be used as parent Parts for future operations.

Cut & Remove

o

Quadric
Cylinder Tool

Plane Tool

Cut & Split

Figure 3-15 Cut & Split
Cut Operations on Parts

The cut is made along the surface of the Plane, or Quadric tool with infinite extent. The
first new Part consists of that portion of the original Part which was on the +Z side (front)
of the Plane tool’s surface (or the inside of the Quadric tool’s surface) and the second new
Part consists of that portion of the original Part which was on the —Z side (back) of the
Plane tools surface (or the outside of the Quadric tool’s surface). The descriptions of the
two new Parts are the same as the original part but have + or - appended to them. As
always, the description for any Part can be changed in the Desc. field in the Feature Detail
Editor for that type of Part.
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Only Parts known to the server can be cut. These include Model Parts, Clip Parts,
I sosurface Parts, and Elevated Surface Parts. A Part Copy cannot be cut directly, but if the
parent of a Copy is cut in any way, the same cut operation is performed on the Copy.

You should be aware that the Cut algorithm breaks the elements intersecting the clip
surface into tetrahedrons. Asthereis no transition zone created between these tetrahedrons
and their non-cut neighbors, non-shared element faces are possible. These non-shared
faces can sometimes result in undesired lines and elements during border and/or feature
angle Element Representation.

Cut & Remove A new Part is created representing the positive portion of the plane tool’s intersection (or
the outside portion of a Quadric tool) of the original Part(s).

(see How To Cut Parts)

Extract Extracts selected Part(s) into a new, true Part, using the Part representation in effect at the
time (full, border, or feature). If more than one Part is selected, then they are joined into a
single Part. If more than one Part is selected when extract is invoked, then all will have
their extracted geometry joined into a single new Part. The new Part is assigned to Frame
0.

The Extract option is closely tied to Element Representation. It creates a new Part using
the geometry of the current representation (what you see is what you get). Extracted Parts
which are in Full Representation are actual copies of the original, but extracted Parts
which are in Border Representation are only the shell or boundary of the original. Extract
is often used with the Save Geometric Entities feature to save extracted Parts (and not the
originals) into asmaller set of data. It isalso used to create hollow Partsfrom solid Partsto
be able to look inside a solid Part after cutting it open with the Cut feature.

(see How To Extract Part Representations)

Merge If more than one Part is selected, the Merge operation creates a new model Part on the
Server host that isacombination of all selected. If only one Part is selected when Mergeis
invoked, then anew Part is created on the Server host that isidentical but fully
independent from the original Part (Note that this type of “copy” does not have the
restriction on Element Representation that Part Copy does, - all Attributes can be
reassigned - but it requires considerably more memory because it does not share the
geometry with the original but now has its own copy of the geometry). The merge
operation creates anew Part. The new Part is assigned the default Display Attributesand is
also assigned to Frame 0.

(see How To Merge Parts)
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