How To ... Introduction to
B 260000 Part Creation

INTRODUCTION

Much of the strength of EnSight derives from it’s flexible and powerful part creation mechanism. Since virtually every
task you perform in EnSight will involve some form of part manipulation, it is vital to understand these concepts.

In EnSight, a partis a named collection of elements (or cells) and associated nodes. The nodes may have zero or
more variables (such as pressure or stress) currently defined at the node positions. All components of a part share
the same set of attributes (such as color or line width).

Parts are either built during the loading process (based on your computational mesh and associated surfaces) or
created during an EnSight session. Parts created during loading are called model parts. Model parts can also be
created during an EnSight session by performing a copy on other model parts.

All other parts are created during an EnSight session and are called created or derived parts. Created parts are built
using one or more other parts as the parent parts. The created parts are said to depend on the parent parts. If one
or more of the parent parts change, all parts depending on those parent parts are automatically recalculated and
redisplayed to reflect the change. As an example, consider the following case. A clipping plane is created through
some 3D computational domain and a contour is created on the clipping plane. The contour’s parent is the clipping
plane, and the clipping plane’s parent is the 3D domain. If the 3D domain is changed (e.g. the time step changes),
the clipping plane will first be recalculated, followed by the contour. In this way, part coherence is maintained.

This article is divided into the following sections:

The Parts List

Creating Parts

Part Types

Part Operations

Part Attributes

Where Parts are Created and Maintained
Hints and Tips

The Parts List

Both model parts as well as all derived parts are displayed as items in the Parts List.

Using Parts(s) A Part description
1-(M/C1) Computational mesh |-
Parent part of currently 2—(I/C1) Iso surface
selected part ------------- > P | 3-(2/Cl1) Clip_plane

d-(V/Cl) Vector Arrow part
5-(P/C1) Profile part
--=6-(T/Cl) Particle trace part
T HT7-(C/C1) Contour part

- REEEEE -Currently selected part
9-(2/C1) Clip_cylinder
lO—(ASHQI) Developed surface

_U
oY
L
~t
)
c
3
o
®
a
n

Part type symbol --------cocmiiain s Case number (important when multiple
datasets have been loaded)
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Items in the Parts List are selected using standard Motif methods:

To ... Do this ... Details ...

Select an item Select (or single-click)  Place the mouse pointer over the item and click the left mouse
button. The item is highlighted to reflect the “selected” state.

Extend a contiguous Select-drag Place the mouse pointer over the first item. Click and hold the left

selection mouse button as you drag over the remaining items to be
selected. Only contiguous items may be selected in this fashion.

Extend a (possibly long) Shift-click Select the first item. Place the mouse pointer over the last item in

contiguous selection the list to be selected. Press the shift key and click the left mouse

button. This action will extend a selection to include all those
items sequentially listed between the first selection and this one.

Extend a non-contiguous  Control-click Place the mouse pointer over the item. Press the control key and

selection click the left mouse button. This action will extend a selection by
adding the new item, but not those in-between any previously
selected items.

De-select an item Control-click Place the mouse pointer over the selected item. Press the control
key and click the left mouse button. This action will de-select the
item.

Open the Quick Double-click Place the mouse pointer over the item and click the left mouse

Interaction Area for a part button twice in rapid succession.

Creating Parts

The mechanism for creating derived parts is largely the same regardless of part type:

1. In the Parts List, select the part(s) to use as parents.

2. Click the desired feature icon. This will open the corresponding creation section for the part type in the Quick Inter-
action area.

If necessary, select a variable to use from the Variables List (e.g. for contours or isosurfaces).

Set the desired creation attributes in the Quick Interaction area. IMPORTANT: if you change a text field, you must
press return to have the change take effect!

5. Click the Create button in the Quick Interaction area.

B w

The example below shows Isosurface part creation:

1. Select the parent 3. Select the variable to use. ---- 4. Select an appropriate isovalue.
part(s). -------oeeiiaee . ,
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Usirg Parts(s) ' Show Variablé . . . » .
- — e /home /vindsockl/palner/ ensight /ensight .comnect .default

:
tenperature Starting listening socket,
Connection accepted,
.

Loordinates
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Value 1.0000e+00

Show Legend|
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Change Vafxablcj Help...
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2. Click the isosurface - - - - R L LT TR 5. Click “Create”.
creation icon.
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Part Types
The following table provides information on the available part types in EnSight:
Part Type Symbol | Feature Icon Description

Clip 2 A surface or line resulting from a clip of other parts using the Line,
Plane, Cylinder, Sphere, Cone, or Surface of Revolution tool.

Contour C Lines of constant value on 2D elements.

Developed D A planar surface derived by unrolling a surface of revolution (e.g.

Surface unrolling a clip created with the Cylinder tool).

Elevated Surface E A part created by scaling a 2D part (in the direction of the local

n surface normal) based on the value of a variable.

Isosurface I - A surface of constant value through 3D elements.

Model M 1| An original part (i.e.loaded from a disk file) or created through some
operation (e.g. copy or extract) on a model part.

Particle Trace T A part consisting of the paths taken by one or more massless
particles as integrated through a vector (typically velocity) field.

Profile P Plot of a variable along a line (the 2D counterpart to an elevated
surface).

Vector Arrow \% A part consisting of a set of arrows showing direction and
magnitude of a vector variable.

Subset S A part created by node and/or element label range(s) from model
part(s).
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Part Operations

EnSight provides several powerful part operators. These operations are accessible from the Edit > Part submenu.

Cut

Copy

Group

Delete

Extract

Merge

The cut operation slices a dependent copy of one or more parts along the surface of either the Plane
tool or one of the quadric tools. Both portions of the copy can be kept (Cut & Split) or the “back” can
be discarded (Cut & Remove). Back is defined as the negative Z side of the Plane tool or the
outside of the quadric tools. A cut produces new parts that contain valid elements of the same order
as the original parts. Variable values at newly created nodes are interpolated.

Cutting can be used to slice away portions of a model that are not needed or to create animation
effects such as “opening” closed regions to view the interior.

See How To Cut Parts for more information.

The copy operation creates a dependent copy of another part. The part is created on the client and
is not known to the server. The new part has its own set of attributes (except for representation), but
shares geometric and variable data with the original.

One of the best reasons to create a copy is to show multiple variables on one part at the same time
in a side-by-side configuration. The copies can be moved independently since each new copy is
automatically assigned a new frame.

See How To Copy a Part for more information.

This operation will collapse the selected parts into a new “umbrella” part. Grouping is most often
used to combine a series of parts into a single part for ease in handling. The part is created on the
client and is not known to the server. The operation is reversible through the Ungroup command.

See How To Group Parts for more information.

The delete operation completely removes not only the currently selected parts, but also any parts
derived from the selected parts.

See How To Delete a Part for more information.

The extract operation is closely tied to part representations. Extract creates a new dependent part
using only the geometry of the current representation of the part. For example, if the current
representation of a part consisting of 3D elements is Border, the result of extraction will be a part
consisting of all unshared 2D elements (the surface).

Extract is most often used to reduce the amount of information for a part (e.g. for faster display or for
geometry output) or to create a surface shell part — perhaps for subsequent cutting — of a 3D
computational domain.

See How To Extract Part Representations for more information.

Merge creates one new dependent part from one or more selected parts. The original parts are
unchanged. If only a single part is selected for the operation, merge will create a “true” copy of the
part (as opposed to the “shallow” copy that the Copy operation creates).

Merging is most often used to combine a series of parts into a single part for ease in handling (such
as attribute setting).

See How To Merge Parts for more information.
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Part Attributes

All parts have numerous attributes that control behavior and display. Although many attributes can be controlled
either through the Quick Interaction area or the Part Mode icons, complete access is provided by the various Feature
Detail Editor dialogs. Part attributes and the Feature Detail editors are covered in detail in How To Set Attributes.

Where Parts Are Created and Maintained

Part creation occurs on either the EnSight client or the server. Since the data that is available on the client and server
are different, it is useful to understand where parts are created and where the data is stored. For example, you can
only perform a query operation for parts that are stored on the server. The following table provides this information for
each part type:

Part Type Where Created Data on Server? Data on Client?
Clip server yes depending on representation
Contour client no yes
Developed Surface server yes depending on representation
Discrete Particle N/A yes depending on representation
Elevated Surface server yes depending on representation
Isosurface server yes depending on representation
Model N/A yes depending on representation
Particle Trace server no yes
Profile client no yes
Vector Arrow client no yes
Subset server yes depending on representation

In the last column, “depending on representation” means the current visual representation for the part. For
example, if the part’s visual representation is “Not Loaded”, then no data is currently present on the client.

Hints and Tips

With some datasets that contain many parts, it sometimes becomes difficult to maintain the connection between a
part as displayed in the Graphics Window and the corresponding item in the Parts List. To see which part(s) are
currently selected in the Parts List, select View > Show Selected Parts... This will open a new graphics window (titled
Part(s) Selected Viewport) that will display only those parts that are currently selected in the Parts List.

You can rapidly cycle through items in the Parts List using the up/down arrow keys on your keyboard. Select any item
in the list and then press the up arrow (to move to previous entries) or down arrow (to move to subsequent entries).
This is particularly helpful when used in conjunction with the Part(s) Selected Viewport window (as described above)
to quickly locate a part of interest.

You can select parts in the Parts List by picking the part in the Graphics Window. In Part Mode, select Pick Part from
the Pick pulldown. In the Graphics Window, place the mouse pointer over any portion of the desired part and press
the ‘p’ key. If you hold down the control key at the same time, the part is added to the list of currently selected parts.

Selected parts can be written to disk and loaded in a future session. Select File > Save > Geometric Entities ... You
have the option of saving either in EnSight format or in VRML format. See How To Save Geometric Entities for
more information.

SEE ALSO

User Manual: Features, Part Operations
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