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ENSIGHT © VERSION 7 END
USER LICENSE AGREEMENT

UNLESS A SEPARATE LICENSE OR TRIAL AGREEMENT
DOCUMENT EXISTS BETWEEN THE LICENSEE AND CEI
OR AN AUTHORIZED CEI DISTRIBUTOR, THE TERMS
AND CONDITIONS OF THIS AGREEMENT SHALL
GOVERN YOUR USE OF VERSION 7 OF THE EnSight
SOFTWARE. READ THIS LICENSE CAREFULLY BEFORE
USING THE EnSight SOFTWARE. BY USING THE EnSight
SOFTWARE YOU AGREE TO BE BOUND BY THIS
AGREEMENT. IF YOU DO NOT ACCEPT OR AGREE TO
BE BOUND BY THE TERMS OF THIS AGREEMENT,
PROMPTLY RETURN THE EnSight SOFTWARE UNUSED
WITHIN THIRTY (30) DAYS OF PURCHASE FOR A
REFUND.

1. LICENSE GRANT. The Licensee is hereby granted
by Computational Engineering International, Inc.
(“CELI”) a single, non-transferable and non-exclusive
license to use the EnSight Software under the terms
and conditions set forth below, in binary form only,
and at the major release level indicated on the
media used to deliver the licensed EnSight
Software.

2. DEFINITIONS.

“Ancillary Software” includes translators, user defined
data readers, tools, or other software which may from time
to time be delivered with, but separate from, the “EnSight
Software”.

“End User” means one individual running an EnSight
process.

“EnSight Purchase Agreement” means the document
provided by Licensee to CEl which describes the type of
installation Licensee is authorized to make.

“EnSight Documentation” means manuals, release or
installation notes related to the EnSight Software,
including electronic versions thereof.

“EnSight Software” means all of the CEI computer
programs that constitute standard EnSight or EnSight
Gold, the EnSight Documentation, the Third-Party
Libraries (if licensed through CEIl), and any backups or
other copies.

“Maximum Seats” means the maximum authorized
number of End Users who may simultaneously use the
licensed copy of the EnSight Software as identified in the
EnSight Purchase Agreement.

“Major Release Level” means all versions of the EnSight
Software which are denoted by the same integer number
to the left of the first decimal point in the specification of
the release. For example, all versions denoted as EnSight
7.x are regarded as the same Major Release Level.

3. USAGE LIMITATIONS. Licensee acknowledges that the
EnSight Software is proprietary and shall remain the
property of CEI. This License is not a sale. Title to and
ownership of the EnSight Software and any copies
thereof, any patents, trademarks or copyrights
incorporated therein and to the CEIl Proprietary
information shall at all times remain with CEI. No rights to

rent, loan, transfer, relicense, distribute, or otherwise
assign any or all of Licensee's rights in the EnSight
Software are granted. All rights not specifically granted to
Licensee by this license shall remain in CEIl. CEl may
include features in the EnSight Software which prevent
unlicensed use or use after license expiration. The license
granted herein does not include provision of support and
maintenance service or future releases or versions of the
EnSight Software.

INSTALLATION. EnSight may be installed and used by
the Licensee only in the manner indicated in the EnSight
Purchase Agreement. End User may use EnSight only at
his immediate workplace, unless otherwise authorized by
CEI. Subject to request of and approval by CEl, Licensee
may permanently or temporarily change the systems and /
or networks upon which Licensee is authorized to use the
EnSight Software. In either case, such change may result
in additional charges to the Licensee. Licensee may
duplicate the EnSight Software for backup, archiving, or
security, provided that each copy includes all of the
copyright or proprietary notices of the original. Licensee
shall not clone, reverse assemble, or reverse compile any
part of the EnSight Software or adopt any part of the
EnSight Software as its own. CEI reserves the right to
charge an upgrade fee for future Major Release versions
of the EnSight Software.

PATENTS AND COPYRIGHTS. EnSight is copyrighted
under the laws of the United States and international
treaty provisions. Notwithstanding the copyright, the
EnSight Software contains trade secrets and proprietary
information of CEI. Licensee acknowledges that CEl owns
these copyrights and has the following exclusive rights
with regard to the EnSight Software: to reproduce it; to
adapt, transform or rearrange it; to prepare derivative
works from it; and to control its distribution. Licensee
agrees not to act in contravention of any of CEl's
intellectual property rights.

EnSight DOCUMENTATION. Licensee may use the
EnSight Documentation only in support of its use of the
licensed EnSight Software and may print or duplicate the
Documentation (except any marked as proprietary), but
only for its internal use and provided that each copy
includes all of the copyright or related notices of the
original. CEIl will provide one (1) printed copy of the
EnSight “Getting Started” document with each license
purchased by Licensee for the EnSight Software.
Additional printed copies of the “Getting Started”
document and copies of the on-line EnSight
Documentation may be purchased from CEI.

. WARRANTY; DISCLAIMER. CEI warrants that for a

period of thirty (30) days after delivery of the EnSight
Software, it will substantially conform in all material
respects to the specifications set forth in CEI's published
EnSight Documentation. If the EnSight Software does not
meet this requirement, and Licensee notifies CEl within
thirty (30) days after delivery, CEIl will, at its option, repair
or replace the effected EnSight Software. This warranty
excludes problems caused by acts of Licensee,
unauthorized use of or causes external to the EnSight
Software, and items which would be covered under
Support and Maintenance service. CEl specifically does



not warrant, guarantee, or make any representations
regarding the use, or the results of the use, of the EnSight
Software or Documentation in terms of correctness,
accuracy, reliability, currentness, or otherwise. The entire
risk as to the result produced by and the performance of
the EnSight Software is assumed by the End User. CEI
does not warrant that the execution of the EnSight
Software will be uninterrupted or error free.

CEI WARRANTS THE ANCILLARY SOFTWARE
ACCORDING TO THE TERMS FOUND IN THE
LICENSE_AND_WARRANTY_AND_SUPPORT FILE OF
THE src DIRECTORY OF THE SOFTWARE
INSTALLATION. THE ABOVE WARRANTIES ARE CEI'S
ONLY WARRANTIES AND ARE IN LIEU OF ALL
IMPLIED WARRANTIES, INCLUDING BUT NOT LIMITED
TO THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE, AND THE ABOVE REMEDIES
ARE THE EXCLUSIVE REMEDIES FOR ANY BREACH
OF WARRANTY. NO ORAL OR WRITTEN
INFORMATION OR ADVICE GIVEN BY CEI OR ITS
EMPLOYEES SHALL CREATE A WARRANTY OR IN
ANY WAY INCREASE THE SCOPE OF THIS
WARRANTY, AND LICENSEE MAY NOT RELY ON SUCH
INFORMATION OR ADVICE. LICENSEE’S SOLE
REMEDY AND CEI'S SOLE OBLIGATION SHALL BE
GOVERNED BY THIS AGREEMENT. LICENSEE
EXPRESSLY AGREES THAT IN NO EVENT SHALL CEl
BE LIABLE FOR ANY CONSEQUENTIAL, INCIDENTAL,
OR SPECIAL DAMAGES ARISING FROM THE BREACH
OF WARRANTY, NEGLIGENCE, OR ANY OTHER
LEGAL THEORY, WHETHER IN TORT OR CONTRACT,
EVEN IF CElI HAS BEEN APPRISED OF THE
LIKELIHOOD OF SUCH DAMAGES OCCURRING,
INCLUDING WITHOUT LIMITATION DAMAGES FROM
INTERRUPTION OF BUSINESS, LOSS OF PROFITS OR
BUSINESS OPPORTUNITIES, LOSS OF USE

OF SOFTWARE, LOSS OF DATA, COST OF
RECREATING DATA, COST OF CAPITAL, COST OF
ANY SUBSTITUTE PRODUCTS, OR LOSSES CAUSED
BY DELAY. FURTHER, CElI SHALL NOT BE
RESPONSIBLE FOR ANY DAMAGES OR EXPENSES
RESULTING FROM ALTERATION OR UNAUTHORIZED
USE OF THE EnSight SOFTWARE OR FROM THE
UNINTENDED AND UNFORESEEN RESULTS
OBTAINED BY LICENSEE AND RESULTING FROM
SUCH USE. IN ANY EVENT, CEI'S MAXIMUM LIABILITY
UNDER ANY LICENSE OR OTHERWISE FOR ANY
REASON SHALL NOT EXCEED THE TOTAL AMOUNT
PAID BY LICENSEE FOR THE CEI EnSight SOFTWARE,
EXCLUSIVE OF ANY SUPPORT AND MAINTENANCE
FEES PAID. THE EXISTENCE OF MORE THAN ONE
CLAIM WILL NOT ENLARGE OR EXTEND THE LIMIT.

. THIRD-PARTY RIGHTS AND LICENSE. If Third-Party
owned graphics libraries are sublicensed to Licensee by
CEl, it will be so noted in the EnSight Purchase
Agreement. All terms related to the EnSight Software,
including and without limitation, terms related to limitation
of remedies and restrictions on use, apply to the Third-
Party Software.

LICENSE MANAGER SOFTWARE. If Licensee is
authorized to install and use License Manager Software to
enable the EnSight Software to execute on multiple
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computer systems on a network, it will be so noted in the
EnSight Purchase Agreement. All terms related to the
EnSight Software, including and without limitation, terms
related to limitation of remedies and restrictions on use,
apply to the License Manager Software. Licensees
authorized to use License Manager Software may install
multiple redundant license servers on the same network
subnet node. Installation of multiple redundant license
servers on different subnet nodes requires Licensee to
submit a written request to CEl, stating that the use of
multiple servers will not enable more than the maximum
seats of the software to be used. Furthermore, Licensee
agrees to submit License Manager log files upon request
to CEl for verification. Use of EnSight on a network is
restricted to one geographic location, unless otherwise
authorized by CEI.

U. S. GOVERNMENT RESTRICTED RIGHTS. If the
Licensee is the USA Department of Defense (“DOD”), the
licensed EnSight Software is subject to “Restricted Rights”
as that term is defined in the DOD Supplement to the
Federal Acquisition Regulations (“DFARS”) section
252.227-7013(c). If the Licensee is any unit or agency of
the U.S. Government other than the DOD, the
Government’s rights in the EnSight Software will be
defined in paragraph 52.227-19(c)(2) of the Federal
Acquisition Regulations (“FAR”). Use, duplication,
reproduction, or disclosure by the U.S. Government is
subject to such restrictions. Contractor/Manufacturer is:
Computational Engineering International, Inc., 2166 N.
Salem Street., Suite 101, Apex, NC 27523, USA.

INVOICES; PAYMENT; TAXES. Licensee agrees to pay
the License Fee(s) owed for this Software License as
shown on a separate Invoice(s) from CEIl. All Payments
will be in U. S. Dollars. Payment is due within thirty (30)
days after the date of each Invoice. Payment is
considered made when good funds are received by CEI.
To those Licensees leasing an EnSight Software License,
future Invoices for the EnSight Software Lease Fee will be
issued yearly in the month prior to that in which the initial
payment of the EnSight Software Lease Fee was made to
CEl. Licensees located in the State of North Carolina,
USA are responsible for payment to CEl of all applicable
State and Local sales taxes. Licensees located in any
State other than North Carolina in the USA are directly
responsible for payment of all State and Local sales taxes
applicable at their location. Licensees located in any
Country other than the USA are directly responsible for
payment of all import and sales taxes to the responsible
government(s) at their location. Licensees who have
obtained a License through an authorized Distributor of
CEl agree to comply with the Distributor’s payment terms
and conditions.

SEVERABILITY. If any provision of this Agreement shall
be held by a court of competent jurisdiction to be contrary
to law or not enforceable, the remaining provisions of this
Agreement shall remain in full force and effect.

EXPORT. This License and the rights granted hereunder
are subject to compliance by Licensee with all laws,
regulations, orders, or other regulations relative to export
or redistribution of Licensed Software that may now or in
the future be imposed by the government of the United
States or any agency thereof or of any other country into
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which licensed EnSight Software may be transported and
any act of noncompliance shall immediately terminate this
License. If the Licensee imports the licensed copy of the
EnSight Software into a country in which CEl has an
authorized Distributor, then if the License was purchased
the Licensee shall pay to CEIl a Penalty Fee equal to one
half the cost of the original Purchased License Fee.

TERM. If a License for the EnSight Software was
purchased by Licensee, then this license is valid upon the
date of initial payment of the Purchase License Fee to
CEl by Licensee and shall continue until an event of
Termination. If a License for the EnSight Software was
leased by Licensee, then this license is valid for twelve
(12) months from the date of initial payment of the Lease
License Fee to CEl by Licensee and shall renew for
subsequent twelve (12) month periods from the date
Licensee pays the amounts indicated on each yearly
invoice, according to Section11, unless an event of
Termination occurs.

TERMINATION. This Software License Agreement shall
terminate upon occurrence of any of the following events:
(i) the failure of Licensee to observe or perform any of the
material covenants, terms, and conditions of this
Agreement where such nonperformance is not fully
remedied by Licensee within thirty (30) days after written
notice by CEl; (ii) any breach of Sections 3, 4,6, 7, 8, 9,
or 10 hereof (effective immediately); (iii) the filing of a
petition for Licensee’s bankruptcy, whether voluntary or
involuntary, or an assignment of Licensee’s assets made
for the benefit of creditors, or the appointment of a trustee
or receiver to take charge of the business of Licensee for
any reason, or Licensee’s becoming insolvent or
voluntarily or involuntarily being dissolved; or (iv) the use
of a license purchased at an academic discount for
purposes other than teaching or academic research.
Termination of this Agreement under Section 15 shall be
in addition to, and not a waiver of, any remedy at law or in
equity. Notwithstanding the foregoing, the provisions of
Sections 4, 6, 7, 8, 9, and 10 shall survive the termination
of this agreement. Upon termination of this Software
License Agreement, Licensee shall promptly cease to use
and shall return to CEI all copies of the EnSight Software,
the Ancillary Software, and EnSight Documentation.

GENERAL. Licensee may not assign or transfer its rights
or obligations under this Agreement without the prior
written consent of CEl. The parties agree that this
Agreement shall be governed and construed by the laws
of the State of North Carolina, USA, and that no conflict-
of-laws provision shall be invoked to permit the laws of
any other state or jurisdiction. Any legal action must be
filed within one (1) year after the cause for such action
arises with the court of jurisdiction in the State of North
Carolina, USA. All preprinted additional or different terms
on any purchase order forms or other documents received
from Licensee are deemed deleted and Licensee agrees
that such terms shall be void even if the Licensee’s
documentation indicates the terms therein take
precedence over other documents. This Software License
Agreement, together with the most recent EnSight
Purchase Agreement delivered to CEI by Licensee,
constitutes the entire agreement of the parties and
supersedes any prior understandings relating to the
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subject matter, and may be amended or supplemented
only in a written agreement signed by both an officer of
CEl and the Licensee.

RESTRICTION ON USE OF TrackdAPI SOFTWARE,
developed and owned by VRCO Inc., an lllinois
corporation, with principal place of business at 330 S.
Wells Street, Suite 1200, Chicago, IL 60606; here after
referred to as “WRCO”. Licensee is prohibited from the
distribution, transfer, modification, or alteration of the
TrackdAPI software and associated written materials and/
or documentation (“TrackdAPI Software”) and shall abide
by the following:

I. PROPRIETARY RIGHTS. Licensee agrees that its use
of TrackdAPI| Software is a license only and VRCO owns
all right, title, and interest in the TrackdAPI Software
including any patents, trademarks, trade names,
inventions, copyrights, know-how and trade secrets
relating to the design, manufacture, operation or service of
the TrackdAPI Software. Nothing in this agreement should
be construed as transferring any aspects of such rights to
Licensee or any third party.

II. WARRANTY DISCLAIMER. THE LICENSED
TrackdAPI Software IS PROVIDED “AS I1S” WITHOUT
WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE IMPLIED
WARRANTIES OR MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS
TO THE QUALITY AND PERFORMANCE OF THE
LICENSED TrackdAPI Software IS ON THE LICENSEE.

[1. LIMITATION OF LIABILITY. IN NO EVENT SHALL
VRCO BE LIABLE FOR COSTS OF PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES OR FOR ANY
SPECIAL, CONSEQUENTIAL, INCIDENTAL, OR
INDIRECT DAMAGES OR LOST PROFITS ARISING
OUT OF THIS AGREEMENT OR USE OF THE TrackdAPI
Software, HOWEVER CAUSED, ON ANY THEORY OF
LIABILITY, AND EVEN IF VRCO HAS BEEN ADVISED
OF THE POSSIBILITY OF SUCH DAMAGES. LICENSEE
AGREES VRCO’S LIABILITY ARISING OUT OF
CONTRACT, NEGLIGENCE, STRICT LIABILITY IN TORT
OR WARRANTY SHALL NOT EXCEED ANY AMOUNTS
PAID BY LICENSEE FOR THE TrackdAPI Software
IDENTIFIED ABOVE.






ENSIGHT® VERSION 7 SUPPORT
AND MAINTENANCE SERVICE
AGREEMENT

UNLESS A SEPARATE AGREEMENT FOR SUPPORT AND
MAINTENANCE SERVICES EXISTS BETWEEN THE
LICENSEE AND CEI OR AN AUTHORIZED CEl
DISTRIBUTOR, THE TERMS AND CONDITIONS OF THIS
AGREEMENT SHALL GOVERN CEI'S PROVISION OF AND
LICENSEE'S USE OF AND PAYMENT FOR SUCH
SERVICES.

1. GENERAL. The EnSight Software Licensee and
Computational Engineering International, Inc.,
(“CELI") agree that the following terms and conditions
apply to the provision of Software Support and
Maintenance Service.

2. DEFINITIONS.
“Ancillary Software” includes translators, user
defined data readers, tools, or other software which
may from time to time be delivered with, but
separate from, the “EnSight Software”.
“EnSight Purchase Agreement” means the
document provided by Licensee to CEIl which
describes the type of installation Licensee is
authorized to make.
“EnSight Documentation” means manuals, release
or installation notes related to the EnSight Software
including electronic versions thereof.
“EnSight Software” means all of the CEIl computer
programs that constitute standard EnSight or
EnSight Gold, the EnSight Documentation, the
Third-Party Libraries (if licensed through CEl, as
called out on Schedule A), and any backup or copies
thereof.
“Major Release Level” means all versions of the
EnSight Software which are denoted by the same
integer number to the left of the first decimal point in
the specification of the release.

3. SOFTWARE SUPPORT SERVICE. During the term of this
Agreement CEI will provide technical support as
described below to the EnSight Software Licensee in its
use of the EnSight Software, provided that Licensee has
an active License to use the EnSight Software from CEI.
CEl will provide telephone consultation on problems
encountered in using the EnSight Software during the
Prime Time period defined as Monday through Friday,
from 8:00 AM to 5:00 PM, USA Eastern Standard Time or
Eastern Daylight Time, excluding U. S. Holidays.
Licensee is limited to five (5) hours per month of
telephone consultation. Alternatively, support requests
can be made to CEl via FAX or Electronic mail.

EnSight U.S. Support Telephone Number:(800) 551-4448
Outside U.S. Support Telephone Number:(919) 363-0883
EnSight Support FAX Number: (919) 363-0833

EnSight Support Email address: support@ensight.com

4. SOFTWARE MAINTENANCE SERVICE. During the term
of this Agreement CEI will maintain the EnSight Software
provided that Licensee has an active License to use the

EnSight Software from CEI. CEI will distribute to Licensee
one copy of new minor releases of the major release
listed on the media used to deliver the EnSight Software
including EnSight Documentation as they become
available, subject to the terms and conditions of this
Agreement. CEl may modify the terms, conditions, and
prices for services applicable to future major releases.

. EXCLUDED SOFTWARE. NO SUPPORT OR

MAINTENANCE SERVICE FOR THE ANCILLARY
SOFTWARE IS OFFERED OR PROVIDED BY THIS
AGREEMENT EXCEPT AS NOTED IN THE
LICENSE_AND_WARRANTY_AND_SUPPORT FILE OF
THE src DIRECTORY OF THE SOFTWARE
INSTALLATION.

. LICENSEE AGREEMENTS FOR SOFTWARE SUPPORT

AND SOFTWARE MAINTENANCE. In order to permit CEI
to supply the Software Support and Software
Maintenance specified above:

(i). If third party graphic libraries accompanied the
EnSight Software delivered to Licensee, as noted in
the EnSight Purchase Agreement, and such third
party issues a new version of such library software
which CEl incorporates into the Software, then
Licensee must comply with any additional licensing
or fee requirements imposed by such third party.
(ii). Licensee agrees to install minor releases, fixes,
circumventions, and corrective code to the EnSight
Software in a reasonable time after receipt thereof.
(iii). Licensee agrees to be responsible for the
installation and administration of the EnSight
Software.

(iv). Upon request by CEl, Licensee will provide the
name, address, telephone and FAX number, and
Email address (if available) of the Licensee’s contact
individual for communicating problems and
solutions.

. FEES. If Licensee is Leasing an EnSight Software

License, then the cost of the Software Support and
Maintenance Service is included in the annual EnSight
Software License Lease Fee.

If Licensee has Purchased an EnSight Software
license, then there is no separate fee for Software
Support and Maintenance Service for a period of
twelve (12) months from the date of the initial
payment of the EnSight Software License Purchase
Fee to CEI. Licensee agrees to subsequently pay
the annual EnSight Software Support and
Maintenance Service Fee(s) for subsequent twelve
(12) month periods at the then current rates when
invoiced. If an additional yearly charge for Support
and Maintenance Service for third-party graphics
libraries of license manager software accompanying
the EnSight Software is required, Licensee agrees to
pay the additional charges at the same time and at
the then current rates.

Licensees located in any State other than North
Carolina in the USA are directly responsible for
payment of all State and Local taxes applicable at
their location for this Service. Licensees located in
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any Country other than the U.S. are directly
responsible for payment of all taxes to the
government(s) at their location for this Service.
Licensees who have obtained a License through an
authorized Distributor of CEIl agree to comply with
the Distributor’s payment terms and conditions.

LIMITATION OF REMEDY AND DISCLAIMER. CEI WILL
USE ITS DILIGENT EFFORTS TO PROVIDE THE
SUPPORT AND MAINTENANCE SERVICES SPECIFIED
HEREIN. CEI MAKES NO OTHER WARRANTY OF ANY
KIND OR NATURE WITH REGARD TO THE SERVICES
TO BE PERFORMED BY CEI UNDER THE TERMS OF
THIS AGREEMENT AND ANY IMPLIED WARRANTIES,
INCLUDING THE IMPLIED WARRANTIES OF FITNESS
FOR A PARTICULAR PURPOSE AND
MERCHANTABILITY, ARE HEREBY DISCLAIMED. THE
REMEDIES SET FORTH IN THIS AGREEMENT ARE
LICENSEE’S EXCLUSIVE REMEDIES FOR ANY
BREACH OF THE TERMS OF THIS AGREEMENT. CEI
WILL NOT BE LIABLE IN ANY EVENT FOR LOSS OF
OR DAMAGE TO REVENUES, PROFITS, OTHER
ECONOMIC LOSS OR GOODWILL OR OTHER
CONSEQUENTIAL, SPECIAL, INCIDENTAL OR
INDIRECT DAMAGES ARISING OUT OF OR IN
CONNECTION WITH THE PERFORMANCE OF ITS
OBLIGATIONS HEREUNDER, INCLUDING ANY
LIABILITY FOR NEGLIGENCE WITH RESPECT TO
SERVICE PROVIDED UNDER THIS AGREEMENT
EVEN IF CEl HAS BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES. IN ANY AND ALL
CASES, CEI'S MAXIMUM LIABILITY IN CONNECTION
WITH OR ARISING OUT OF THIS AGREEMENT SHALL
NOT EXCEED THE EQUIVALENT OF ONE (1) YEAR OF
CHARGES FOR THE RELEVANT SERVICE. THE
EXISTENCE OF MORE THAN ONE CLAIM WILL NOT
ENLARGE OR EXTEND THE LIMIT.

INVOICES AND PAYMENT. To those Licensees who have
purchased an EnSight Software License, future Invoices
for the EnSight Software Support and Maintenance Fee(s)
will be issued yearly in the month prior to that in which the
initial payment of the EnSight Software License Purchase
Fee was made to CEI. Invoices shall be due and payable
within thirty (30) days of date of invoice. All payments will
be in U. S. Dollars.

Payment of invoice is considered made when good
funds are received by CEI.

OBSOLETE PRODUCTS. CEI will continue to provide
Software Support Service for the release prior to the most
current release for a period of twelve (12) months after
the release date of the most current release. At that time,
the previous release is designated as Obsolete and
Software Support Service for the Obsolete release shall
thereafter be discontinued.

TERM. The Term of this Agreement shall be from the date
payment from Licensee is first received by CEl for the
EnSight Software License Purchase Fee or the EnSight
Software License Lease Fee, whichever is applicable,
until an event of Termination.

TERMINATION. EnSight Software Support and Software
Maintenance Service hereunder may be terminated as
follows: (A) by Licensee or CEl to be effective during or
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after the first year of such Service upon giving ninety (90)
days written notice; (B) by CEI with respect to Obsolete
Products; (C) by CEl immediately and without notice, with
respect to the EnSight Software, the license for which has
expired or been terminated; (D) by CEl after ten (10) days
subsequent to providing notice to Licensee upon either (i)
nonpayment by Licensee of any Invoiced amount due
under this Agreement or the EnSight End User License
Agreement; or (ii) nonperformance by Licensee of any
other material term or condition of this Agreement.

ASSIGNMENTS. The Licensee may not assign or transfer
its rights or obligations under this Agreement, in whole or
in part, without the written consent of CEIL.

APPLICABLE LAW. The parties agree that this
Agreement shall be governed and construed by the laws
of the State of North Carolina, USA, and that no conflict-
of-laws provision shall be invoked to permit the laws of
any other state or jurisdiction. Any legal action must be
filed within one (1) year after the cause for such action
arises with the court of jurisdiction in the State of North
Carolina, USA.

GENERAL. The terms and conditions stated in this
Agreement constitute the complete and exclusive
statement of the Agreement between Licensee and CEl
and supersede all prior oral and written statements of any
kind whatsoever made by either party or their
representatives.

All preprinted additional or different terms on any
purchase order forms or other documents received
from Licensee are deemed deleted and Licensee
agrees that such terms shall be void even if the
Licensee’s documentation indicates the terms
therein take precedence over other documents.
Any waivers of or amendments to the terms and
conditions of this Agreement, to be effective, must
be in writing and signed by an officer of CEl and
Licensee.

CEI Address:

Computational Engineering International, Incorporated
2166 N. Salem Street, Suite 101, Apex, North Carolina
27523

USA
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Introduction

What’s in Getting Started?

This Getting Started manual contains the following information:
» Installation (and verification) instructions (Chapters 1 and 2).
* An introduction to the EnSight user interface (Chapter 3).

*  Some simple, step-by-step demonstrations of basic EnSight functionality (Chapters
4-7).

Conventions Used in Getting Started

The following typographic conventions are used in the Getting Started manual:
A numbered step tells you exactly what to do:

1. Change the value to “0.0” and press return.

UNIX and DOS level commands are denoted in a fixed-width font. Never type the
leading “96’ — it indicates that the command is to be issued at a shell prompt.

% ensight7.client -cm

Menu selections use “>" to indicate the selection hierarchy. For example, “Tools >
Plane > Line” means to select Plane from the Tools menu and then select Line from the
Plane cascade menu.

Notes and warnings provide particularly important information:
Note: Text emphasized in this fashion is a note.

Warning: Text emphasized in this fashion is a warning. Warnings typically indicate
that your actions may have unintended consequences.
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Where’s the Rest?

How To

User Manual

Command
Language Manual

Xiv

The remainder of the EnSight documentation (as well as a version of this manual) is
available online. The other documentation is divided into three manuals:

The How To documentation consists of relatively short articles that describe how to
perform a specific operation in EnSight, such as change the color of an object or create
an isosurface. Step-by-step instructions and pictures of relevant dialogs are included.
In addition, each How To article typically contains numerous hyperlinks (colored blue)
to other related articles (and relevant sections of the User Manual).

To access a list of the online How To articles, select Help > How To Manual.... From
this location you can easily navigate to any of the articles or to a comprehensive index.

The User Manual provides a detailed reference for EnSight.

To access the User Manual, select Help > User Manual.... From this location you can
easily navigate to any of the chapters, the table of contents, or a comprehensive index.

Note: When navigating in the online User Manual, you can easily return to the User
Manual Table Title Page by clicking on the footer text: EnSight 7 User Manual.

The Command Language Manual provides details for each command of the command
language used in EnSight. Note that this is an advanced manual which is generally not
needed by most users.

To access the Command Language Manual, select Help > Command Manual.... From
this location you can easily navigate to the table of contents or a comprehensive index.

Note: When navigating in the online Command Language Manual, you can easily
return to the Command Language Manuel Title Page by clicking on the footer text:
EnSight 7 Command Language Manual.
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1 Installation For Unix Systems

What You’ll Need
For Installation

EnSight is a powerful software package for the postprocessing, visualization, and
animation of complex datasets. One of the unique features of EnSight is its ability to
run distributed, sharing the workload between a Server process (handling data [/O and
all compute intensive functions) and a Client process (managing user-interface
interaction and graphic rendering). The EnSight Client and Server can either run on
the same computer system (stand-alone operation) or the Client can run on a
workstation and the Server can run on a remote computer system (distributed
operation).

Important: The EnSight client is designed to run on a user s workstation. It is not
designed to run on a remote machine due to its interaction with the windowing system
and graphics hardware. If it is run on a remote machine, performance will suffer and
rendering errors may occur.

If you are installing EnSight for a trial evaluation, you will be provided with a license
key file which permits you to install and execute EnSight in either stand-alone or
distributed mode on any computer system at your site for a limited amount of time.

If you have purchased or are leasing a license for EnSight, have chosen to run
distributed, and always intend to run the Client processes on the same workstation(s),
the easiest method of installation will be to node-lock the Clients to that (those)
workstation(s). If however you anticipate running the Client process from a number of
different workstations at different times, (the maximum number of concurrent EnSight
processes is governed by the number of seats for which you are licensed) then you will
need to install the EnSight License Manager.

To install and run EnSight, you will need:

A CD-ROM drive attached to a UNIX system.

2. A computer system capable of running the EnSight Client and/or Server. See
Table 1 below for a list of supported EnSight platforms.

3. If you plan to run EnSight distributed, your networking environment must support
the TCP/IP network protocol. If you can run t el net from the Client to the Server
host system, you have TCP/IP installed. If you have questions, consult your local
system administrator.

4. A valid EnSight license key. If the key information was not included with your
materials, it will be sent via FAX or email.

5. Sufficient disk space. Approximately 300 MB will be required, depending on how
many architectures are installed. Data files, some printable documentation, and
some executables can be removed after installation to save space.

6. Sufficient memory. A minimum of 128 MB of memory is recommended for
typical usage. If you work with large datasets you will require more.
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Per-platform notes:

1-2

SGI

Sun

HP

IRIX 6.5 is required. SGI periodically releases various patches to the IRIX
system software. It is vital that all recommended patches be installed for
proper EnSight operation. SGI provides patches free over the Internet: see
http://support.sgi.com.

Solaris 2.8 is required. EnSight uses the OpenGL libraries provided by Sun
for 3D graphics support for the EnSight Client. These libraries are provided
for Solaris 2.5.1 or greater. Execute the following to determine if the libraries
are installed:

%1ls -1 Jusr/openwin/lib/libG.so

If the response indicates that there is “no such file ...” the OpenGL libraries
are not installed. Contact Sun for information on how to obtain the libraries.
Sun’s OpenGL libraries support essentially all of the available graphics
systems that Sun has produced over the past few years. However, only the
Creator3D and later boards provide hardware graphics support. Since other
boards emulate the graphics in software, performance will be quite limited.

Note that EnSight will only run under the Common Desktop Environment
(CDE).

HP-UX 11.00 is required. If you are running an earlier OS level, you must
upgrade in order to run EnSight 7.

Compaq Tru64 Unix v5.1 is required. If you are running an earlier OS level, you must

IBM

Linux

upgrade in order to run EnSight 7.

AIX 5.1 is required. If you are running an earlier OS level, you must upgrade
in order to run EnSight 7. In addition, you must enable your X server to
support OpenGL. See Post Installation Instructions on page 1-8 for details.

RedHat 6.x and RedHat 7.x have been tested - other distributions based on
the Linux 2.4 kernel may work also.

Supported operating system levels and platforms are subject to change. The
most recent information can be obtained from our website:

www.ensight.com/products/hardware. html
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Vendor

Supported OS Level / Processors

SGI

IRIX 6.5 (32 or 64 bit)

HP

HPUX 11.00 (32 or 64 bit)
PA-RISC processors

HPUX 11.20 (64-bit)
[A-64 processors

Sun

Solaris 2.8 (32 or 64 bit)
Sparc processors

Compaq

Tru64 Unix v5.1 (64 bit)
Alpha Processors

IBM

AIX 5.1 (32 or 64 bit)
Power processors

Linux

Kernel 2.4
X86 (32 bit), X86-64 (64 bit), IA-64 (64 bit)

Microsoft

Windows 2000/XP
X86 (32 bit)

Table 1: Supported EnSight Platforms.

Note: All clients require OpenGL for hardware accelerated graphics performance.
Software OpenGL emulation is available through the X client (ensight7 -X)

Supported operating system levels and platforms are subject to change. The

most recent information can be obtained from our website:

Getting Started with EnSight 7
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Installation
Summary

Contacting CEI

1-4

For users with a CD-ROM drive attached to the system on which EnSight will be
installed, the instructions can be summarized as follows:

Insert the CD-ROM.

Mount the CD-ROM drive.

Select an installation directory.

Execute the installation script and follow the instructions.

Execute any required post-installation steps.

Set up the required license key(s) for your environment.

NS kv =

If the Client seats are floating, start the EnSight License Manager.

If you do not have a CD-ROM attached to the system on which EnSight will be
installed, the following steps apply:

Insert the CD-ROM on a system with a CD-ROM drive.

Mount the CD-ROM drive.

Select a temporary installation directory.

Execute the installation script and follow the instructions.

Pack up the installed files, move them to the desired host, and unpack.
Execute any required post-installation steps.

Set up the required license key(s) for your environment.

Sl A o

If the Client seats are floating, start the EnSight License Manager.

Should you encounter problems in your installation or use of EnSight, please contact
CEI support:

Email:  support@ensight.com
Hotline:  800-551-4448 (U.S)

919-363-0883 (Non-U.S.)
Fax: 919-363-0833
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Installation

1.1 Installation

The installation instructions are divided into the following five sections:

Mounting the CD-ROM and Mounting the CD-ROM on an HP System
Installing on systems with an attached CD-ROM drive

Installing on systems without an attached CD-ROM drive

Post installation instructions

Installing the EnSight license key

Mounting the CD-ROM Drive

Note: For mounting the CD on an HP system, see the next section.

1.

The EnSight CD was written under ISO9660 using Rockridge extensions. Insert
the EnSight CD into the CD-ROM drive. The drive must either be attached to the
system on which EnSight will be installed OR be attached to a machine that is
accessible (over the network) from the desired installation machine.

On many machines, the CD-ROM drive is mounted automatically when a disk is
inserted. To check for this, execute the df command. On many SGI systems, the CD-
ROM will be automatically mounted on / COROM On a Sun system running vol d, the
CD-ROM will be mounted on / cdr on cdr on.

The directory on which the CD-ROM is mounted will be referred to as CDROM DI R. If
the CD-ROM is mounted, proceed to the next section.

2.

If you do not see the CD-ROM mounted, you will have to mount it manually (or
consult your local system administrator). To mount it manually (note that you will
require root permission to perform this operation):

% nkdir /cdrom

Execute the applicable mount command for your system. Note that the actual
device name (the parameter after the “-r”” flag) will depend on how your system is
set up.

Note: The commands shown below are only examples. The actual command for your
system will depend on your platform, OS level, and system setup. See the man page on
mount or your local system administrator for more information.

System Sample Mount commands
SGI /sbin/mount -t is09660 -r /dev/rdsk/dksld4vol /cdrom
Sun /sbin/mount -f hsfs -r /dev/dsk/cOt6d0s0O /cdrom

Compaq [usr/sbin/mount -t cdfs -r -o rrip /dev/rz4c /cdrom

IBM /fusr/sbin/munt -v cdrfs -r /dev/cdO /cdrom

Linux nmount /mmt/cdrom

Getting Started with EnSight 7
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Installation

Mounting the CD-ROM Drive on an HP system

1.

Insert the EnSight CD into the CD-ROM drive. The drive must either be attached
to the system on which EnSight will be installed OR be attached to a machine that
is accessible (over the network) from the desired installation machine.

The EnSight CD was written under ISO9660 using Rockridge extensions, so you
must mount the CD using pfs _mount:

% pfs_nmountd & site specific
% pfsd 4 & [----- |
% pfs_mount -t rrip -x uni x /dev/dsk/c0t0dO /cdrom

Note: pfs_mount has a bug. If you see the error message “pfs_mount: Not owner”, or

“pfs_mount:giving up on /cdrom” you must edit /etc/group and make sure that root
belongs to 8 or less groups. If not, you must take root out of some of the groups to meet
this condition, then logout and back in to try mounting again.

Installation for Systems with Attached CD-ROM Drives

If your CD-ROM drive is attached to the system on which you wish to install EnSight,
then perform the steps described here. If not, then skip to the next section.

1-6

1.

Select an installation directory. A typical choice is/ usr/ | ocal . In the discussion
below, this directory will be referred to as | NSTALL_DI R. Be sure you have write
permission (and sufficient disk space) in this directory before proceeding. If the
directory is write protected, you may require root (superuser) status to perform the
install.
Be sure the CD is inserted and change the directory to CDROM DI R (be sure to replace
CDROM _DI Rwith the directory on which your CD-ROM is mounted as described in
the previous section):

% cd CDROM DI R
On an HP system:

% cd /cdrom
Execute the installation script:

% ./install _unix
If you do not wish to install the software in/ usr/ | ocal , change the install directory
using choice “98” on the install menu.
The install script lists the various components on the CD. Choose the option to install
EnSight.
The EnSight installation menu will present a list of components. You probably want
choice “98” which will install the software together with documentation and examples.
Following this choice you will be presented with a list of architectures to install. To
save disk space, you do not need to install the documentation on systems intended to
run only the EnSight Server. The documentation is required on any systems that will
run the EnSight Client. You may also save disk space by not installing the extra
example data sets.
After installing the needed architectures, choose “99” to go back a menu to either
install more components, or to again choose “99” to return to the main install menu.
Simple License Manager (SLiM) will automatically be installed for the architectures
selected in step 6. Should you have a floating key and wish to run the SLiM on a
different system, please see section “Installing the EnSight License Keys”.
You do not need to install EnLiten or EnVideo manually as these components are
automatically installed when you install EnSight.

Proceed to Post Installation Instructions on page 1-8.
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Installation for Systems without Attached CD-ROM Drives

If you wish to install EnSight on a system that does not have an attached CD-ROM
drive, then perform the steps described here. Two machines are discussed here: the
system on which EnSight will be installed (referred to as | NSTALL_HOST) and the
system on which the CD-ROM drive is attached (referred to as CDROM_HOST).

1. On CDROM HOST, select a temporary installation directory. In the discussion below,
this directory will be referred to as TMP_I NSTALL_DI R. Be sure you have write
permission (and sufficient disk space) in this directory before proceeding. If the
directory is write protected, you may require root (superuser) status to perform the
install.

2. Be sure the CD is inserted and change directory to COROM DI R (be sure to replace
CDROM DI Rwith the directory on which your CD-ROM is mounted as described in
the section above Mounting the CD-ROM Drive):

% cd CDROM DI R

On an HP system:
% cd /cdrom

3. Execute the installation script:
% ./install _unix

4. Follow instructions 4 through 9 outlined in the previous section (/nstallation for
Systems with Attached CD-ROM Drives).
5. Change directory to TMP_I NSTALL_DI R:
% cd TMP_I NSTALL_DI R

6. Pack up the distribution files using the t ar command and compress:
%tar -cvf CEl.tar CE
% conpress CEl.tar

7. On| NSTALL_HOST, select an installation directory. A typical choice is/ usr/ | ocal .
In the discussion below, this directory will be referred to as | NSTALL_DI R. Be sure
you have write permission (and sufficient disk space) in this directory before
proceeding. If the directory is write protected, you may require root (superuser)
status to perform the install.

8. Copy the CEl . tar. Z file from CDROM HOST to the | NSTALL_DI R directory you just
created on | NSTALL_HOST. This can be accomplished using f t p or some other file
transfer mechanism. Unless you wish to install on additional systems, you can
remove TMP_I NSTALL_DI R/CEl . t ar . Z from CDROM_HOST.

The remaining steps are performed on | NSTALL_HOST.
9. On I NSTALL_HOST, change directory to | NSTALL_DI R:
% cd | NSTALL_DI R

10. Unpack and remove the tar file:

% zcat CEl.tar.Z | tar -xvf -
%rmCEl.tar.Z

11. Be sure permissions are set correctly:

% cd CE
% ./ set _perm ssions

Proceed to the next section.
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Post Installation Instructions

Adobe Acrobat .pdf files for local printing of all EnSight 7 documentation were
installed in the | NSTALL_DI R/ CEl / ensi ght 76/ doc/ Manual s directory (see Printing
the documentation on page 4-21 for more information).

All Users All users (no matter what shell interpreter is used) must add the following commands
to their ~/. cshrc file. Be sure to replace | NSTALL_DI R with the appropriate value.

setenv CEl _HOVE | NSTALL_DI R/ CEl
set path = ( $path ${CEl _HOVE}/bin )

You will have to log out and back in again for these changes to take effect.
Existing EnSight users please read the Note: on next page.

The environment variable has the following meaning:

CEl _HOMVE The CEI installation directory.
In addition, setting the following environment variables can change EnSight’s
behavior:

CEl _ARCH The start scripts for EnSight automatically detect the

architecture of the machine you are using. To override this
auto detection you can select a specific executable by
setting this environment variable.

For example, on an SGI system, EnSight may automatically
select the 64-bit executables, sgi _6. 5_n64. To override this
and use the 32-bit executables instead, you can set:

setenv CEl _ARCH sgi 6.5 n32.

This will cause the 32-bit executables in
${ CEl _HOVE}/ ensi ght 76/ machi nes/ sgi _6.5_n32
to be used.

ENSI GHT7_I NPUT
A dynamic input device library to load with EnSight. May
be set to an input device name (i.e. polhemus) to load from
${ CEl _HOVE}/ ensi ght 76/ machi nes/ ${ CEl _ARCH}/ | i b_i nput Or to
a full path name to load from a user-specified location.

ENSI GHT7_READER
A directory which contains additional user-defined readers
to be loaded before any user-defined readers that are part of
the EnSight distribution.
If you need this capability, please see the README file in
${ CEl _HOVE}/ ensi ght 76/ src/ readers/ for more
information.

ENSI GHT7_UDW
A directory which contains additional user-defined writers
to be loaded before any user-defined writers that are part of
the EnSight distribution.
If you need this capability, please see the README file in
${ CEl HOME}/ ensi ght 76/ src/witers/ for more
information.
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ENSI GHT7_MAX_THREADS
The maximum number of threads to use for each EnSight

server. Threads are used to accelerate the computation of
streamlines, clips, isosurfaces, and other compute-intensive
operations. At this time threads are supported on all
systems that run EnSight. A maximum of 2 threads may be
used with a Standard license, while 128 threads are allowed
with a Gold license.

ENSI GHT7_MAX_CTHREADS
The maximum number of threads to use for each EnSight

client. The same 2 thread limitation applies for a Standard
license.

ENSI GHT7_MAX_SOSTHREADS
The maximum number of threads to use for each EnSight

server-of-servers. As the server-of-servers is a Gold feature,
the limit for threads is 128.

Bourne Shell Users For Bourne Shell (/ bi n/ sh) users, the following commands must be added to their
~/ . profil e file. Be sure to replace | NSTALL_DI Rwith the appropriate value.

CEl _HOVE=I NSTALL_DI R/ CEI
export CEl _HOVE
PATH=$PATH: ${ CEl _HOVE}/ bi n
export PATH

You will have to log out and back in again for these changes to take effect.

Platform-specific Certain systems require additional settings.

setiings IBM The X Server must be started with the OpenGL extension. There are a number
of ways this can be done under the Common Desktop Environment. See
/usr/ | pp/ QpenGL/ README for information.
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Installing the EnSight License Keys

Keying Overview

Key Installation

You should have received an EnSight license key file from your EnSight
representative. (If not, please contact CEI or your local distributor of EnSight). The
following provides a brief overview of the EnSight keying mechanism. The
information provided is not critical to the installation process: you can skip it or return
to it later if desired.

The EnSight Client software can be installed either node-locked or floating. The
choice for your installation was made when you purchased EnSight or requested a trial
evaluation.

In a node-locked EnSight Client installation, the systemID numbers for all EnSight
Client systems were provided to CEIL. The Client will read the license key file

(sli n7. key) to determine if it is running on a licensed host. The key file also contains
information on the licensing company and expiration date.

Note: If you are installing for a trial evaluation, you will normally be installing
EnSight as node-locked. Trial installations will use a key file which allows node-locked
operation on any computer system at your site for a limited time.

The advantage of a node-locked EnSight Client installation is that it is simple to install
—only the sl i n7. key file is required. The disadvantage is that you will only be
permitted to run the EnSight Client on those workstations for which you have
submitted systemID numbers.

If you have purchased or are leasing an EnSight license, you have the additional option
of a floating EnSight Client installation in which the Client reads the sl i n¥. key file as
before. However, the file now contains information concerning which IP networks are
valid for the license. In addition, the number of permitted seats (concurrent executions)
is tracked using the EnSight’s Simple License Manager (or SLiM). The advantage of a
floating EnSight Client installation is that EnSight can be executed from any
workstation within the given IP network as long as the maximum seat count has not
been exceeded. The disadvantage is that a system daemon (slimd) must be installed
and run in order to track the seat count.

The contents of the sl i n¥. key file are provided by your EnSight representative.

Note: All machines which will execute the EnSight Client must have access to the key
file. The Client process will always look for the file in the ${CEI HOME}/license
directory.

1. Change directory to the | i cense subdirectory:
% cd INSTALL_DI R/ CElI/license

2. Create the sl i nv. key file by doing either a) or b):

a. Ifyoureceived your key contents via email, use a text editor (e.g. vi or emacs)
to create the file sl i n7. key, then copy into it the appropriate contents from the
email, save the file, and exit the editor.

b. If you did not receive the key contents by email, you will have to type them
from the printed information you have received. Using a text editor (e.g. vi or
emacs), create the file sl i nv. key. Enter the text exactly as shown — in
particular be careful with uppercase Oand zero (0). Save the file and exit the
text editor.

Be sure the sl i nv. key file is readable by all users of EnSight. Execute:

% chrmod 644 sl i nv. key
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If you are installing a node-locked license, your installation is complete. You should
now proceed to Verifying the Installation on page 1-14. If you encountered problems,
please consult Troubleshooting the Installation on page 1-13 before contacting CEI
support.

If you are installing EnSight’s Simple License Manager, continue. Your designated
host system will act as your license manager server and is referred to here as LM _HOST.
The sl i nv. key file contains a S| i md line that describes LM HOST (the third word on
the line is the name of the system). Most installations will run a single copy of the
EnSight License Manager and will therefore have only one sl i nd line. However, it is
possible to run multiple (redundant) license managers. If this was requested, your
slinv. key file will have a sl i md line for each host. Execute the following steps for
each host, replacing LM _HOST as appropriate.

1. Logonto LM HOST.

Note: Installing EnSight will automatically install SLiM for the selected
EnSight architectures. Should you wish to install SLiM separately to a
different directory or for a different architecture, rerun the installation script
on the EnSight CD and install the SLiM license manager.

2. Change directory to the | i cense subdirectory:
% cd INSTALL_DI R/ CEl/1icense

3. Create the file slinv. key by doing either a) or b):

a. Ifyoureceived your key contents via email, use a text editor (e.g. vi or emacs)
to create the file sl i n7. key, then copy into it the appropriate contents from the
email, save the file, and exit the editor. If the machine on which you created
the file is not the same as LM HOST, you must move (using f t p or some other
file transfer mechanism) sl i n¥. key to the directory ${ CEl _HOVE}/ | i cense on
LM _HOST.

b. If you did not receive the key contents by email, you will have to type them
from the printed information you have received. Using a text editor (e.g. vi or
enmacs), create the file sl i n7. key. Enter the text exactly as shown — in
particular be careful with uppercase O and zero (0). Save the file and exit the
text editor.

4. The EnSight License Manager server will listen for connections on the socket port
number given as the first number on the applicable sl i md line of the sl i n7. key
file. If you did not specify a desired port number when you requested your key,
port number 7790 is used. If this number conflicts with other usage at your site,
you CANNOT change the key file — contact CEI for a new key.

5. Start the EnSight License Manager daemon. (Note that you must have set
${ CEI _HOVE} and the path to the bin directory, as explained in the Post Installation
Instructions, for these scripts to work — even if all you are installing is the license
manager.)

% slind_start

6. To check that the daemon is running properly:

% sl ind_status

The output should indicate that “slimd is running”. The Simple License Manager
(SLiM) is now running (if not, see Troubleshooting the Installation on page 1-13). If
you need to stop the daemon at any time, execute sl i md_st op.
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If the license manager host is rebooted, the daemon will need to be restarted. On
systems that are restarted infrequently, this is not a problem. However, you may want
to consider adding the sl i nd_st art program to your system’s boot procedures
(remember to set ${ CEI _HOVE} prior to executing sl i nd_st art ). Consult your local
system administrator for assistance.

This completes the installation process. You should now proceed to Verifying the
Installation on page 1-14. If you encountered problems, please consult
Troubleshooting the Installation on page 1-13 before contacting CEI support.

Additional information regarding SLiM can be found in
${CEI_HOME}/license/README.TXT.

Note: If you are currently using SLiM with a previous version of EnSight, you
do not need to run SLiM from the CEI install directory. However, you are
strongly encouraged to do so at this time to take advantage of any updates
made to SLiM. At some point you will be required to run SLiM from the
CEl install directory. In either case, do not try to run a previous slimd
and a new slimd at the same time. The install unix script will try to detect
your current slim7.key from a previous installation of EnSight and, if it
can, it will try to copy it into CEI_HOME/license. Should it not be able to,
you will have to do this manually.

1-12 Getting Started with EnSight 7



Troubleshooting the Installation

1.2 Troubleshooting the Installation

Problem

Probable Causes

Solution

CD-ROM does not mount or
read

EnSight’s Simple License
Manager daemon does not start

Getting Started with EnSight 7

CD not properly seated in
the drive

System problem

Several potential causes

Check that CD is properly seated.

Consult your local system administrator.

Check the Simple License Manager log
file (${ CEl _HOVE}/ | i cense/ sl i md-1 og-
HOST. t xt where HOST is the license
manager host name) for error messages
and correct as necessary.

Review: ${ CEl HOVE}/ | i cense/ README. TXT
Check system log file.

Search on “slim” or “license” on our
website FAQ’s:

www. ensi ght. coml FAQ | i cense_i ndex. ht m
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1.3 Verifying the Installation

Verifying installation is simple: the EnSight Client is started and the EnSight Server is
connected to it. In the instructions that follow, CLI ENT_HOST refers to the system on
which the EnSight Client was installed and SERVER_HOST refers to the system on which
the EnSight Server was installed. If the installation is stand-alone, then CLI ENT_HOST
and SERVER_HOST actually refer to the same system.

The instructions also assume that the environment variable CEI _HOME, as well as the
command search path have been set up correctly as described in the preceding section.

Starting EnSight for Stand-alone Use

If your installation of EnSight is stand-alone (i.e. the Client and Server are both
running on the same workstation), EnSight will automatically start and connect the
Client and Server processes transparently.

You should be logged in to the console of the workstation on which the EnSight Client
and Server have been installed. In a the shell window, start EnSight using the
ensi ght 7 shell script:

% ensi ght 7

This shell script will automatically start the Client and the Server and make the
connection. You can tell if the connection was successful by clicking the Info... button
on the right of the desktop and seeing “Connection accepted” in the EnSight Message
Window. Licensing information (licensee and expiration date) should also appear in
the lower left corner of the Graphics Window. “EnSight 7 or “EnSight 7 Gold” will
appear in the upper right corner of the graphics screen to indicate the license being
used. You can now close the EnSight Message Window and proceed to Chapter 3.

If the connection failed, please consult the next section (Troubleshooting the
Connection) before contacting CEI support.

Starting EnSight for Distributed Use

Starting the Client

Starting the Server

1. Log on to the console of CLI ENT_HOST and open at least two shell windows. Since
the EnSight user interface will open on the right side of your screen, place the two
shell windows on the left side.

2. In one of the shell windows, start the EnSight Client:

% ensight7.client -cm
The - cmoption tells the Client to begin listening for a connection from the Server.
The EnSight Client user interface should appear on your workstation screen.

3. In a different shell window on your workstation, log on to SERVER_HOST:
% t el net SERVER_HOST

4. In the same shell window as step 3, start the EnSight Server:
% ensi ght 7. server -c¢ CLI ENT_HOST

The - ¢ CLI ENT_HOST option tells the EnSight Server to connect to the EnSight
Client listening on CLI ENT_HOST.
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You can tell if the connection was successful by clicking the Info... button on the right
of the desktop and seeing “Connection accepted” in the EnSight Message Window (see
the image below). Licensing information (licensee and expiration date) should also
appear in the lower left corner of the Graphics Window. You should now proceed to
Chapter 3.

If the connection failed, please consult the next section (Troubleshooting the
Connection) before contacting CEI support.
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The EnSight Client after a successful connection with the Server process. Note the licensing
information in the lower left corner of the Graphics Window.
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1.4 Troubleshooting the Connection

Problem

Probable Causes

Solution

EnSight Client and/or Server
fails to start.

Client and Server start, but
manual connection fails.

Wrong license or license
cannot be found

Previous versions of EnSight
start when I type ‘ensight7’

Client and/or Server executables
are not found in the user’s
command search path. The
environment variable CEl _HOME is
not set correctly.

Incorrect CLI ENT_HOST provided to
the Server.

Possible networking problem.

EnSight socket ports (1105 and
1106) are in use.

The sl i n7. key file is not properly
installed in the
${ CEl _HOVE}/ | i cense directory

You have a floating license and
SLiM (slimd) is not running

CEI_HOME is not set to
installation location or your site
uses custom bin scripts which are
not correct.

Set the appropriate path and
environment variable on both

CLI ENT_HOST and SERVER HOST as
described in the previous section.

Double-check your Client’s host
name: run the host name command
on the Client system. Use the
resulting name when starting the

Server:
ensi ght 7. server -c CLI ENT_HOST

Be sure you can t el net from

CLI ENT_HOST to SERVER HOST. If
not, consult your local system
administrator for assistance.

Quit the Client. Execute the netstat
command:

your _path/netstat -a |
110

on both CLI ENT_HOST and
SERVER_HOST. If either 1105 or 1106
is listed, reboot the system. If the
problem persists, contact CEI
support.

Note: your _pat h will vary
according to machine and OS,
typically, for sgi: /usr/etc

for linux: /bin; for HP, IBM, Sun:
/usr/bin; and for Compagq: /usr/sbin

grep

Make sure the license key(s) have
been installed correctly and that all
users have read permission for the
file(s).

Review:

${ CEl _HOVE}/ | i cense/ README. TXT

Start the slimd license manager.

Be sure CEI_ HOME is set correctly,
and that CEI_HOME/bin is in your

path. If custom bin scripts used, fix
them.
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1.5 Where’s the Rest?

After installing EnSight, you should proceed to the Chapter 3, EnSight Graphical User
Interface for an introduction to the user interface and details on how to interact with
EnSight.
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2 Installation For Windows Systems

What You'll Need
For Installation

EnSight is a powerful software package for the postprocessing, visualization, and
animation of complex datasets. One of the unique features of EnSight is its ability to
run distributed, sharing the workload between a Server process (handling data [/O and
all compute intensive functions) and a Client process (managing user-interface
interaction and graphic rendering). The EnSight Client and Server can either run on
the same computer system (stand-alone operation) or the Client can run on a
workstation and the Server can run on a remote computer system (distributed
operation).

Important: The EnSight client is designed to run on a user s workstation. It is not
designed to run on a remote machine due to its interaction with the windowing system
and graphics hardware. If it is run on a remote machine, performance will suffer and
errors may occur.

If you are installing EnSight for a trial evaluation, you will be provided with a license
key file which permits you to install and execute EnSight in either stand-alone or
distributed mode on any computer system at your site for a limited amount of time.

If you have purchased or are leasing a license for EnSight, have chosen to run
distributed, and always intend to run the Client processes on the same workstation(s),
the easiest method of installation will be to node-lock the Clients to that (those)
workstation(s). If, however, you anticipate running the Client process from a number
of different workstations at different times, (the maximum number of concurrent
EnSight processes is governed by the number of seats for which you are licensed) then
you will need to install the EnSight License Manager.

To install and run EnSight, you will need:

The Ensight 7 CD.

2. A PC workstation capable of running the EnSight software. The system should

conform to the following:

*  OS must be Windows 2000, or Windows XP.

* A Network Interface Card

*  Microsoft TCP/IP installed

* A video board providing hardware accelerated OpenGL support is highly
recommended. For a list of boards that have been tested by CEI and their
respective performance, see the README.performance file located in the
performance folder.
A minimum of 64MB of memory. 128 MB or more is recommended.
300MHz or faster CPU is recommended
A screen resolution of at least 1024 by 768 is recommended.

3. Sufficient disk space. Full installation will require 180 MB of disk space.

A valid EnSight license key. If the key information was not included with your
materials, it will be sent via FAX or email.
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Contacting CEI

2-2

Should you encounter problems in your installation or use of EnSight, please contact
CEI support:

Email:  support@ensight.com
Hotline:  800-551-4448 (U.S)

919-363-0883 (Non-U.S.)
Fax: 919-363-0833
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Installation

2.1 Installation

The installation instructions are divided into the following three sections:
» Installation Procedure
* Post installation instructions

* Installing the EnSight license key

Installation Procedure

In order to install the EnSight software you will need to be logged in as administrator,
or have administrator privileges.

To install the EnSight software:

1. Place the EnSight CD in your CD-ROM drive.

2. Open Windows Explorer.

3. Double click on Setup.exe in the top directory of the CD.

4. Follow the instructions as prompted by the setup program.

Once the installation is complete, the Windows machine must be rebooted in order for
EnSight environment variables to take effect.

Post Installation Instructions

Acrobat .pdf files for local printing of all EnSight 7 documentation were installed in
the | NSTALL_DI R\ CEl \ ensi ght 76\ doc\ Manual s directory during installation (see
Printing the documentation on page 4-21 for more information).

The EnSight installation procedure sets the necessary environment variables for
executing the EnSight software. However, if you wish to inspect these variables, do
the following:

1. If Windows 2000:
Start > Settings > Control Panel > System > Advanced > Environment Variables
If Windows XP:
Start > Control Panel > System > Advanced > Environment Variables

2. Check that the following is defined:
CEI_HOME - should contain the path of the CEI directory where you installed the

EnSight software. This will typically be:
“C:\Program Files\CEI\”.

PATH - should have appended to it the EnSight client and server directory paths.

This will typically be:
“C:\Program Files\CEI\EnSight76\machines\win32”
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Installing the EnSight License Keys

Keying Overview

Key Installation

2-4

You should have received an EnSight license key file from your EnSight
representative. (If not, please contact CEI or your local distributor of EnSight). The
following provides a brief overview of the EnSight keying mechanism. The
information in the Overview provided is not critical to the installation process: you can
skip it or return to it later if desired.

The EnSight Client software can be installed either node-locked or floating. The
choice for your installation was made when you purchased EnSight or requested a trial
evaluation.

In a node-locked EnSight Client installation, the systemID numbers for all EnSight
Client systems were provided to CEI. The Client process will read the license key file
(sli n7. key) to determine if it is running on a licensed host. The key file also contains
information on the licensing company and expiration date.

Note: If you are installing for a trial evaluation, you will normally be installing
EnSight as node-locked. Trial installations will use a key file which allows node-locked
operation on any computer system at your site for a limited time.

The advantage of a node-locked EnSight Client installation is that it is simple to install
—only the sl i n7. key file is required. The disadvantage is that you will only be
permitted to run the EnSight Client on those workstations for which you have
submitted systemID numbers.

If you have purchased or are leasing an EnSight license, you have the additional option
of a floating EnSight Client installation in which the Client reads the sl i n¥. key file as
before. However, the file now contains information concerning which IP networks are
valid for the license. In addition, the number of permitted seats (concurrent
executions) is tracked using the EnSight’s Simple License Manager (or SLiM). The
advantage of a floating EnSight Client installation is that EnSight can be executed
from any workstation within the given IP network as long as the maximum seat count
has not been exceeded. The disadvantage is that a system daemon must be installed
and run in order to track the seat count.

The contents of the sl i n¥. key file are provided by your EnSight representative.

Note: All machines which will execute the EnSight Client must have access to the key
file. The Client process will always look for the file in the %CEI_HOME%\license
directory.

1. Create the sl i nv. key file, which must be located in the %CEl_ HOME%\license
directory, by doing either a) or b):
a. If you received your key contents via email, use a text editor (e.g. notepad) to
create the file sl i nv. key, then copy into it the appropriate contents from the
email, save the file, and exit the editor.

b. If you did not receive the key contents by email, you will have to type them
from the printed information you have received. Using a text editor (e.g.
notepad), create the file sl i n. key. Enter the text exactly as shown — in
particular be careful with uppercase Oand zero (0). Save the file and exit the
text editor.
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If you are installing a node-locked license, your installation is complete. You should
now proceed to Verifying the Installation on page 2-8. If you encountered problems,
please consult Troubleshooting the Installation on page 2-7 before contacting CEI
support.

If you are installing EnSight’s Simple License Manager, continue. A designated host
system will act as your license manager server and is referred to here as LM HOST. The
slinv. key file contains a sl i nd line that describes LM HOST (the third word on the line
is the name of the system). Most installations will run a single copy of the EnSight
License Manager and will therefore have only one s| i nd line. However, it is possible
to run multiple (redundant) license managers. If this was requested, your sl i nv. key
file will have a sl i nd line for each host. Execute the following steps for each host,
replacing LM HOST as appropriate.

2. Logon to LM HOST.

3. Create the file sl i n¥7. key key, which must be located in the
%CEI_HOME%\license directory, by doing either a) or b):

a. If you received your key contents via email, use a text editor (e.g. notepad) to
create the file sl i n¥. key, then copy into it the appropriate contents from the
email, save the file, and exit the editor.

b. Ifyou did not receive the key contents by email, you will have to type them
from the printed information you have received. Using a text editor (e.g.
notepad), create the file sl i nv. key. Enter the text exactly as shown — in
particular be careful with uppercase O and zero (0). Save the file and exit the
text editor.

If your system is running Microsoft Windows 2000, or Windows XP you can
optionally install the License Manager (sl i nd_ser vi ce. exe) as a system service.
Under Windows 2000 or XP you can also install or uninstall the EnSight License
Manager service at any time by running the program sl i rmst | . exe, which is found
in the UCEl _HOVE% | i cense\ machi nes\ wi n32 directory. It can also be installed as a
service from the setup.exe program at the time EnSight is installed.

If the EnSight License Manager was installed as a Windows service

(sl'i md_servi ce), it will attempt to start automatically each time you boot your
system. It will not be able to start until you have placed a valid key file (sl i nv7. key)
in the license directory, however. To check on its status, or to start it manually after
creating your key file, for Windows 2000 go to Start > Settings > Control Panel >
Administrative Tools (or for Windows XP go to Start > Control Panel > Administrative
Tools) and open the Services dialog. The sl i nd_ser vi ce should appear in the list
of services. If it is running, its status should be listed as “started”. You can also start it
manually by selecting it and clicking the dialog’s “Start” button.

You can also check the License Manager’s status by double-clicking on
sl i nd_st at us. exe in the %CEl _HOVE% | i cense\ machi nes\ wi n32 directory. This
program will contact the license manager and display a status message.

If the sl i md_ser vi ce fails to start automatically when your system comes up,
check the system and/or application error logs (using the Event Viewer) for possible
error messages. You should also check the slimd log

(YCEl _HOME\ | i cense\ sl i md- | og- HOST. t xt ). Note that the CEl. HOME
environment variable must be set for your system to run the license manager, even if
you did not install the EnSight client or server.
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The EnSight License Manager service will listen for connections on the socket port
number given at the end of the applicable sl i nd line of the sl i n¥. key file. If you did
not specify a desired port number when you requested your key, port number 7790 is
used. If this number conflicts with other usage at your site, you CANNOT change the
key file — contact CEI for a new key.

This completes the installation process. You should now proceed to Verifying the
Installation on page 2-8. If you encountered problems, please consult Troubleshooting
the Installation on page 2-7 before contacting CEI support.
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2.2 Troubleshooting the Installation

Problem

Probable Causes

Solution

CD-ROM does not mount or

read

EnSight’s Simple License

Manager daemon does not

start

Getting Started with EnSight 7

CD not properly seated in
the drive

System problem

CEI_HOME not defined
or incorrect

Key file not valid

slimd_service not
installed as windows
service.

slimd_service service not
started

Check that CD is properly seated.

Consult your local system administrator.

Set CEI HOME environment variable.

Inspect the slim7.key file for blank lines or
extra characters at end of lines

Make sure slimd_service.exe is present in
%CEl _HOVE% | i cense\ machi nes\ wi n32
directory, run slimnstl.exe

Start manually or see system and/or
application error logs for autostart failure
cause.

Check the slimd-log-HOST.txt log.
Review: UCEI _HOVE% | i cense\ READVE. TXT
Search on “slim” or “license” on our website

FAQ’s:

www. ensi ght . comf FAQ |i cense_i ndex. ht m
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2.3 Verifying the Installation

Verifying installation is simple: the EnSight Client is started and the EnSight Server is
connected to it. In the instructions that follow, CLI ENT_HOST refers to the system on
which the EnSight Client was installed and SERVER_HOST refers to the system on which
the EnSight Server was installed. If the installation is stand-alone, then CLI ENT_HOST
and SERVER_HOST actually refer to the same system.

The instructions also assume that the environment variables CEl _HOMVE and PATH have
been set up correctly as described in the preceding section.

Starting EnSight for Stand-alone Use

If your installation of EnSight is stand-alone (i.e. the Client and Server are both
running on the same workstation), you will perform an auto-connect of the EnSight
Client and Server processes.

Choose EnSight7 from the Start menu > Programs toolbar.

This will automatically start the Client and the Server and automatically make the
connection. Ifthe connection is successful, you should see “Connection accepted” in
the Status History area (just below the upper right corner of the EnSight window).
Licensing information (licensee and expiration date) should also appear in the lower
left corner of the Graphics Window. You should now proceed to Chapter 3.

If the connection failed, please consult the next section (Troubleshooting the
Connection) before contacting CEI support.

Starting EnSight for Distributed Use

Starting the Client 1. Logon to the CLI ENT_HOST. Double click the ens7cl.exe icon located in the
| NSTALL_DI RECTORY\machines\win32 folder.

2. Bring the Connection dialog up, by File > Connect Server...
3. Change the “Type” to “Manual”.

4. Click the “Connect Server” button.
5

If the SERVER_HOST is a UNIX machine, follow the “Starting the Server”
instructions in Chapter 1. If the SERVER_HOST is a Windows machine, continue
with these instructions.

Starting the Server

Log on to the SERVER_HOST. Double click (or run, if you telnet to the machine) the
ens7sv.exe icon located in the | NSTALL_DI RECTORY\machines\win32 folder.

6. In the resulting application console window, enter the name of the CLI ENT_HOST
machine.

If the connection is successful, you should see “Connection accepted” in the Status

History area (see the image on the next page). Licensing information (licensee and
expiration date) should also appear in the lower left corner of the Graphics Window.
You should now proceed to Chapter 3.

If the connection failed, please consult the next section (Troubleshooting the
Connection) before contacting CEI support.
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Troubleshooting the Connection

2.4 Troubleshooting the Connection

Problem

Probable Causes

Solution

EnSight Client and/or Server
fails to start.

Client and Server start, but
manual connection fails.

Wrong license or license cannot
be found

Client and/or Server executables
are not found in the user’s
command search path. The
environment variable(s) CEl _HOVE
or PATH are not set correctly.

Incorrect CLI ENT_HOST provided to
the Server.

Possible networking problem.

The sl i nv. key file is not properly
installed in the
%CEl _HOVE% | i cense directory

Set the appropriate path and
environment variable on both

CLI ENT_HOST and SERVER HOST as
described in the previous section.

(Do a restart of the computer after
the installation)

Double-check your Client’s host
name: use the hostname shown in
the CLI ENT_HOST application
console, resulting from starting the
EnSight client.

Be sure you can t el net from

CLI ENT_HOST to SERVER HOST. If
not, consult your local system
administrator for assistance.

Make sure the license key(s) have

been installed correctly and that all
users have read permission for the
file(s).
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2.5 Where’s the Rest?

After installing EnSight, you should proceed to the next chapter, EnSight Graphical
User Interface for an introduction to the user interface and details on how to interact
with EnSight.
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3 EnSight Graphical User Interface

This chapter provides a quick introduction to the EnSight Graphical User Interface. In
this chapter you will explore the layout of the user interface. Conventions used in the
interface (such as how to select multiple items in a list) will also be discussed.
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3.1 Tour of the GUI

The major components of the EnSight user interface are shown below.

Note: This whole upper Information Button (click to see most EnSight messages) - ----------- .

level of the GUI is referred Message/Feedback Area - ------------mmmmm i !

t the “Desktop” . '
0 asthe Leskiop Quick Interaction Area - - - ---c-aa-aaa. .
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MainMenu -------------- ""nh Bl Gamry  View Toals  Cas I il e} .
Feature lconBar «---------- v e e e R -

.-|I||4.|-rh.-d,. ol :
. . FR S C T pp— w e abs T ops B paa :
Main Parts List -« ---«------- - SN || (e \J :
LRl RS R BN .
Applr Hew Varishie Hrip *
Shoiskid  Hidsisin Line Cugsian | Line | Flans Ak | D s Fist Dgdny  brgrral. lmbae
: E A pliwemeity v, Tine Sl Node T30
Es] .
| Tl
Mode Selection Area - ------- ->- = E_
|
|
| -
=
-5

Mode lconBar - ------------1}

FILEEFT!

m B BEH BRI Eeeet.| Trami fadit. o o | = | A | e Memall|

Transformation Control Area - - - - e

Graphics Window

Main Menu The Main menu provides access to basic EnSight functionality. The Help menu (at the
far right end of the menu bar) contains items for accessing online help.

Message/Feedback The Message area displays brief messages during various operations. Note that Tool
Area Tips are available for most icons.

Information Button Clicking the Info... button will bring up the EnSight Message Window where
additional information about EnSight operations is displayed. The color of the Info...
button will indicate the type of the recent entries. Green indicates normal information,
yellow indicates warnings, and red indicates errors.
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Main Parts List The Main Parts List displays all parts associated with the current session. A part is a
named collection of elements (or cells) and associated nodes. All components of a part
share the same set of attributes (such as color or line width).

Parts are accessed via the Main Parts list. Items in the list are selected by placing the
mouse pointer over the item and clicking the left mouse button. You can extend a
selection by pressing the shift key as you click an item. Additional techniques for
selecting parts are discussed on page 3-10.

Understanding part concepts is crucial for productive use of EnSight. See section
4.5 Parts and Part Attributes for more information on parts. Also see Introduction to
Part Creation in the online documentation.

Feature Icon Bar The Feature Icon Bar contains icons associated with the major “features” of EnSight.
Clicking the left mouse button on an icon selects the feature and opens the associated
interface in the Quick Interaction area. Features include the following:

Color

Contour

Isosurface

Particle Trace

Clip

Vector Arrows

Elevated
Surface

Subset Parts

Displacement

Query/Plot
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Set the color of the parts selected in the Main Parts list.
Parts can be colored either by a constant color or based on
the value of a variable.

Create or modify a new contour (isoline) part using the
part(s) selected in the Main Parts list as parents and the
variable selected in the Variables list.

Create or modify a new isosurface part using the part(s)
selected in the Main Parts list as parents and based on an
isovalue of the variable selected in the Variables list.

Create or modify a new particle trace part using the part(s)
selected in the Main Parts list as parents and the variable
selected in the Variables list as the velocity variable.

Create or modify a new clip part using the part(s) selected in
the Main Parts list as parents. EnSight can create several
types of clips including 1D line clips, planar clips, and
quadric clips.

Create or modify a new vector arrow part using the part(s)
selected in the Main Parts list as parents and the variable
selected in the Variables list. Vector arrows display
direction and magnitude of a vector variable.

Create or modify a new elevated surface part using the
part(s) selected in the Main Parts list as parents and the
variable selected in the Variables list. An elevated surface is
a surface projected away from another surface with scaling
based on the value of a variable.

Create or modify a new subset part from node and/or
element label ranges of model parts.

Provides controls (in the Quick Interaction area) for
specifying displacements.

Provides controls for performing various query and plotting
operations.



Tour of the GUI

Interactive
Query

Solution Time

Flipbook
Animation

Keyframe
Animation

Variable
Calculator

Profile Plot

Developed
Surface

Tensor Glyph

Material Part

Vortex Cores

Shock
Surfaces/
Regions

Separation/
Attachment
Lines

Boundary
Layer
Variables

Provides controls for specifying interactive queries, which
display variable values as the mouse is moved over objects
in the Graphics Window, as the cursor tool is moved within
a volume, or at specific node, element, ijk, or xyz locations.

Provides controls for managing time for transient datasets.

Provides controls for specifying Flipbook animations.
Flipbook animations are on-screen animations that permit
graphic transformations during playback. Flipbooks can be
used to animate clipping planes and isosurfaces and are also
useful for visualizing transient data

Provides controls for specifying keyframe animations.
Keyframe animation provides sophisticated motion control
and output options for generating animations for either
online presentation (e.g. MPEQG) or video.

Opens the variable calculator, for creating computed
variables.

Create or modify a new profile plot part using the part(s)
selected in the Main Parts list as parents and the variable
selected in the Variables list. A profile plot is the 1D
counterpart of an elevated surface.

Create or modify a new developed surface part using the
part(s) selected in the Main Parts list as parents. A
developed surface is constructed by unrolling a quadric clip
about its axis of revolution.

Create or modify a tensor glyph part using the part(s)
selected in the Main Parts list (as parents) and the tensor
selected in the Variables list.

Create or modify parts which are based on the intersection
or domain of material values.

Create or modify a vortex core part using the part(s) selected
in the Main Parts list as parents and the variable selected in
the Variables list.

Create or modify a shock surface or region part using the
part(s) selected in the Main Parts list as parents and the
variable selected in the Variables list.

Create or modify separation or attachment line parts using
the part(s) selected in the Main Parts list as parents and the
variable selected in the Variables list.

Create or modify boundary layer variables

Getting Started with EnSight 7



Quick Interaction
Area

Mode Selection
Area

Tour of the GUI

The Quick Interaction area provides the interface controls associated with the current
feature selected from the Feature Icon bar. Changes in this area typically affect the
parts currently selected in the Main Parts list. For example, if the currently selected
feature (selected from the Feature Icon bar) is Color, the Quick Interaction area
provides controls for setting the color of the parts currently selected in the Main Parts
list. If the feature is Isosurface, the Quick Interaction area provides (among other
things) a numeric type-in for setting the isovalue.

Warning: If you change a text field (for example, a numeric type-in), you must press
return to have the change take effect! This applies not only to text fields in the
Quick Interaction area, but throughout the EnSight user interface.

Many of the Quick Interaction areas — those associated with created parts — provide
“Create” buttons. Clicking the Create button will build a new part (such as an
isosurface or a clipping plane) based on current settings. Once built, the new part
appears in the Main Parts list.

Some Quick Interaction areas will show a Variables list. Only variables appropriate
for the selected feature will be shown in the list. A variable must be selected before
the “Create” button is pressed.

The Mode Selection Area selects the current major mode. Each mode has an
associated set of icons that are loaded into the vertical Mode Icon bar when the mode
is active. The six modes of EnSight are:

Part Part Mode icons control various part attributes. The operation
of Part Mode icons applies only to the parts currently selected
in the Main Parts list.

|-.-..-|=

Annotation Annotation Mode provides control over various annotation
entities: text, lines/arrows, color legends, and bitmap logos.

|‘1IIF;:-

Plot Plot Mode provides control over the appearance and behavior
of plot entities. A plot entity (typically created by a query
operation) contains information for one or more X-Y plots.
Plot entities can be positioned arbitrarily within the Graphics
Window.

|-l:--'=u

Viewport Viewport Mode provides control over viewports. The
Graphics Window can be overlaid with multiple user-defined
viewports. Viewports can be sized and positioned arbitrarily

and have different backgrounds and borders.

I-1n‘:.¢-_

Frame . Frame Mode provides control over frames. A frame is a
coordinate frame of reference that can be positioned
independent of other frames. Parts can be attached to
different frames permitting sophisticated and complex
animations (e.g. exploding views). Note: By default, this mode
is not visible. See Main Menu > Edit > Preferences... General
User Interface - Frame Mode Allowed.

|lEA!F

Getting Started with EnSight 7 3-5



Tour of the GUI

Mode Icon Bar

Transformation
Control Area

View View Mode icons control various global viewing attributes.
v Note that many of the View Mode icons have counterparts in
. Part Mode — the View Mode icons act as global toggles while
W

the Part Mode Icon applies only to the parts selected in the
Main Parts list. Note: By default, this mode is not visible. See
Main Menu > Edit > Preferences... General User Interface - View
Mode Allowed.

The Mode Icon Bar displays the icons associated with the currently selected mode.
The icons are arranged in a vertical scrolling region to the left of the Graphics
Window. The Quick Icon Reference in the online documentation provides a quick
reference for all EnSight icons as well as hotlinks from the icons to relevant online
articles.

The Transformation Control Area provides icons that control various aspects of object
transformations. Transformations are accomplished by selecting the action (such as
rotate), moving the mouse into the Graphics Window, clicking and holding the left
mouse button, and dragging the mouse to achieve the desired transformation.

The Transformation Editor (opened by clicking the Transf Edit... icon) provides
precise control over all types of transformations.

The possible actions are:

Rotate Rotate: click and drag
»  left-right to rotate about the vertical axis
e up-down to rotate about the horizontal axis
*  left-right with the control key pressed to rotate about
the screen Z axis.

Translate Translate: click and drag

Sy +  left-right to translate in the horizontal direction

e up-down to translate in the vertical direction

e left-right with the control key pressed to translate in Z.

Zoom Zoom: click and drag
*  up/right to zoom out or down/left to zoom in
*  with control key pressed to pan
Zoom is implemented by moving the virtual camera.
Band Zoom Rubber-band zoom: click and hold the left mouse button
on one corner of the desired viewing region, drag to
opposite corner. An outline of the region will appear as
you drag. Release the mouse button to zoom to the
outlined region.
Reset Tools and Open the Reset Tools and Viewports dialog that permits
Viewports % easy resetting of all or some transformation operations.
Transformation : Open the Transformation Editor dialog. From within this
Editor Domnssman. ] editor, all global transforms (including scaling where

appropriate) as well as frame and tool transforms can be
controlled. There is also control of the center of transform,
look-at/look-from locations, and z-clipping.
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Look down axis Set the axis the viewer looks down.
+X| +¥Y| +Z| -X| .¥| -Z

Store/Recall Allows the user to store the current view and recall it at a
. Store| Recall .
view later time.
Undo Undo Allows the user to undo the last transformation.
Tool Tips TeolTips  CONtrols whether tool tips are displayed when the mouse is

moved over icons.

Graphics Window All 3D objects, as well as annotation entities, are displayed in the Graphics Window.

The Graphics Window can contain additional (up to fifteen) user-defined viewports as
well as X-Y plots.
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3.2 User Interface Conventions

Dialog Windows

The EnSight user interface uses standard menus, dialogs, buttons, and other interface
components (for Unix the OSF/Motif toolkit is used). This section provides
information on these components as well as instructions for interaction.

A dialog is a window that groups interface components based on function. Dialogs are
typically opened by making selections from a menu or clicking an icon. Menu
selections and icons that open dialogs always end with “...”. Most EnSight dialogs can
be opened and closed independently. In order to optimize scarce workstation screen
real estate, you should close dialogs that are not in use. The default position of each
dialog was chosen to best use the space available. You can, however, move the dialogs
using your window manager and then save the positions for subsequent sessions (select
Save Size and Position of Main Windows from the Edit > Preferences... General User
Interface dialog).

Dialogs typically consist of buttons, menus, lists, and areas to type in. Some EnSight
dialogs also have expandable sections that let you hide parts of the interface that you
use infrequently. Each expandable section consists of an indicator button, a section
title, and the contents of the section. The indicator button and the section title are
always visible. If the section is open, the contents are visible as well.

The indicator button is a toggle switch for
opening and closing the section. For Unix,
a right-pointing arrow indicates a closed
section. Clicking the arrow will open the
section. A down pointing arrow indicates
an open section. Clicking the arrow will
close the section. These indicators are
referred to as turndown buttons.

Desc

I Computational mesh

- Creation Attributes

G l - General Attributes |
- Node, Element, and Line Attributes |

Displacement Attributes

Displace By None _l|
Factor | 1.0000e-+00

(Note: For Windows, a regular toggle
button is used.)

~ I
Closel {Zi‘m;&%fel Lhdate Z&amn%l

Appby Changes I
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Menus The EnSight documentation uses the following terms to describe various types of
menus:

Menu bar A horizontal strip across the top of a dialog listing menu
titles.

Pull-down menu A pull-down menu is one accessed directly from a menu
bar.

Cascade menu or A submenu is accessed from another menu selection.
submenu  Submenu selections are indicated by a right-pointing
arrow.

Options menu or pop- An options menu is accessed by pressing the associated
up menu button. The current selection always appears as the
button title.

Menubar .... 3 File Eiit @wery View Tooks | Cass Help

Cursor
Pull-downmenu - ------------------ » Lise
Flags
EBox
Cemadrr

Tl Pl it o0

Cascademenu ... ... oo oaoao.n »

Diamond button group (Unix) .- -----.

Windows Version will not have the
diamond buttons, but selection will work
as described for diamond buttons
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Lists

Lists (such as the Main Parts list) are presented in dialogs as scrollable sections.
Various mechanisms are used to select items from a list for further action:

To... Do This... Details...

Select an item Single-click  Place the mouse pointer over the item and
click the left mouse button. The item is
highlighted to reflect the “selected” state.

Extend a Select-drag Place the mouse pointer over the first item.

contiguous Click and hold the left mouse button as you

selection drag over the remaining items to be selected.
Only contiguous items may be selected in this
fashion.

Extend a (possibly  Shift-click Place the mouse pointer over the item. Press

long) contiguous the shift key and click the left mouse button.

selection This action will extend a selection to include

all those items sequentially listed between the
previous selection and this one.

Extend a non- Control-click  Place the mouse pointer over the item. Press
contiguous the control key and click the left mouse
selection button. This action will extend a selection by

adding the new item, but not those in-between
any previously selected items.

De-select an item  Control-click Place the mouse pointer over the selected
item. Press the control key and click the left
mouse button. This action will de-select the
item.

You can also double-click list items. The result depends on the list and type of item.
For model parts in the Main Parts list, a double-click will open the Color Quick
Interaction area. For created parts, the Quick Interaction area for the corresponding
part type will open. Double-clicking variables in the Main Variables list will open the
Feature Detail Editor for Variables with the clicked variable already selected. To
double-click, place the mouse pointer over the item and click the left mouse button
twice in rapid succession.
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Buttons EnSight uses the following kinds of buttons:

Rectangular

Arrow

Diamond

Square

Arrow button

Mesh Slice X Value | | 0000e+01

Use Towl XYZ Domain Intersect Interactive Off

Bin |4 go06e. 02 Mav | g seste 03 et | g 16500 63

Create Apply Tool Change Fool Locaion... Help...

Place the mouse cursor in the button area and click the left mouse
button. Rectangular buttons typically access the function described
in the label. If the label is followed by “...” then the button opens
another dialog.

Place the mouse cursor in the button area and click the left mouse
button. Arrow buttons typically have an associated text field or
scroll bar. Clicking the button increments or decrements the text
field or scroll bar value.

Place the mouse cursor in the button area and click the left mouse
button. Diamond buttons (also called radio buttons) are toggles that
select an item from a mutually exclusive list. Exactly one diamond
button of a group can be on at any given time. Note that for the
Windows Version no diamond buttons are used, but that the
selection of items works as described here.

Place the mouse cursor in the button area and click the left mouse
button. Square buttons are toggles that access the function
indicated by the label.

Cursor _|Line _|Plane Axis | Bounds Fast Display  Legend... Info...

Rectanghlar buttons '

Square button
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Text Fields EnSight utilizes two types of text fields:

Information
Text Fields

Editable Text
Fields

These text fields are used to report information and cannot be edited
by the user. Information text fields are surrounded with a single
pixel border

Place the mouse cursor in the text field and click to insert a blinking
insertion cursor. Several techniques are available to accelerate text
editing. Select a single word by double-clicking or the entire string
by triple-clicking. Selected text is replaced by subsequent typing.
The left and right arrow keys (on most systems) will move the
insertion cursor.

Note: You must type return (while the blinking insertion cursor is
still in the field) for changes to text fields to take effect!

Where appropriate (i.e. in File Selection dialogs), EnSight recognizes the following
shortcut specifications for UNIX directories:

~/

~user nane/

A

Expands to your home directory.
Expands to the home directory of user name.
Expands to the current working directory.

Expands to the parent directory of the current working directory

(For Windows systems, one should use a \ (backslash) in place of the / (forward

slash)).

Note that standard wildcard characters (e.g. * to represent a series of zero or more
arbitrary characters) can also be used in File Selection dialogs.

3-12
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3.3 Where’s the Rest?

Once you are familiar with the EnSight user interface, proceed to the next chapter,
Simple Demonstration.

Several online articles provide overview and reference information. See the EnSight
Overview (Help > EnSight Overview...) and the Quick Icon Reference (Help > Quick
Icon Reference...).

For additional overview information, see Chapter 1 of the User Manual. Chapter 5 of
the User Manual also contains an overview of the user interface.

Finally, the table of contents and/or the index of the following, as well as internal links,
are easily navigated. For questions related to a specific task, see the How To Manual
(Help > How To Manual ...). For detailed information on a feature or concept, see the
User Manual (Help > User Manual ...).
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4 Simple

Demonstration

This chapter provides a step-by-step demonstration of basic EnSight operation. After
successfully completing this chapter, you should be able to:

Getting Started with EnSight 7

start EnSight (including the Client-Server connection),

read a dataset and load a model,

transform objects in the Graphics Window: rotate, translate, and zoom,
reset transformations,

create and manipulate additional viewports,

work with parts and change part attributes,

access the online documentation,

exit EnSight.
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4.1 Starting EnSight

If you successfully performed the installation verification as described in Verifying the
Installation on page 1-14, you have already started EnSight and connected the Client
and Server. The same operation will be performed here.

To start EnSight, execute the following instructions for your particular installation type
(stand-alone or distributed).

Starting EnSight for Stand-alone Use

For Unix Systems:

If your installation of EnSight is stand-alone (i.e. the Client and Server are both
running on the same workstation), you can use these simplified steps to start EnSight
and auto-connect the Client and Server processes.

You should be logged into the console of the workstation on which the EnSight Client
and Server have been installed. In addition, the CEI _HOMVE and other ENSIGHT7
environment variables, as well as your command search path must be set up correctly
as described on page 1-8.

1. Change to the directory containing the simple frame dataset. (The dataset
contained in this directory will be loaded into EnSight in section 4.2.)

% cd $CElI _HOVE/ ensi ght 76/ dat a/ f r anme

2. Start EnSight using the ensi ght 7 shell script:
% ensi ght 7

For Windows Systems:

Starting EnSight for

4-2

1. Choose EnSight7 from the Start > Programs > CEI menu.

This will automatically start the Client and the Server and make the connection. If you
click on the Info... button on the Desktop, you should see “Connection accepted” in the
EnSight Message Window dialog. Licensing information (licensee and expiration
date) should also appear in the lower left corner of the Graphics Window. You should
now proceed to the next section.

If the connection failed, please consult Troubleshooting the Connection on page 1-16
before contacting CEI support.

Distributed Use

If your installation of EnSight is distributed (7.e. the Client and Server are running on
different computer systems), use the steps given below to start EnSight. Note that this
operation is a manual connection. EnSight can be set up to perform the connection
automatically. See Help > How To Manual ... and click on How To Connect
Automatically for details.

In the instructions that follow, CLI ENT_HOST refers to the system on which the EnSight
Client was installed and SERVER_HOST refers to the system on which the EnSight
Server was installed.
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The instructions also assume that the CEI _HOME environment variable as well as the
command search path have been set up correctly as described on page 1-8.

For UNIX Systems:

1.

Log on to the console of CLI ENT_HOST and open at least two shell windows. Since
the EnSight user interface will open on the right side of your screen, place the two
shell windows on the left side.
In the first shell window, start the EnSight Client:

% ensight7.client -cm

The - cmoption tells the Client to begin listening for a connection from the Server.
The EnSight Client user interface should appear on your workstation screen.

In the second shell window on your workstation, log on to SERVER_HOST:
% t el net SERVER_HOST

In the second shell window, change to the directory containing the simple frame
dataset. (The dataset contained in this directory will be loaded into EnSight in
section 4.2.)

% cd $CEl _HOVE/ ensi ght 76/ dat a/ f r ame

In the second shell window, start the EnSight Server:
% ensi ght 7. server -c¢ CLI ENT_HOST

The - ¢ CLI ENT_HOST option tells the EnSight Server to connect to the EnSight
Client listening on CLI ENT_HOST.

For Windows Systems:

L.

A

Log on to the CLI ENT_HOST. Double click the ens7cl.exe icon located in the
| NSTALL_DI RECTORY\ensight76\machines\win32 folder.

Bring the Connection dialog up, by File > Connect Server...
Change the “Type” to “Manual”.
Click the “Connect Server” button.

If the SERVER _HOST is a UNIX machine, follow steps 3 through 5 in the “For
UNIX Systems” above. If the SERVER HOST is a Windows machine, continue with
these instructions.

Log on to the SERVER _HOST. Double click (or run, if you telnet in to the machine)
the ens7sv.exe icon located in the | NSTALL_DI RECTORY\ensight76\machines\win32
folder.

In the resulting application console window, enter the name of the CLI ENT_HOST
machine.

The Server should make the connection. If the connection is successful, you should
see “Connection accepted” in the Status History area (just below the upper right corner
of the EnSight window). Licensing information (licensee and expiration date) should
also appear in the lower left corner of the Graphics Window.

If the connection failed, please consult Troubleshooting the Connection on page 1-16
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before contacting CEI support.

Distributed Use - Automatic Connection

You can perform an automatic connection where the Server starts automatically and
connects to the Client, even though the two processes are on different host systems.
This type of connection requires some initial setup and is not discussed in the Getting
Started manual. However, once configured, the automatic connection lets you start a
session in a single step.

See How To Connect Automatically (Help > How To Manual ...) in the online
documentation for details.

(For information on the online help facility, see Using Online Help on page 4-20.)
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Reading a Dataset

After starting EnSight, the next step in any session is to read a dataset and load the
parts. To read a dataset, the relevant files and data format must be specified. EnSight
supports several formats common in the computational analysis field. In addition,
EnSight also supports native formats suitable for storing both block structured and
unstructured (7.e. finite-element) geometry. In this example, we will load an EnSight

native format file.

After you have successfully started EnSight (as detailed in the previous section), you

are ready to read a dataset.

1. Select File > Data (Reader)... from the EnSight Main menu.

For EnSight to properly read data, it must know both the file name and format. In this example, we
will load a simple geometry that requires only a single data file — the geometry file. Many datasets
require the specification of at least one other file that contains results (variable) information.

For UNIX: Since we initially started EnSight (in the
previous section) from the desired directory

($CEI _HOVE/ ensi ght 76/ dat a/ f r ane), this directory
is opened automatically (as seen in the Directories
list).

For Windows: You will be in the machines\win32
directory. You need to go up two levels by twice
double clicking on the .. directory, then go down to
dat a, then the f r ame directory.

2. Click frane. case in the Files list. - = - = - -« -« -2 - -

3. Be sure the Format is set to Case (it is by default).- -

4. Click (Set) Case to set the casefile to the file
currently selected in the Files list (i.e.
frane. case). - ceecoo oo

5. Click Okay to accept the selections and close the
dialog window.- - == ---=-------------

Filter

tusrlocaliC Elensigh®tEdain irame]

Sy Startag Tims Shap

Binary Filss Avs
Puth
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furr localSUE ensg h P Edats ramed’ 4 Irmmagso
.
.
.
’
%
B e 8, ol Pl i Tl b
.
.
............ s I DR [ rA Y B
Farmnst Tl
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Enfight Chdes Filled® sds Raajiiliel)

frazea . cnss

fuary les i LR s gl T a b Framia
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Apply Filiar Camcal
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See Help > How To Manual ... (and select How To Read Data) for more information
on data reading. In this case, you can also get there by clicking the Help button.
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When the File Selection dialog is closed, EnSight reads the file and opens the Data
Part Loader dialog. During the initial read, EnSight determines the individual parts
available in the file. You can choose to load all the parts, or only a subset. You can
also pick an initial visual representation for each part individually (more on this later).

6. Click Load All. This will load the parts into EnSight and
display them in the Main Parts list. - - - - - - - - - - - - - - - - _.

7. Click Close.

Ml Data Part Loader (Case) [O][=]
Unstructured Data Structured Data
Parts List

3d space frame
green arrow
blue arrow
frame base

Element Visual Rep. 3D border, 2D full
Feature Angle | i34
New Part
Description

NOTE: Variables will not be loaded for newly
created parts until this dialog is closed.

T Close Load Selected Load All Help

The four constituent parts are now listed in the Main Parts list and displayed in the

Graphics Window:

Note: To improve the legibility of the Getting Started manual, all images of the
Graphics Window are shown with a white background rather than the default black

background that EnSight uses.

See How To Read EnSight 7 Data (Help > How To Manual ...) for more information on
the Data Part Loader dialog. There is a How To Read <format> Data for each direct,

built-in reader format.
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Getting Your Data Into EnSight

EnSight supports a number of common data formats as well as interfaces to various
simulation packages. There are four different means to get your data into EnSight.

Type 1 - Direct (built-in) Readers - Are accessed by choosing the desired format in
the Data Reader dialog. These include common data formats as well as a number of
readers for commercial software. See How To Read and Load Data (Help > How To
Manual ...).

Type 2 - User-Defined readers - A library of routines is provided with EnSight to
allow users to create their own custom interfaces. Like Type 1, User-Defined Readers
have the advantage of not requiring a separate data translation step and thus reduce
user effort and disk storage requirements. A number of User-Defined Readers are
provided with EnSight; complete documentation and dummy routines may be found in
the directory SCEI_ HOME/ensight76/src/readers.

Type 3 - Stand - Alone Translators - May be written by the user to convert data into
EnSight format files. A complete description of EnSight formats may be found in
Chapter 11 of the EnSight Online User Manual. The suggested format to use is the
“EnSight Case Gold” format. Several translators are provided with EnSight. These are
found in the directory SCEI_ HOME/ensight76/translators. Translators must first be
compiled before they may be used. Some require links to libraries provided by the
vendor of the program in question. See the README files found in each translator’s
directory.

Type 4 - EnSight Formats - A growing number of software suppliers support the
EnSight formats directly, i.e. an option is provided in their products to output data in
one of the EnSight formats.

The table that follows summarizes all of the data formats and software packages for
which an interface of Type 1-4 exists. As this information changes frequently, please
consult our website (www.ensight.com/products/solvers.html) or your EnSight support
representative should you have any questions. If your format or program is not listed
here, there is the possibility that an interface does indeed exist. Contact EnSight
support for assistance. Should you create a User-Defined Reader or Stand - Alone
Translator and wish to allow its distribution with EnSight, please send an email to this
effect to support@ensight.com.

Data Format / Program Type Comments
ABAQUS 1 Direct reader for binary or ascii (.fil) files (ABAQUS STANDARD or EXPLICIT
ACUSOLVE 2 Contact vendor for information
ADAGIO 2 Use Exodus II reader
ADINA 3 Use I-DEAS neutral files and translators
ALEGRA 2 Use Exodus II reader
ANSYS 1 Direct reader for binary .rst, .rth, .rmq, .rfl files
CASE (EnSight6/EnSight Gold) 1 Native EnSight formats, EnSight6 Case and EnSight Gold Case
CFD++ 4 Exports EnSight Case format
CFD-ACE 2 Contact vendor for DTF reader
CFD-FASTRAN 2 Contact vendor for DTF reader
CFDESIGN 2 Uses Tecplot files and reader
CFF 2 User reader for Common File Format from BOEING (WIND code)
CFX4 2,3 User reader, and translator (useful if results contain massed particles)
CFX5 4 Code exports EnSight Case format
CFX-TASCflow 3 Converts TASCflow output to EnSight format (or use PLOT3D converter from vendor)
CGNS 3 User reader
COBALT 2,4 User reader (obtain from vendor) - or - Exports EnSight Case Gold format
CRAFT 4 Exports EnSight Case Gold format
CRUNCH 4 Exports EnSight Case Gold format
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Data Format / Program

Type

Comments

CTH 2 Use Exodus II reader

ECLIPSE 3 Contact CEI for details

ENSIGHT (EnSight 5) 1 Original EnSight format (unstructured)

ESTET 1 Direct reader

EXODUS I 2 User reader

FAST Unstructured 1 Direct reader for NASA FAST unstructured format

FEFLO 3 Contact vendor for information

FEMWATER 2 Use GMS reader

FENSAP 4 Contact vendor for information

FIDAP 1 Direct reader for FIDAP neutral (FDNEUT) files

FINE/Aero 1,2 Use PLOT3D or CGNS files/reader

FINE/Turbo 1,2 Use PLOT3D or CGNS files/reader

FIRE 4 Code exports EnSight format

FLOW-3D 2 User reader for FLOW-3D results (flsgrf) files

FLUENT (particle files) 3 Converts Fluent particle file to EnSight format

FLUENT 4 Code exports EnSight Casefile format

FOAM 4 Contact developer (Imperial College) for interface details
GASP 4 Exports EnSight Case format

GMS 2 User reader for GMS groundwater modeling framework, contact CEI for information
GUST 4 Exports EnSight Case format

HDF 2 Contact CEI for information

I-DEAS 3 Translator for -DEAS FEA neutral file

10/API 2 User reader for MODELS 3 framework, contact CEI for information
KIVA 2,3 Conversion routines to export EnSight format, contact CEI for info
LS-DYNA 2 User reader for d3plot files

MAYA ESC 4 Contact vendor for information

MODELS 3 2 Use IO/API reader

MOVIE.BYU 1 Direct reader for MOVIE.BYU format files

MPGS 4.1 1 Direct reader for MPGS, EnSight’s predecessor
MSC.DYTRAN 2 User reader for MSC/Dytran archive (.arc) or data (.dat) files
MSC.NASTRAN 2 User reader for binary OP2 files

MUSES/Prism 2 User reader from Thermoanalytics

NCC 2 User reader interface to National Combustion Code, contact CEI for info
N3S 1 Direct reader for the EDF code N3S

NetCDF 2 User reader, contact CEI for information

NSMB 2 User reader developed by CERFACS and CSCS

NSU2D / NSU3D 4 Contact CEI for information

PATRAN 3 Converts PATRAN neutral files to MOVIE.BYU format
PHOENICS 1 Use PLOT3D file/reader, contact CEI for information
PLOT3D 1 Direct reader for PLOT3D and FAST structured formats
POLY-3D 3 Contact vendor for information

POLYFLOW 4 Outputs EnSight Case format

POWERFLOW 3 Contact CEI for information on interfaces available

PRESTO 2 Use Exodus II reader

PRONTO 2 Use Exodus II reader

PXI 2 User reader for Parallel Exodus Interface format

RADIOSS 3 Contact vendor for interface details

RADTHERM 2 User reader from Thermoanalytics

RESCUE 2 User reader for Schlumberger reservoir modeling framework, contact CEI for information
SCRYU 2 User reader

SILO 2,3 Reads various formats supported by SILO API

SPHINX 4 Code exports EnSight format

STAR-CD (Version 3.0.5 & up) 4 Code exports EnSight Casefile format (including particle data)
STL 2 User reader for STL geometry files (may also be exported)
TAHOE 4 Contact CEI for information on interfaces available
TECPLOT 2 User reader for TECPLOT structured and unstructured formats
Telluride 4 Code exports EnSight format

UNCLE 2 User reader, contact CEI for details

UNIC-CFD 3 Contact vendor for details

USM3D 4 Contact CEI for information

VECTIS 2,3 User reader
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4.3 Performing Transformations

Performing Transformations

It’s easy to rotate, translate, and zoom the geometry displayed in the Graphics Window.

Note: By default EnSight ships with the left mouse button defined to do Transformation
Actions, the middle button defined to do Translations directly, and the right mouse

button defined to do Zoom operations directly. The assignment of operations to mouse
buttons can be customized by the user.

Rotate using the mouse:

1.
2.
3.

Select Rotate in the Transformation Control area. - - - . .. .. ... .. »
Move the mouse pointer into the Graphics Window.

Click and hold the Jeft mouse button and drag the mouse left and
right. The model rotates about the vertical (Y) axis.

Drag the mouse up and down. The model rotates about the horizontal (X) axis.
Hold down the control key and move the mouse left and right. The model rotates

about the Z axis.

Translate using the mouse:

or:

1.

Select Translate in the
Transformation Control
area.

the mouse. The model pans.

Note that the zoom operation actually moves the virtual camera rather than moving

the geometry.

2. Move the mouse pointer into the 1. Move the mouse pointer into the
Graphics Window. Graphics Window.

3. Click and hold the left mouse button |2. Click and hold the middle mouse
and drag the mouse left and right. button and drag the mouse left and
The model translates horizontally. right. The model translates horizontally.

4. Drag the mouse up and down. The |3. Drag the mouse up and down. The
model translates vertically. model translates vertically.

5. Hold down the control key and move (4. Hold down the control key and move
the mouse left and right. The model the mouse left and right. The model
translates in and out along the Z axis. translates in and out along the Z axis.

Zoom using the mouse: or:

1. Select Zoom in the
Transformation Control
area.

2. Move the mouse pointer into the 1. Move the mouse pointer into the
Graphics Window. Graphics Window.

3. Click and hold the left mouse button |2. Click and hold the right mouse button
and drag the mouse up or to the and drag the mouse up or to the right.
right. The model zooms out. The model zooms out.

4. Drag the mouse down or to the left. |3. Drag the mouse down or to the left. The
The model zooms in. model zooms in.

5. Hold down the control key and move |4. Hold down the control key and move

the mouse. The model pans.
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See How To Rotate, Zoom, Translate, Scale (Help > How To Manual ...) for more

information on model transformations.

At this point, you have probably transformed the model into a strange orientation. You
can easily reset the view to the default position and orientation.

1. Click Reset... in the Transformation Control area. This opens the
Reset Tools and Viewport(s) dialog. - - - - - - - - - - - - -

You can use this dialog to clear the selected transform operator only
(i.e. the one currently selected in the Transformation Control area), all
rotate, translate, scale transforms (but not zoom), or to “reinitialize”
the entire view. Reinitialize will not only clear all transformations, it
will also reposition the virtual camera such that all currently visible
parts are scaled to fit the Graphics Window, and make the center of
rotation to be the centroid of the visible parts.

......... » Reset...l

=+ Hesat Tosh ared Viersgorl| =)

Eeret Toolizl

By (lalsal By Folemi bl
YA =] Viewp=aat

Hsat Corsosr Hasak Lina lasak Flana
Hosat Guadric| Hasak Boox

Hormh v arwEarhisk

Rt By Seleafend | Reset Fobsied
Tramafarm Onky | Translatafosla

- P Reinitialize

beeea Pt Close Halp

See How To Reset Tools and Viewports (Help > How To Manual ...) for more

information on resetting transformations.
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You can also perform precise transformations (such as rotating 22.5 degrees about the

X axis) using the Transformation Editor.

4. Click Transf Edit... in the Transformation Control area.
This opens the Transformation Editor dialog in Global

Transform mode. - - - - ------------- oo

In this mode, changes to the Transformation Editor apply only
to the currently selected action in the Transformation Control
area (e.g. rotate or translate).

5. Select Rotate icon in the Transformation Editor dialog. - - - -
6. Select X AXiS. - - - -mrmmmmmreee

7. Place the mouse pointer in the Increment field and double- -

click the left mouse button to select the entire value

“1.000000. - = = = = === = wm e

8. Enter the value “22.5” and press return.

The model is rotated precisely 22.5 degrees about the X axis.

9. Grab the slider (click and hold the left mouse button) and
drag left and right. Note that the actual number of degrees
rotated is printed above the slider thumb switch as it is
moved.

Experiment with the Transformation Editor — set Axis to other
values or change the current action in the Transformation
Control area to edit translation or scale. (If the model doesn’t
seem to move in the translate mode, increase the increment
and limit, press return, and move the slider again.)

When you are done:

11. Reinitialize all transformations as described in steps 1-3
above.
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Performing Transformations

EnSight Hot Keys

4-12

EnSight makes use of certain keyboard keys to simplify common operations. A quick
reference is shown below. Make sure the main EnSight window is selected, then try
these function keys.

F1 - Rotate 45 degrees about x-axis (hold Control key down for -45 degree rotations)
F2 - Rotate 45 degrees about y-axis (hold Control key down for -45 degree rotations)
F3 - Rotate 45 degrees about z-axis (hold Control key down for -45 degree rotations)
F4 - Toggle on/off spin mode (Next rotate will continue to spin)
FS5 - Show standard right view (Look down the x-axis)
F6 - Show standard top view (Look down the y-axis)
F7 - Show standard front view (Look down the z-axis)
F8 - Return scene to view prior to F5, F6, or F7
(hold Control key down while pressing F5, F6, F7 will store current view to selected Fx key)
F9 - Toggle on/off full screen mode
F10 - Decrease stereo separation angle |
F11 - Increase stereo separation angle | (If hardware supports stereo)
F12 - Toggle on/off stereo display |
P key - Used for picking operations
A key - Abort keyframe animation
Control key - When held during rotates or translates, model rotates/translates about z-axis

For more information, see the online help “HowTo” sections (Help > How To Manual ...):
F1, F2, F3, F4, F5, F6, F7, F8, F9 - How To Rotate. Zoom, Translate.
F10, F11, F12 - How To Enable Stereo Viewing.

The user may also assign EnSight commands or macros to any keyboard or mouse key.
See How To Define and Use Macros (Help > How To Manual ...) for more information.
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Creating and Manipulating Viewports

4.4 Creating and Manipulating Viewports

In addition to the default viewport (which takes up the entire Graphics Window and
cannot be changed), EnSight provides up to fifteen additional user-defined viewports.
These viewports can be sized and positioned arbitrarily and can have different border
and background attributes. By default, each viewport displays all parts that are
currently visible. You can, however, have viewports that display only a subset of the

visible parts.

To create new viewports:

1. Click VPort in the Mode Selection area to enter
Viewport mode. - ------c-c-coaoon

2. Click the New Viewport icon to create a new
VIEWPOIt. «-------mmma oo

3. Click the New Viewport icon again to create another

new viewport.

R

e | ~o -9 |+ozz
ﬁ ,-e =" '=-
- -
’.

Your Graphics Window should look like the following. New viewports initially appear in columns
starting from the top left corner. Note that the second viewport created has a light green border: this
viewport is the currently selected viewport. Viewport operations (such as setting a border) operate only
on the currently selected viewport(s). To select a viewport:

4. Move the mouse pointer into the
Graphics Window and within the

bounds of the first new viewport (the

upper one with a white border).

5. Click the left mouse button to select

the viewport.
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Creating and Manipulating Viewports

You can easily resize or reposition a viewport. To reposition a viewport:

6. Place the mouse pointer within the bounds (but not too close to an edge) of the
selected viewport. The mouse cursor should be an arrow.

7. Click and hold the left mouse button and drag the viewport to the desired location.

To resize a viewport:

8. Place the mouse pointer within the bounds of the selected viewport. Move the
pointer towards one of the corners until the cursor changes to an arrow and right-
angle.

9. Click and hold the left mouse button and drag the viewport corner to the desired
location.

You can also move a single viewport edge by positioning the pointer over an edge,
clicking, and dragging. Experiment with resizing and repositioning the viewports.

Viewport mode is exclusively for changing the properties of viewports. You cannot
work with parts or rotate objects while in Viewport mode. To return to normal
operation, change the mode from Viewport to Part.

10. Click Part in the Mode Selection area to enter Part mode.
11. Click Rotate in the Transformation Control area.

12. Move the mouse into the Graphics Window and into one of the new viewports you
created. Note that the selected viewport is no longer highlighted with the light
green border.

13. Click the left mouse button and drag to rotate the objects in the viewport.

The other viewports are unchanged — each viewport maintains its own set of
transformations.

User-defined viewports can easily be deleted when they are no longer required:

14. Click VPort in the Mode Selection area to enter
Viewport mode.

15. Move the mouse pointer into the Graphics Window
and within the bounds of one of the two viewports
you created. Click to select the viewport.

16. Click the Delete icon (or hit the “Del” key on the
keyboard while the mouse is in the graphics window)
to remove the viewport. . - ... ... ... __._.__._.

You will be asked to confirm the deletion.

17. Delete the second viewport you created as well.

See How To Define and Change Viewports (Help > How To Manual ...) for more
information.
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4.5 Parts and Part Attributes

Since virtually every task you perform in EnSight involves some form of part
manipulation, it is vital to understand how parts work.

Parts are either built during the loading process (based on your computational mesh
and associated surfaces) or created during an EnSight session. Parts created during
loading are called model parts. Model parts can also be created during an EnSight
session by performing geometric operations (such as a copy) on other model parts.

All other parts are created during an EnSight session and are called created or derived
parts. Created parts are built using one or more other parts as the parent parts. The
created parts are said to depend on the parent parts. If one or more of the parent parts
change, all parts depending on those parent parts are automatically recalculated and
redisplayed to reflect the change. Examples of created parts include clipping planes,
isosurfaces, isocontours, and particle traces.

Only model parts will be used in this section. The next two chapters will work with
created parts.

The Main Parts list provides access to all parts. Each part is listed individually in a
scrollable list. Each entry provides a part descriptor (name) and three additional pieces
of information:

Part b . d Select Part(s} To Operate On

art number (assigne 1-(M/C1) 3d space frame <€ - - - - - - Part Descriptor
by EnSight) - - - - - - - - - - - - 2-(M/C1} green arrow

3-({M/C1) blue arrow

4-{M/C1} frame base

Do ]
Part type code (M P
indicates a Model part) - - - - - - ---. "7 TTToTcC Case number

EnSight provides a large number of attributes that can be edited on a per-part basis.
Attributes control the appearance or behavior of parts. Examples include visibility,
color, line width, and transparency. Part attributes are typically edited in Part Mode.
Some part attributes controlled through Part Mode icons also have a counterpart in a
View Mode icon that acts as a global toggle for the attribute. For example, View Mode
has an icon for hidden surface that enables/disables shaded surface display for all parts.
Part Mode has a hidden surface icon that enables/disables shaded surface display on a
per-part basis.

Many operations in EnSight (such as setting attributes) require that the parts to be
acted on are selected (highlighted) prior to the operation. Items in the Main Parts list
are selected by placing the mouse pointer over the item and clicking the left mouse
button. You can extend a selection by pressing the shift key as you click an item.
Additional techniques for selecting items in lists are discussed on page 3-10.

In the remainder of this section, we will explore parts and changing part attributes.
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The last operation performed was to delete the two viewports we had created. If
necessary, reset the transformations to return to the default view (as described on
page 4-10).

The first task is to enable hidden surface (shaded) display. By default, the part-specific
shaded attribute (as set in Part Mode) is on. By toggling on the corresponding Shaded
toggle on the Desktop, we enable hidden surface display for all parts.

1. Click the Shaded Toggle on the Desktop to enable shaded
surface display for all parts. - = === -------ccaaaa-- P [Shaded _|Hidden Line CICursor _ILine _IPlane

All objects in the Graphics Window are now displayed with shaded
surfaces rather than the default wireframe. We can now selectively disable S;’f’::;g;’;::’;:i":;ﬁon ~
shaded display for individual parts. - « =« ==« e cceem i

3-(M/C1) blue arrow

2. Select the “green arrow” and “blue arrow” parts in the Main Parts list: 4-(MIC1) frame base
place the mouse pointer over the green arrow part, click the left mouse
button, and drag down until both parts are highlighted.

.

Click Part in the Mode Selection area to enter Part mode. = !

4. Click the Part Shaded Toggle to disable shaded surface display for the
selected parts (you may have to scroll the vertical Mode Icon bar to
reveal the icon).- === -=--=----c-m-mmrrmn e

Note that the Part Shaded Toggle icon changes (the wireframe side is now

highlighted) to reflect the fact that the selected parts have shaded disabled.
Let’s change the line width of the selected parts: %I
5. Click the Part Line Width pulldown and select 3 Pixels from the menu, _ :é:il
Note that the line width of the selected parts (the arrows) has increased. B *_ :Z"::::
6. Select the “frame base” part in the Main Parts list. )
7. Click the Part Visibility Toggle to disable display of the part. .~

""" » [Red

After these operations, the geometry in your Graphics Display should look
like the following.
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Parts are assigned a default color when loaded into EnSight. These colors are
constant, meaning that every portion of the part is colored the same. Parts can also be
colored by a variable value. Since the value associated with a variable typically varies
from node to node, the displayed color will vary across the surface of the part.

To change part colors:

8. Select all the parts in the Main Parts list: choose Edit

> Part > Select All.

9. Click the Color icon in the Feature Icon bar.- - - - - -

The Quick Interaction area for color opens. Note that
the Color by menu is set to Constant Color.

10. Click the Mix... button to open the Color Selector

dialog. - - - - e e

11. Pick a shade of gray from the bottom row of the
color palette and click Apply at the bottom of the
dialog.

12. Click Close to close the Color Selector dialog.

Note that all parts in the Graphics Window are now
colored by the same shade of gray.

Although this dataset has no associated variable data, we

can still color the parts by a variable since EnSight
provides some defaults: Coordinates and Time. The
Coordinates variable treats the XYZ coordinate of a
node as a vector; color is assigned based on the
magnitude of that vector.

13. Select (single-click) Coordinates in the Variables list

14. In the Quick Interaction area, click Apply New

Variable, « -« cmcemme i

Note the color change. The left rear post of the frame is

closest to the origin of the coordinate system and is
colored blue.

! Vector : |
Color By Constant Color Component Magnitude i

Coordinates Mix...I R | 100 G | 000 B | 0.00
Time

Apply New Variable | Help... |
A

See How To Change Color (Help > How To Manual ...) for more information.
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Up to this point, all parts have been selected by clicking in the Main Parts list. You
can also select parts by picking them in the Graphics Window. Although this dataset
contains only four parts, most geometries contain many more and selecting parts via
the list can become tedious. To select parts by picking:

15. Move the mouse into the Graphics Window and place the pointer
over the arrow on the left side of the model.

16. Press (and release) the ‘p’ key on the keyboard.

Look at the Main Parts list: the “green arrow” part (number 2) should
now be the only part selected. (If this is not the case, be sure the
mouse pointer is directly over one of the lines of the part and press the
‘p’ key again.)

17. Move the mouse pointer over the arrow on the right side of the
model.

18. Press and hold the control key. With the control key still down,
press and release the ‘p’ key.

Holding down the control key during the pick extends the current L-(M/CT) 34 space frame
selection: both the “green arrow” and the “blue arrow” parts should
now be selected in the Main Parts list. See How To Select Parts (Help
> How To Manual ...) for more information.

3-(M/C1) blue arrow
4-{M/C1) frame base

If a dataset contains many parts, it can be difficult to determine which

parts in the Graphics Window correspond to the parts selected in the

Main Parts list. To display selected parts only:

19. Select View > Show Selected Part(s)... from the Main menu.

This opens a new graphics window (titled Selected Part(s) Window)

that displays only the arrow parts.

20. Select View > Show Selected Part(s)... again to remove the
window.

21. Click the Part Shaded Toggle to enable shaded surface display for
the selected parts (you may have to scroll the vertical Mode Icon
bar to reveal the icon). -

22. Select the “frame base” part in the Main Parts list.
23. Click the Part Visibility Toggle to enable display of the part.. - - - - - - - - -

EnSight can display node and element labels on selected parts. The
label values are either provided explicitly from the dataset or are
provided by EnSight. To display node labels:

24. Click the Node Label Toggle (you may have to scroll the vertical
Mode Icon bar to reveal the icon) to enable node display for the

“frame base” part. - - - - - - - oo oo %EE

See How To Display Labels (Help > How To Manual ...) for more information.
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After these operations (and some rotate and zoom transformations) your Graphics
Window should look something like the following. (Note that the node labels have
been colored black here to contrast with the white background — your labels will be
white on a black background.)
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4.6 Using Online Help

EnSight 7 provides two types of documentation online:

How To The How To documentation consists of relatively short articles that describe how to
perform a specific operation in EnSight, such as change the color of an object or create
an isosurface. Step-by-step instructions and pictures of relevant dialogs are included.
In addition, each How To article typically contains numerous hyperlinks (colored blue)
to other related articles (and relevant sections of the User Manual).

User Manual The User Manual provides a detailed reference for EnSight.

Several documents are directly accessible from the main Help menu. The remainder
can be accessed through hyperlinks, a table of contents, or an index. Most of the
complex dialogs within EnSight have help buttons that will open a How To article. To
open the How To table of contents:

1. Select Help > How To Manual...

The EnSight online documentation uses the Acrobat® Reader software from Adobe Systems, Inc. Acrobat
Reader provides much the same functionality as a World Wide Web browser while providing greater
control over document content

. . . P HowTo.pdf [=][o] (]
quality. The user interface is RN S : Hele
very simple and provides n|& & E|H&[T e« » n|e o |Dolm| s '

1 111 1 1 [ Bookmarks {Thumbrails > * 2
intuitive navigation controls. B i . |
Tttt : %.mmmnn How To ... . Table of Contents | ||~
. 3 Start EnSight
Besides the use of Bookmarks . -|t;-mrmm s mevne- - <= jnt-h ? G008 1
. . . ' I [ Sawe or Qutput
for navigation, The following + |||y [ wmenpusts viewing perams Introduction ' Manipulate Tools
b d 1 b [ Manipulate Tools Use the Online Documentation . Use the Cursor (Point) Tool
. " Using The How To Manual Use the Line Tool
Can e use * [ b D Visualize Data EnSight Overview D Use the Plane Tool
' I [ Create and Manipulate ‘ar 1 Use the Cylinder Tool
. . . . I [ Query, Probe, Plot Start EnSight ' Use the Sphere Tool
* Clicking on the house icon ! ||; [ wenpuats pars Cannect Automatically : Uss the Cone Tool
. ' b [ animate Command Line Start-up Options . Use the Surface of Revolution Tool
will return you to the How | ||s [ amotete R ' Visualize Data
' I [ Configure EnSight Read and Load Data ' Introduction to Part Creation
To table of contents. . - - - .. « ||p O miscananeous Read Data ' Create Contours
[ Index Load Multiple Datasets (Cases) ' Create Isosurfaces
. . . . . Load Transient Data J Create Particle Traces
* Blue text is a link: clicking Use Sever of Servers ' Create Clip Lines
. . . Read EnSight Gold Data 1 Create Clip Planes
Read EnSight 5 Data 1 Create Quadric Clips
on it will Jump to a new Read EnSight 6 Data . Create LIK Clips
. Read ABAQUS Data Create XYZ Clips
location. --------mmmmmea e I Read ANSYS Data : Create XYZ Box Cli
Read ESTET Data : C:(;:lz Vecloro,l)\(rrclu?a:
Read FAST Unstructured Data Create Elevated Surfaces
o You can gO baCk to the Read PLOT3D Data ' Create Profile Plots
. 1 . d b Read FIDAP NEUTRAL Data : Create Developed (Unrolled) Surfaces
T 1 1 a Read Fluent Universal Data Create Subset Parts
p cvious y viewe p ge y Read MOVIE.BYU Data ' Create Tensor Glyphs
. . Read MPGS Data ' Display Displacements
Cllell’lg the baCk button Read N3S Data 1 Display Discrete or Experimental Data
. . Read User Defined ' Change Time Steps
(very similar to a Web Do Structured Extraction : Greate Glips
Extract Vortex Cores
Save or Output ' - .
.......................... [ ey == GO oo o0 Extract Separation and Attachment Lines
browser)' i“e ‘:"‘he‘;"l:lre "é‘h’a‘ivj i E:lracl Shock Slu'rfaces I
ecord an lay Commans iles
. . Print/Save an Image Create and Manipulate Variables
The How To articles are heavily Save Geometric Entiies Activate Varisbles
1' k d d 1 'd SavelRestore Context Create New Variables
Cross-linked and also pI‘OVl c Save Scenario Extract Boundary Layer Variables
Edit Color Palettes
. . Manip Viewing F s
llnkS tO I'CleVal’lt SeCthIlS Of the Rotate, Zoom, Translate, Scale Query, Probe, Plot
U Z Set Drawing Mode (Line, Surface, Hidden Line) Get Point, Node, Element, and Part Information
Set Global Viewing Parameters Probe Interactively
ser Manual. Set Z Clipping Query/Plot
Set LookFrom / LookAt Change Plot Attributes
. . . Set Auxiliary Clipping Query Datasets
FOI‘ more lnfOI‘matIOIl on USIIlg Define and Change Viewports
. . Save and Restore Viewing Parameters Manipulate Parts
Create and Manipulate Frames Change Color
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Reset Tools and Viewports Copy a Part
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Printing the
documentation

To access the User Manual table of contents:

Click the iconify button to close the Acrobat Reader window.

Using Online Help

Select Help > User Manual... from the EnSight Main menu, then click “Table of Contents” on the

title page.

The User Manual
contains blue
hypertext links just
like the How To
articles: you can click
on items and jump to
a new location:

chapter and section
entries in the table of
contents

index entries in the
index

cross references in the
text that begin “See

ER]

the footer of every
page will jump back
to the title page of the
User Manual (from
which you can jump
to any chapter). - - - - .
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EnSight Case Reader
EnSight5 Reader

ABAQUS Reader

ANSYS RESULTS Reader.
ESTET Reader

FAST UNSTRUCTURED Reader
FIDAP NEUTRAL Reader .
FLUENT UNIVERSAL Reader
Movie BYU Reader .. ...
MPGS 4.1 Reader

N3S Reader

PLOT3D Reader

22UserDefinedReaders . . ......... ... ... ... .. L

2.3 Other External Data Sources

External Translators. . . . .

Exported from Analysis Codes. . . . .

2.4 Command Files

Saving the Default Command File for EnSight Session. .

25ArchiveFiles ... ...

Saving and Restoring a Full backup

2.6 Context Files

Saving a Context File. . . .
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Adobe Acrobat .pdf files for all documentation are included on the EnSight CD
distribution (and were placed in the SCEI_HOME/ensight76/doc/Manuals directory

during the installation process). These documents (GettingStarted.pdf, HowTo.pdf, and
UserManual.pdf) have been optimized for printing and formatted for letter-size paper.

You can open these files and print any or all pages from within Acrobat, or you can
send them out for printing.
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Exiting EnSight
4.7 Exiting EnSight

All EnSight actions have a counterpart in the EnSight command language. During a
session, all actions are being recorded to a default command file. When you exit
EnSight, you have the option of saving this command file.

To quit EnSight:

1. Select File > Quit... from EnSight’s Main menu. The Quit

Conﬁrmation dlalog Opens | Save Command Backup File Ta:

femrfbopdeneiglla AaliiPdg

_| Sawve Full Backup Archive File Ta:

2. Click Yes to exit EnSight.- -« ==« -vcmmmmaaaaaa - ernslghiofod 153 arehive

Do you really want to exit?

EI Cancel I

If you toggle on Save Command Backup File To and save the commands (for example,
to a file called fi | e. cnd), you could then start a subsequent Unix version EnSight
session (from the same starting directory) with the command:

% ensight7 -p file.cnmd

(assuming you are running stand-alone) to duplicate the entire session. You could
accomplish the same thing by starting EnSight normally and then playing the
command file from the command dialog (this would be the normal way to do it in the
Windows version). See How To Record and Play Command Files (Help > How To
Manual ...) for more information.

Note that the Quit Confirmation dialog also provides an option to save a “Full Backup
Archive File”. An archive (which is saved for both the Client and the Server), contains
a binary dump of the complete state of the system. Unlike replaying a command file
(which has to re-execute every action), the restoration of an archive occurs very fast
since only the saved state is restored. See How To Save or Restore an Archive (Help >
How To Manual ...) for more information.
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4.8 Where’s the Rest?

Where’s the Rest?

After successfully completing this tutorial, you should proceed to the next
demonstration. Although the next tutorial contains some material applicable to all
users, it is intended primarily for analysts doing computational fluid dynamics (CFD)
work. If your application area is not CFD, you may wish to consider skipping the next
chapter and proceeding directly to Chapter 5.

The How To Manual contains details on the operations covered in the chapter. The
following online articles are relevant to the topics covered here.

Note: you get to these by selecting Help from the main menu, then How To Manual...,

then the topic indicated below:

Consult...

How To Read Data

How To Read <format>
Data

How To Rotate, Zoom,
Translate, Scale

How To Reset Tools and
Viewports

How To Define and Change
Viewports

How To Select Parts

How To Set Attributes

Getting Started with EnSight 7

For More Information On...

specifying data to read into EnSight

reading the <format> built-in reader data format.

performing transformations in the Graphics Window
as well as performing precise transformations using
the Transformation Editor

resetting transformations back to the default settings

creating and editing user-defined viewports

selecting parts

setting part attributes
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5 Flow Visualization Example:
Unstructured Mesh

This chapter provides step-by-step instructions for performing many basic
postprocessing operations — especially those relevant to computational fluid dynamics
analysis. After successfully completing this chapter, you should be able to:

Getting Started with EnSight 7

create a clipping plane and display contours and vector arrows on the plane,
move the clipping plane with the mouse (interactive clipping),

create an isosurface and change the isovalue interactively,

create a single particle trace and a rake of traces,

move the rake of traces with the mouse (interactive particle tracing),
animate particle traces,

save an image of the Graphics Window to a file.

5-1



Starting EnSight

5.1 Starting EnSight

Starting EnSight for

For Unix Systems:

If you successfully performed the installation verification as described in Verifying the
Installation on page 1-14, you have already started EnSight and connected the Client
and Server. The same operation will be performed here.

To start EnSight, execute the following instructions for your particular installation type
(stand-alone or distributed).

Stand-alone Use

If your installation of EnSight is stand-alone (i.e. the Client and Server are both
running on the same workstation), you can use these simplified steps to start EnSight
and auto-connect the Client and Server processes.

You should be logged in to the console of the workstation on which the EnSight Client
and Server have been installed. In addition the CEl _HOME environment variable, as well
as your command search path, must be set up correctly as described on page 1-8.

1. Change to the directory containing the acrospace dataset. (The dataset contained in
this directory will be loaded into EnSight in section 5.2.)

% cd $CElI _HOVE/ ensi ght 76/ dat a/ ami

2. Start EnSight using the ensi ght 7 shell script:
% ensi ght 7

For Windows Systems:

1. Choose EnSight7 from the Start > Programs > CEI menu.

This will automatically start the Client and the Server and make the connection. To
see if the connection is successful, you can click on the Info... button on the Desktop.
You should see “Connection accepted” in the EnSight Message Window which comes
up. Licensing information (licensee and expiration date) should also appear in the
lower left corner of the Graphics Window. You should now close the EnSight Message
Window and proceed to the next section.

If the connection failed, please consult Troubleshooting the Connection on page 1-16
before contacting CEI support.

Starting EnSight for Distributed Use

5-2

If your installation of EnSight is distributed (i.e. the Client and Server are running on
different computer systems), use the steps given below to start EnSight. Note that this
operation is a manual connection. EnSight can be set up to perform the connection
automatically. See How To Connect Automatically (Help > How To Manual ...) for
details.

In the instructions that follow, CLI ENT_HOST refers to the system on which the EnSight
Client was installed and SERVER_HOST refers to the system on which the